Kopete freezes when previewing LaTeX

Bug #183989 reported by tmp on 2008-01-18
34
Affects Status Importance Assigned to Milestone
Kopete
Fix Released
Medium
kdenetwork (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: kopete

How to reproduce:
  1) Write some LaTeX code, e.g.
          $$\sum_{i=1}^{10} \frac{1}{x^i}$$
  2) Press CTRL-L in order to preview it
  3) Kopete freezes

Philip Rodrigues (phil-kde) wrote :

See https://bugs.kde.org/show_bug.cgi?id=135997 . It's debatable whether it's a kde or a kubuntu bug, but the easiest solution would just be to replace /bin/sh with /bin/bash in the kubuntu version of kopete_latexconvert.sh

added upstream bug

Changed in kopete:
status: Unknown → New
Changed in kopete:
status: New → Fix Released
Milian Wolff (milianw) wrote :

fixed upstream, could someone backport it?

see: http://bugs.kde.org/show_bug.cgi?id=135997 and http://websvn.kde.org/?view=rev&revision=799199

from the kde 4.0.4 changelog:
"Fix the latex script for dash based systems (like *buntu). Fixes bug 135997. See SVN commit 799199."

And since this only changes the shell script this fix should be valid for kde 3.5.9 as well.

Yuriy Kozlov (yuriy-kozlov) wrote :
Changed in kopete:
status: New → In Progress
Jonathan Riddell (jr) wrote :

uploaded to hardy-proposed, waiting for approval.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in kdenetwork:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Is this an issue with KDE4? If not, the intrepid task ought to be set to "invalid", otherwise this needs to get fixed in Intrepid ASAP.

Changed in kdenetwork:
assignee: nobody → jr

I can confirm that the version in hardy-proposed 4:3.5.9-0ubuntu1.1 fixes the problem.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in kdenetwork:
status: Fix Committed → Fix Released
Yuriy Kozlov (yuriy-kozlov) wrote :

Invalid for intrepid since this fix was backported from KDE 4.0.

Changed in kdenetwork:
assignee: jr → nobody
status: In Progress → Invalid
Changed in kopete:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.