[KDE 4] Kopete-KDE4 does not shows any contact avatar (in the msn and yahoo protocols)

Bug #183390 reported by Joshua Dunamis on 2008-01-16
14
Affects Status Importance Assigned to Milestone
KDE Network
Fix Released
Medium
kdenetwork (Ubuntu)
Low
Unassigned

Bug Description

I upgraded kopete-kde4 to version 4:4.0.0-0ubuntu3~gutsy1~ppa1. When I select "Show the contact photo if possible", in MSN and Yahoo protocols not appears any contact avatar.

Federico (81joe81) wrote :

...but for which protocols does it happen? And have you set the related option in the settings -> contact list menu?
I'm using version 4:4.0.0-0ubuntu3~gutsy1~ppa1 and the Jabber protocol (with a gmail account) and I am able to see my contacts photos.

Harald Sitter (apachelogger) wrote :

Works for me as well.

Changed in kdenetwork-kde4:
status: New → Incomplete
Joshua Dunamis (dunamis) wrote :

Yes I selected in the settings to show the contacts photo if exists but both in the msn and yahoo protocol no photo is showed.

Joshua Dunamis (dunamis) wrote :

Does it works only with jabber protocol?

description: updated
Changed in kdenetwork-kde4:
status: Incomplete → Confirmed
Joshua Dunamis (dunamis) on 2008-01-16
Changed in kdenetwork-kde4:
status: Confirmed → New
Joshua Dunamis (dunamis) wrote :

I'm changing every thing in the settings -> Contacts list but I cannot see any contact photo. I can see only my photo in the state bar of kopete.

Changed in kdenetwork-kde4:
status: New → Confirmed
Joshua Dunamis (dunamis) on 2008-01-16
Changed in kdenetwork-kde4:
status: Confirmed → New
anonym (launch-mailinator) wrote :

For jabber and jabber/gmail works but for Msn the avatar does not apears.

Joshua Dunamis (dunamis) wrote :

Thanks Anoyn to confirm the problem. I hope someone is able to solve directly or indirectly this bug, at least giving an expleination!!!

Changed in kdenetwork-kde4:
status: New → Confirmed
Joshua Dunamis (dunamis) on 2008-01-18
description: updated
description: updated
Joshua Dunamis (dunamis) on 2008-01-20
Changed in kdenetwork-kde4:
status: Confirmed → New

I can confirm this bug with MSN protocol.
It doesn't display the pictures of my contacts and
it doesn't send out my personal avatar to my contacts
It's still present in kopete 0.50.1 (KDE 4.0.1)

Changed in kdenetwork-kde4:
status: New → Confirmed
Joshua Dunamis (dunamis) wrote :

I can confirm this bug in kopete 0.50.1 in KDE 4.0.1 a Fabio Puddu

I can confirm that it works well with Jabber protocol but the avatars doesn't appear for MSN protocol.

Fabio Puddu (fabius) wrote :

This bug should have been fixed with kde commit 775453.
fix is released in version 0.50.1 using kde 4.0.2
in my hands it seems to work OK with msn protocol;
i think we need to have some confirm/feedback on the yahoo plugin before marking as fix commited

Joshua Dunamis (dunamis) wrote :

Yes in the msn protocol it seems work, not for all contacts. In the yahoo protocol it not still seems to work.

talentus (talentus) wrote :

It still doesn't work for me with the MSN protocol in version 0.50.1 using KDE 4.0.2.

talentus (talentus) wrote :

After more in depth experiments, it appears that avatars appear only for a small part of my contacts using MSN protocol. So the bug is not totally fixed.

Using Kopete 0.50.1, KDE 4.0.3, of Kubuntu 8.04 beta (installed yesterday, and up to date), I do not see the avatars of any of my contacts in the contact list or in the chat window - so, still not fixed for me.

Re my previous comment, I should have said that all my contacts are MSN Messenger, no other systems.

Harald Sitter (apachelogger) wrote :

Someone please search/create a bug on http://bugs.kde.org so that this issue can be fixed in KDE, thank you :)

Changed in kdenetwork-kde4:
importance: Undecided → Low
talentus (talentus) wrote :

This bug could have been reported as bug 146118 on KDE bug tracker.
See https://bugs.kde.org/show_bug.cgi?id=146118 for confirmation.

Harald Sitter (apachelogger) wrote :

Thank you talentus.

Changed in kdenetwork:
status: New → Unknown
Changed in kdenetwork:
status: Unknown → Confirmed
flaccid (chris-xhost) wrote :

I confirm this as well. This should be a high priority, it really removes the useability away from demanding IM users.

Ivo Mans (ivomans) wrote :

Just installed the 4.1 release, but problem still same Yahoo and MSN.
In KDE3 version of kopete the contact photo's are shown properly for these users.

Jonathan Thomas (echidnaman) wrote :

In Intrepid kdenetwork-kde4 lives in kdenetwork.

Changed in kdenetwork:
status: Confirmed → Triaged
description: updated
Changed in kdenetwork:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Fix committed upstream for KDE 4.2.1.

Changed in kdenetwork:
milestone: none → jaunty-alpha-5
status: Triaged → Fix Committed
Jonathan Thomas (echidnaman) wrote :

This bug was fixed in the package kdenetwork - 4:4.2.1-0ubuntu1

---------------
kdenetwork (4:4.2.1-0ubuntu1) jaunty; urgency=low

  * New upstream release
  * Update build-deps (kdepimlibs5-dev, libphonon-dev, libplasma-dev)
  * Update install files (replace 4.2.0 w/ 4.2.*)
  * Update kdenetwork-dev dep (kdebase-dev >= 4:4.2.1)
  * Update depends on kdenetwork-dev (${shlibs:Depends})

 -- <email address hidden> (Roderick B. Greening) Fri, 27 Feb 2009 13:39:18 -0330

Changed in kdenetwork:
status: Fix Committed → Fix Released
Michael Coo (augustuslogos) wrote :

I did remember this one being fixed in KDE 4.2, but now the yahoo protocol has no buddy avatars again...I'm using Kubuntu Lucid..I think this is broken in KDE 4.3 as well...i've been using pidgin ever since it got broken again..

Changed in kdenetwork:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.