Ubuntu

Kmix volume control don't work with OSS-linux

Reported by Sergei Andreev on 2007-07-04
8
Affects Status Importance Assigned to Milestone
KDE Multimedia
Fix Released
Wishlist
kdemultimedia (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kmix

I'm using M-audio Revolution 5.1 in kubuntu 8.04, kde 3.5.9

Because of alsa bug:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1754

I had to switch to OSS sound driver oss-linux_v4.0-1006_i386).

First, Kmix didn't start automatically.

After launching it manualy all sliders are at their maximum and what ever I do they are always return to maximum.

So, how can I make Kmix to work in a proper way?

Sergei Andreev (seajey) wrote :

There is a patch to add OSS4 support for kmix-3.5.9:
http://development.yoper.com/build/yoper-3.1-apriori/patches/kmix/3.5.9

Some discussion about it is hear:
http://www.4front-tech.com/forum/viewtopic.php?t=2584

Daniel Letzeisen (dtl131) wrote :

Is there any update to this? We have many new users converting to OSS4 because of the X-fi, but lots of other high-end sound card owners and even onboard HD audio as well). Please include the patch in an update through Adept/Synaptic/apt. Thank you.

Daniel Letzeisen (dtl131) wrote :

It appears jr is the kdemultimedia maintainer.

Changed in kdemultimedia:
assignee: nobody → jr
Sergei Andreev (seajey) on 2008-07-08
description: updated
Sergei Andreev (seajey) on 2008-07-08
description: updated
Yuriy Kozlov (yuriy-kozlov) wrote :

This looks like a significant feature addition and probably can't be included as an update to Hardy at this point.

Please bring up the issue and the patch on the kde-devel mailing list, and file a wishlist bug on bugs.kde.org to get this included in KDE4.

Daniel Letzeisen (dtl131) wrote :

Thank you, Yuriy. I have filed the bug on bugs.kde.org
https://bugs.kde.org/show_bug.cgi?id=166591

Changed in kdemultimedia:
assignee: jr → nobody
importance: Undecided → Wishlist
status: New → Triaged
Changed in kdemultimedia:
status: Unknown → New
Changed in kdemultimedia:
status: New → Confirmed
Sergei Andreev (seajey) wrote :

It seems that bug https://bugs.kde.org/show_bug.cgi?id=166591 is fixed.
Upgraded to kmix 2.6.1 (KDE 3.5.10) - there is no any mixer to choose, see attached screenshot.

dpkg-reconfigure linux-sound-base and activating Sound System from Kcontrol didn't helped.

Jonathan Thomas (echidnaman) wrote :

Seeing as this is a wishlist item and that we don't really currently have the resources in Kubuntu to implement this, I am closing this bug here. If and when the KDE Multimedia team implements this feature, we will pick it up in the next Kubuntu release. In the meantime you can track this feature request at http://bugs.kde.org/show_bug.cgi?id=166591 . Thanks for understanding.

Changed in kdemultimedia (Ubuntu):
status: Triaged → Won't Fix
Changed in kdemultimedia:
status: Confirmed → Fix Released
Changed in kdemultimedia:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.