KDE applications mix translations in menus

Bug #42323 reported by jeroenl
42
Affects Status Importance Assigned to Milestone
kdelibs (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Using up-to-date kubuntu dapper in Dutch:

Since a few days the menu's are mixed Dutch/English. Especialy the menubar itself is for a large part in English. The different menu's also have some English words in it, but only a few.

Revision history for this message
Anthony Mercatante (tonio) wrote :

I have the same problem in french...

Heard that was due to kde import in Rosetta...

Revision history for this message
Krzysztof Lichota (krzysiek-launchpad-ubuntu-com) wrote :

Polish too.

Revision history for this message
Jonathan Riddell (jr) wrote :

I've uploaded a version of kdelibs that should fix kdelibs.pot to include the strings it was missing. We'll need to wait for new language packs to be made before this will show.

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

Same thing here with French

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

Since this bug seems to apply to various languages other than Ducth, should it be renamed or reopened under a new name and linked to a more "general" package than "kde-18n-nl" which is the Dutch language package?

Revision history for this message
jeroenl (jeroenl) wrote :

As requested. Hopefully it is the right package.

Revision history for this message
Jonathan Riddell (jr) wrote :

Fix is uploaded but needs new language packs to be made from rosetta.

Changed in kdelibs:
status: Unconfirmed → Fix Committed
Revision history for this message
jeroenl (jeroenl) wrote :

Allthough I see updated language packages when I upgrade, this bug isn't yet resolved. I still see english words instead of Dutch, like Bookmarks instead of Bladwijzers.

Hopefully this will be resolved asap.

Revision history for this message
Anthony Mercatante (tonio) wrote :

I discussed with Jonathan, and it appears the fix wasn't complete.
Next update in language packs "should" resolve the problem.

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

Today's dist-upgrade have fixed the problem for me. My menus are now completely translated.

Revision history for this message
Raphaël Pinson (raphink) wrote :

Fixed in French aswell since a few days ago (apart from Affichage/Split View in Konqueror which seems to have not been translated again).

Marking as fix released.

Changed in kdelibs:
status: Fix Committed → Fix Released
Revision history for this message
jeroenl (jeroenl) wrote :

Yes this is fixed. Great!!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers