KDE3 libthai dynamic loading unneccessarily requires libtool archive file

Bug #190371 reported by Pattara Kiatisevi on 2008-02-09
6
Affects Status Importance Assigned to Milestone
kdelibs (Debian)
Fix Released
Unknown
kdelibs (Ubuntu)
Undecided
Unassigned

Bug Description

KHTML makes use of libthai (http://sourceforge.net/projects/libthai) in identifying possible word breaking positions in Thai text (as Thai has no space as word boundaries) (Ref: khtml/rendering/break_lines.cpp). There are two methods to link libthai: explicit linking (configure --enable-libthai) or dynamic loading using KLibLoader.

In Debian/Ubuntu KHTML+libthai has been working fine through the dynamic loading method. However KLibLoader requires libtool archive file to work (that is, libthai.la), therefore users must install libthai0 and libthai-dev in order to have KHTML rendered Thai text properly, which is somewhat strange, but at least working.

But in the recent versions of libthai (0.1.9-1), this libthai.la file was removed, (Ref: http://changelogs.ubuntu.com/changelogs/pool/main/libt/libthai/libthai_0.1.9-1/changelog).

Hence, Thai word breaking in KDE/KHTML is not working anymore.

Possible solutions:
1) explicitly link libthai into kdelibs (i.e., make kdelibs depend on libthai0)
2) fix the khtml code to NOT require libthai.la (which actually makes sense). One solution is to use QLibrary instead of KLibLoader.
The patch will be attached (or online accessible at:
http://linux.thai.net/viewvc/viewvc.cgi/software/kde/kdelibs-3.5.6/kdelibs-3_5_6-thai-break-qlibrary-instead-of-klibloader.patch.txt?view=log)

For 2) we did send the patch to the kde-devel list since September 2007. And the answers were:

"This is a Debian specific packaging bug. Many distributions are still shipping libtool archive files. Please contact the packagers of KDE for Debian via http://bugs.debian.org/. "
( http://lists.kde.org/?l=kde-devel&m=119104527320060&w=2 )

"it's a distro bug if they make KDE 3 stop working -- it's been working for years like that.:"
( http://lists.kde.org/?l=kde-devel&m=119105494901329&w=2

So, we filed the bug at Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=444284 and so far the problem hasn't been fixed yet.

The problem exists in Ubuntu too so I'd like to report it here and hope that it will be fixed as soon as possible. Solution 1) or 2) is both OK. Thank you very much in advance.

Daniel Holbach (dholbach) wrote :

To get your fix included in Ubuntu, it would help if you tried transforming it into a debdiff (http://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff) and submit it for review (http://wiki.ubuntu.com/SponsorshipProcess). If you prefer somebody else to do that, that's fine - please just indicate if you're available to do that.

Yuriy Kozlov (yuriy-kozlov) wrote :

Pattara, any progress on this?
Thanks for working on it.

Changed in kdelibs:
status: Unknown → New
Pattara Kiatisevi (pattara-mm) wrote :

Thanks for your message and sorry for the delay. I really wanted to work on this but time hasn't allowed so far.

Would someone lend me a hand on this?

Yuriy Kozlov (yuriy-kozlov) wrote :

You can come to #kubuntu-devel and ask for help. Note that at this point this needs to be tested/investigated and, if needed, fixed in KDE4. I'm not sure if it can still be fixed in Hardy/KDE3.

Pattara Kiatisevi (pattara-mm) wrote :

As far as I know KDE4 doesn't have problem as KLibLoader in KDE4 does
not use libtool files.

However KDE4/Qt4 has other problems with Thai, which make it difficult
to say that Thai language is supported in KDE4.

Patches to fix those problems are gathered here:
http://www.suriyan.in.th/development . We did send them to Qt developers
and post to http://bugs.kde.org:

https://bugs.kde.org/show_bug.cgi?id=156558 (libthai dynamic loading)
https://bugs.kde.org/show_bug.cgi?id=156561 (Kate issues)
http://bugs.kde.org/show_bug.cgi?id=156071 (Konsole issues)

Qt4 patches are at
http://linux.thai.net/viewvc/viewvc.cgi/software/qt/x11-free-4.3.1/.

Is it better to file the bug here in Launchpad and hope that maybe the
changes get propagated to upstream somehow?

Advice are very welcome.

Pattara

Yuriy Kozlov wrote:
> You can come to #kubuntu-devel and ask for help. Note that at this
> point this needs to be tested/investigated and, if needed, fixed in
> KDE4. I'm not sure if it can still be fixed in Hardy/KDE3.
>
>

Daniel T Chen (crimsun) on 2008-11-28
Changed in kdelibs:
status: New → Confirmed
Changed in kdelibs (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.