KIO FTP is shortening the URL

Bug #162233 reported by toms on 2007-11-12
12
Affects Status Importance Assigned to Milestone
krusader
Fix Released
Medium
kdelibs (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned
Hardy
High
Unassigned

Bug Description

Version: Stable Kubuntu (Gutsy Gibon) x86/amd64, reproduced on both platforms (I have notebook/x86 and my desktop as amd64 both running stable kubuntu).

Packages with bug:
This bug has been found in every package, which is using KIO-ftp://

Describtion:
When I'm using long FTP username, KIO FTP is shortening it. Ex: <email address hidden> (as username to FTP) is shorten to toms%40l...oft.sk and that is not correct because toms@l...oft.sk is not the right username. So, I can't work with FTP anymore! I have to close the window which has made the FTP connection (konqueror, krusader etc) and I have to connect again (->open window, type URL, type username&pass, then It works for sometime).

I put 2 screenshots which are describing my problem better
http://www.linuxsoft.sk/kiobug/KIO1.png
http://www.linuxsoft.sk/kiobug/KIO2.png (as you can see, I'm not even able to change the username. )

Thank you for fixing this bug as fast as possible.

Tomas Srnka

This bug seems to be equivalent to this one reported (and solved) at bugs.kde.org:
<https://bugs.kde.org/show_bug.cgi?id=150973>
I would also appreciate a quick solution in 7.10 because krusader is my favourite FTP tool!
Carsten

Frode M. Døving (frode) wrote :

Needs priority.

Frode M. Døving (frode) wrote :

debdiff from kdelibs_3.5.8-0ubuntu3.1

Frode M. Døving (frode) wrote :

diffstat to the previous debdiff.

Changed in krusader:
status: Unknown → Fix Released
Jonathan Riddell (jr) wrote :

Uploaded to -proposed

Changed in kdelibs:
status: Confirmed → Fix Committed
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test.

Please get this uploaded into hardy ASAP.

gripped (lee-r-harris) wrote :

Sorry if this is a stupid question but how do I get it to test ?

I have added proposed in the settings of adept and other packages now show as upgradable but not kdelibs.

(This bug has been bugging me since Gusty was released.)

Hi,

gripped [2007-12-20 16:52 -0000]:
> Sorry if this is a stupid question but how do I get it to test ?
>
> I have added proposed in the settings of adept and other packages now
> show as upgradable but not kdelibs.

It'll still take some hours until it gets built.

Martin
--
Martin Pitt http://www.piware.de
Ubuntu Developer http://www.ubuntu.com
Debian Developer http://www.debian.org

Jonathan Riddell (jr) wrote :

Fixed in hardy in 4:3.5.8-4ubuntu4

Changed in kdelibs:
status: Fix Committed → Fix Released
gripped (lee-r-harris) wrote :

Fixed for me in gutsy.

I can sftp to my webserver using ssh keys again.

Yay.

Brian Murray (brian-murray) wrote :

I tried recreating this bug using the url 'ftp://<email address hidden>' in konqueror but had no luck. Without a test detailed test case I'm not certain how to recreate this bug.

Martin Pitt (pitti) wrote :

gripped, toms, can you please test the package in gutsy-proposed?

toms (toms-linuxos) wrote :

Ok, will test it this night on my desktop PC.

gripped (lee-r-harris) wrote :

I did I thought ?
Four posts up.

Works and I have encountered no problems but I only use it for sftp.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in kdelibs:
status: Fix Committed → Fix Released
Changed in krusader:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.