ksnapshot doesn't send to gwenview

Bug #730691 reported by nowardev
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Graphics
Fix Released
Medium
kdegraphics (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdegraphics

Take a screenshot
click send to
select what you want for example gwenview
gwenview will load saying could not open the file
on the alpha1 worked
now alpha 3 no

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ksnapshot 4:4.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Mon Mar 7 16:45:59 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101120)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kdegraphics
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
In , 2kmm (2kmm) wrote :

Version: unspecified (using Devel)
OS: Linux

Ksnapshot takes the first screenshot as soon as the program starts. But in KDE SC 4.4.81 if I click 'open with' and select a program from the list, the applications starts and informs me that the file it should show cannot be opened.

The file that is given to the application is in /home/<user>/<lastname>.png. If I take a second screenshot the external application gets the file correctly at /tmp/kde-<user>/<lastname>.png

Reproducible: Always

Revision history for this message
In , Alexey Shildyakov (ashl1future) wrote :

Cannot confirm this. Use Gwenview to 'open with'.
KDE 4.4.3

Revision history for this message
In , Burkhard Lück (lueck) wrote :

(In reply to comment #1)
> Cannot confirm this. Use Gwenview to 'open with'.
> KDE 4.4.3

This is not about 4.4.3 but a BR for 4.4.81 (trunk, soon 4.5)

I can confirm this bug with recent trunk compiled from sources.
trunk r1109164-1 does not have this bug.
So it looks to me like a regression introduced with the fix r1109164 for http://bugs.kde.org/show_bug.cgi?id=204628, therefore cc'ing the committer

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 241526 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 249820 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Debfx-kde (debfx-kde) wrote :

*** Bug 244587 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 252111 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 251855 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Jospoortvliet (jospoortvliet) wrote :

Version: 0.7.1 (using KDE 4.5.80)
OS: Linux

First of all, awesome work on the ksnapshot UI. Much better ;-)

I can imagine the average user missing a big 'close' button but considering that eg ESC and the window close button both work just fine there is imho no issue.

So the problem. Simple. hit prtscrn and choose "send to". The apps don't work (gwenview tells me it can't find the image).

The KIPI export plugins (i guess that's what it is isn't it?) seem to have the same issue - I only tried the "export to HTML one" (quite awesome btw, altough not exactly relevant for 1 picture) but it also didn't show any actual picture.

Even after saving the file it doesn't work - save as 'test.png', then observe Gwenview telling you it can't open 'test1.png'.

Reproducible: Always

Steps to Reproduce:
Hit Prt Sc key. Click "Send to". Choose random menu option and observe failure.

Actual Results:
failure (app or service can't find picture)

Expected Results:
success (app or service displays/submits/works with picture)

OS: Linux (x86_64) release 2.6.37-rc3-git6-9-desktop
Compiler: gcc

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

[Comment from a bug triager]
I can confirm this bug on KDE SC 4.6 beta2 on ArchLinux (but it works properly on KDE SC 4.5.4)

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

*** Bug 259466 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Janjabber (janjabber) wrote :

I can reproduce it in 4.6b2 under Archlinux, and 4.5.2 under Mandriva.

Revision history for this message
In , Alexey Shildyakov (ashl1future) wrote :

Think the duplicate of bug 240051

Revision history for this message
In , Dario Andres (andresbajotierra) wrote :

[Comment from a bug triager]
In fact, it is very related but I don't know if the behaviour is exactly the same.
Just checked again with KDE SC 4.6beta1
1) KSnapshot starts, first screenshot is taken, Send To menu options doesn't work
2) A second screenshots is taken, the Send To menu options work!
3) The second screenshot is saved to a file, the proposed filename in the KSnapshot window titlebar changes again, the Send To menu options doesn't work ...
(I don't know if bug 240051 included this cases as well...)

Regards

Revision history for this message
In , Thomas Tanghus (tanghus) wrote :

Confirmed on Kubuntu 10.10 KDE SC 4.5.90 (4.6 RC1).

If you take a snapshot you can share it on facebook _if you don't save it first_
Otherwise KSnapshot increments the numbering of the filename which points to a non-existing file.

Besides that: Great UI and potentially great sharing possibility.

Revision history for this message
In , Pau Garcia Quiles (pgquiles) wrote :

See this thread for my acknoledgement of the problem, a possible fix, and rejection of the fix by one of the maintainers of KSnapshot:

http://thread.gmane.org/gmane.comp.kde.devel.graphics/119

Revision history for this message
In , Thomas Tanghus (tanghus) wrote :

(In reply to comment #7)
> See this thread for my acknoledgement of the problem, a possible fix, and
> rejection of the fix by one of the maintainers of KSnapshot:
>
> http://thread.gmane.org/gmane.comp.kde.devel.graphics/119

That was long ;-)

My 0.02 €:

- When starting KSnapshot it should take a snapshot, create a tempory file under /tmp, show "New Snapshot" or something in the title bar. KSnapshot could/should delete any unused temporary files on exit.

- When the user clicks "Save As..." it should suggest the last used name incremented by 1.

- When the user chooses to "Send to" a different program or plugin it should be passed the temporary file. I don't know if there's a way to notify the opening application that it's a temporary file, but I see it as the responsibility of the external application - not KSnapshot - to determine the action taken when saving the image. At least on Linux/*nix it's just checking whether it's under /tmp and then suggest another location.

Revision history for this message
In , Jospoortvliet (jospoortvliet) wrote :

@Pau
While that thread did end up with something usable (the [modified] behind the filename instead of showing unsaved should solve the issue there) one of the things you mentioned, the issue we talk about here (send to not working) was not discussed. Because Aaron got carried away with the other item. Looks like he had a bad day there ;-)

I think you mentioned 2 different issues and only 1 of them got addressed. Nobody responded to your first issue:
 - The behavior when you open KSnapshot (a snapshot is taken but it's
not available to Send To... actions)
(eg this bug)

I hope Aaron can look at that at least ;-)

Revision history for this message
In , Pau Garcia Quiles (pgquiles) wrote :

@Jos

Send to... does not work because the first snapshot taken when you start KSnapshot is not saved.

I have seen an even trickier consequence of the (IMHO, wrong) saving workflow KSnapshot currently uses: you take a snapshot, but when you do Send to..., the file which is used (opened) is actually the snapshot *before* the last one.

Revision history for this message
In , Pau Garcia Quiles (pgquiles) wrote :

I'm currently busy with Christmas and porting KSnapshot to Windows. If noone has provided a solution when I'm done with that (in a week or so), I'll work on a solution to the root cause of this bug.

It'll be a variation of what I proposed in the thread I linked above. I think this variation would be acceptable to Aaron because it will unconditionally save the file to the last-used directory (no guessing of temporary vs definitive) and won't automatically show a dialog.

IIRC there are more bugs against KSnapshot which are caused by the saving flow.

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 264714 has been marked as a duplicate of this bug. ***

Revision history for this message
In , BadBoy (sklep-szybkieczytanie) wrote :

Same here. Just cannot open any screenshot directly in any application. All I can do is save it to disk and then open it manually. It has been this way since the beginning of my adventure with Kubuntu (10.04).

Revision history for this message
In , styx (blprince) wrote :

Created attachment 57319
Sets new snapshots to modified so it is saved temporarily.

Revision history for this message
In , styx (blprince) wrote :

One line to rule them all :D

Revision history for this message
In , styx (blprince) wrote :

I added a Patch to fix this.

Revision history for this message
In , Jospoortvliet (jospoortvliet) wrote :

This bug has been fixed in KSnapshot 0.8.2 (part of KDE Applications 4.6.0 or is this part of workspace?)

Revision history for this message
nowardev (nowardev) wrote :
Revision history for this message
In , Pau Garcia Quiles (pgquiles) wrote :

(In reply to comment #14)
> I added a Patch to fix this.

You patch only fixes this bug for the first time.

Steps to reproduce after applying your patch:

1. Open KSnapshot
2. Send to -> KolourPaint. Screenshot is there. Great!
3. Close KolourPaint, go back to KSnapshot
4. Save As...
5. Take new snapshot
6. Send to -> KolourPaint.

Expected: screenshot is in KolourPaint

Actual result: KolourPaint shows a white rectangle

I have applied your patch because it's better than nothing, but it's not THE fix.

(Sorry for taking so long to answer, I have been very busy lately)

Jos: not, this is not fixed yet. I don't know why this bug was marked as FIXED.

Revision history for this message
In , Kourilj24 (kourilj24) wrote :

I can confirm this, it doesn't work for quite some time for me, it's beggining to annoy me.

Revision history for this message
In , BajK (kaiuwebroulik2) wrote :

Can anybody test if this bug also affects Kipi plugins, especially Kopete plug in? So, does it work to send the first screenshot taken directly to a Kopete contact using its kipi plugin? I think not?

Revision history for this message
In , Kourilj24 (kourilj24) wrote :

Surely someone can, but I'm not using kopete.

2011/3/10 <email address hidden>

> https://bugs.kde.org/show_bug.cgi?id=240051
>
>
>
>
>
> --- Comment #11 from <KaiUweBroulik2 hotmail com> 2011-03-10 16:54:01 ---
> Can anybody test if this bug also affects Kipi plugins, especially Kopete
> plug
> in? So, does it work to send the first screenshot taken directly to a
> Kopete
> contact using its kipi plugin? I think not?
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>

Revision history for this message
In , Tomasz Kane (tomaszkane) wrote :

I confirm this on Kubuntu 10.10 KDE 4.6.1

When I choose "Sent to" -> GIMP, gimp says:

GIMP Message
Opening '/home/kane/Obrazy/tmp/qq2.png' failed: Could not open '/home/kane/Obrazy/tmp/qq2.png' for reading: Nie ma takiego pliku ani katalogu

Revision history for this message
In , BajK (kaiuwebroulik2) wrote :

Did you set this weird path to tmp files or is this generated by ksnapshot? Since ~/Documents(?)/tmp is a bit unusual?

Revision history for this message
In , Kourilj24 (kourilj24) wrote :

Well, I didn't set anything about tmp files. I would expect ksnapshot to
save printscreen to /tmp/snapshot.png or to /tmp/ksnapshot/snapshot.png,
from where it can be passed to gimp or whatever else. Instead of this
~/downloads/snapshot.png is passed to gimp, but nothing is saved there, so
gimp can't open it.

2011/3/11 <email address hidden>

> https://bugs.kde.org/show_bug.cgi?id=240051
>
>
>
>
>
> --- Comment #14 from <KaiUweBroulik2 hotmail com> 2011-03-11 10:04:14 ---
> Did you set this weird path to tmp files or is this generated by ksnapshot?
> Since ~/Documents(?)/tmp is a bit unusual?
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>

Revision history for this message
In , Pau Garcia Quiles (pgquiles) wrote :
Revision history for this message
In , Ea0 (ea0) wrote :

Same here, on opensuse11.4 (kde4.6). I had same on opensuse11.3 (kde 4.4)

Revision history for this message
DAP (darkness) wrote :

I have the same bug from default KDE version in maverick to KDE 4.6.1 from ppa.

Revision history for this message
Maarten Bezemer (veger) wrote :

Same bug in maverick KDE 4.5.1 as well

Changed in kdegraphics (Ubuntu):
status: New → Confirmed
Changed in kdegraphics:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Maarten Bezemer (veger) wrote :

I confirm this on Kubuntu 10.10 KDE 4.5.1

Bug is also on LP #730691: https://bugs.launchpad.net/ubuntu/+source/kdegraphics/+bug/730691

Revision history for this message
In , Stecue (stecue) wrote :

(In reply to comment #17)
> I confirm this on Kubuntu 10.10 KDE 4.5.1
>
> Bug is also on LP #730691:
> https://bugs.launchpad.net/ubuntu/+source/kdegraphics/+bug/730691
I confirm this on openSUSE 11.3/11.4 since KDE 4.5. This is really annoying.

Revision history for this message
In , nadavkav (nadavkav) wrote :

I can confirm this bug on Kubuntu (11.04) with KDE 4.6.2

Revision history for this message
In , sanette (sanette-linux) wrote :

I confirm too, on kubuntu 11.04 with a fresh ksnapshotrc

What annoys me is that I'm sure it is very easy to solve !

it made me smile too:

first I press "Print Screen" and then click on "send to gimp", it tells me
"screenshot1.png" not found.

So I click on "save" -> it saves "screenshot1.png"

and now I click again on "send to gimp", and it tells me
"screenshot2.png" non found !

nice isn't it ? ;)

Revision history for this message
DAP (darkness) wrote :

I have this bug in 11.04 with KDE 4.6.3 from ppa.

Revision history for this message
In , BajK (kaiuwebroulik2) wrote :

Seems fixed on 4.7. I press the PrintScreen key, KSnapshot pops up, I choose “Open with” Gimp or Kolourpaint or Gwenview and it works just fine.

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 274536 has been marked as a duplicate of this bug. ***

Revision history for this message
In , 2kmm (2kmm) wrote :

Jea, open the first snapshot works if you NOT save it. If you save it, it won't work until you take a new one (as long as you not save this too). So the case switched from 'first screenshot only opens if it was saved' to 'all screenshots only open if they were not saved'.

Revision history for this message
In , Bugs-kde-org3 (bugs-kde-org3) wrote :

Comment #22

Unfortunately it does not work like this. Using:

KSnapshot
Version 0.8.2
Using KDE Development Platform 4.6.4 (4.6.4)

-

GIMP Message
Opening '/home/hyper/Desktop/Screenshot1.png' failed: Could not open '/home/hyper/Desktop/Screenshot.png' for reading: No such file or directory

-

(1) I did press the screenshot button
(2) I chose from the KSnapshot menu to open with GIMP
(3) I did not switch programs while GIMP was loading
(4) I did get the above error

Revision history for this message
In , 2kmm (2kmm) wrote :

(In reply to comment #23)

I was talking about 4.6.80 (4.7 beta 1).

Revision history for this message
In , Jaanus-ojangu (jaanus-ojangu) wrote :

Same problem in KSnapshot Version 0.8.2 in Mageia.

Revision history for this message
In , Victor (blindvic) wrote :

Created attachment 61267
The same here

I didn't notice that it doesn't open just the first screenshot.
Sometimes it opens even first screenshot successfully.
I tried to run the ksnapshot from konsole to see any error messages - not there. But the KolourPaint has the right file name - but blank file. Looks like knapshot is trying to call external program to open the screenshot, but it's not saved yet to the disk...

Revision history for this message
In , Mprizee (mprizee) wrote :

I have the same bug, excepting that the second (or third...) snapshot does not work better. I try to send the picture to Facebook (album Wall Photos).

The first snapshot, the name is the same as the last saved file and the thumbnail cannot be displayed.
The second (third..) still displays the old name but can show the thumbnail of the snapshot.

Should I open a new bug ?

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 280863 has been marked as a duplicate of this bug. ***

Revision history for this message
DAP (darkness) wrote :

Fixed in KDE 4.7

Revision history for this message
In , Christoph-maxiom (christoph-maxiom) wrote :

*** Bug 282708 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Cyberbeat-p (cyberbeat-p) wrote :

I have a similar problem:

1) press print-screen to take snapshot with ksnapshot
2) press "save.." to save file as "myfilename.png"
3) press "send to.." gimp:

error: gimp cannot open file "myfilename1.png"

so ksnapshot sends a name to gimp which does not exist yet

Revision history for this message
In , Bugs-kde-org3 (bugs-kde-org3) wrote :

I'm running meanwhile

Qt: 4.7.4
KDE Development Platform: 4.7.1 (4.7.1)

and it works there now. I make a screenshot, and in ksnapshot tell it to open with gimp - works just fine.

Revision history for this message
In , 2kmm (2kmm) wrote :

(In reply to comment #30)
> I'm running meanwhile
>
> Qt: 4.7.4
> KDE Development Platform: 4.7.1 (4.7.1)
>
> and it works there now. I make a screenshot, and in ksnapshot tell it to open
> with gimp - works just fine.

The original bug is fixed, yes. But what comment #29 describes is that he opens the snapshot AFTER saving it. And this does not work anymore.

Revision history for this message
In , Cyberbeat-p (cyberbeat-p) wrote :

right, and I have to add to my comment #29 that this problem still persists in kde-4.7.1

Revision history for this message
In , Bugs-kde-org3 (bugs-kde-org3) wrote :

Yes, the problem in #29 still exists in KDE 4.7.1

Revision history for this message
In , Roger Pixley (skreech2) wrote :

So I can confirm that saving the file initiates AutoIncrementing the name which makes the send to file less useful.

To outline the steps.

1) Take a screenshot with Ksnapshot and instantly use the sendto menu.

Results: Correctly sends the temporary image file to the resource.

2) Use the Save As to save the file as some unique name and then use the sendto menu to try open the file.

Results: Send to passes along the unique name with an incremented number at the end which has no temporary file or corresponding existing file which produces an error.

Workarounds: If opening an application that you can edit or save with then use sendto first then save from the application or save afterwards. Else just use sendto before saving.

I don't have any good solutions to this problem since in all other cases you would like ksnapshot to autoincrement your file as soon as you've saved. A temporary code workaround might be (as suggested by richmoore) having a recent files menu that could use the sendto from older files though a much more stable workaround would be to allow programs to pass along resources instead of saved files. That has some issues as well but it's much more flexible and would at least work as intended (with the exception of final file name)

Revision history for this message
In , Maarten Bezemer (veger) wrote :

It seems to be fixed in KDE 4.7.3

Changed in kdegraphics (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Maarten Bezemer (veger) wrote :

It is fixed for me in KDE 4.7.3

Revision history for this message
In , sanette (sanette-linux) wrote :

(In reply to comment #35)
> It seems to be fixed in KDE 4.7.3

I agree, even in 4.7.2 it works for me now

Revision history for this message
In , Jospoortvliet (jospoortvliet) wrote :

Unfortunately I can still reproduce this on Plasma Workspace 4.7.3 (KSnapshot 0.8.2).

Revision history for this message
In , Rafael Belmonte (eaglescreen) wrote :

I also think this is fixed, in my case, cheked in KDE 4.9.2.
Please, close this bug.

Revision history for this message
In , adaptee (adaptee) wrote :

Can't reproduce using KDE SC 4.10, either. Close it based upon recent comments.

Changed in kdegraphics:
status: Confirmed → Fix Released
Revision history for this message
nowardev (nowardev) wrote :

yes it's fixed :)
kubuntu 12.10

Revision history for this message
In , Kdebug8 (kdebug8) wrote :

I confirm this on KDE 4.10.0

Version 0.8.2

try "send to..." and it crashes everytime.

Please, reopen.

Revision history for this message
In , Kdebug8 (kdebug8) wrote :

Application: KSnapshot (ksnapshot), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6 QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7 0x00007fdb506f3349 in KIPI::Plugin::setUiBaseName (this=0x17e20b0, name=<optimized out>) at ../../libkipi/plugin.cpp:309
#8 0x00007fdb50b84b49 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x17e20b0, parent=0x1592aa0) at /build/buildd/digikam-3.0.0~rc/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9 0x00007fdb50b85057 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007fdb5ffb1251 in KPluginFactory::create (this=0x17b9720, iface=0x7fdb615b9440 "KIPI::Plugin", parentWidget=0x0, parent=0x1592aa0, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#11 0x00007fdb615b1897 in KIPI::PluginLoader::Info::plugin() const () from /usr/lib/libkipi.so.8
#12 0x0000000000417cc8 in _start ()

Revision history for this message
In , adaptee (adaptee) wrote :

(In reply to comment #39)
> I confirm this on KDE 4.10.0
>
> Version 0.8.2
>
> try "send to..." and it crashes everytime.
>
> Please, reopen.

You crash is due to mixing incompatible (kipi-plugin related ) binaries from different repos, which has nothing to do with this issue.

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 317552 has been marked as a duplicate of this bug. ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** This bug has been marked as a duplicate of bug 258431 ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 240051 has been marked as a duplicate of this bug. ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 268712 has been marked as a duplicate of this bug. ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 270310 has been marked as a duplicate of this bug. ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 237353 has been marked as a duplicate of this bug. ***

Revision history for this message
In , De-meyer-maarten (de-meyer-maarten) wrote :

*** Bug 280947 has been marked as a duplicate of this bug. ***

Changed in kdegraphics:
status: Fix Released → Invalid
Revision history for this message
Maarten Bezemer (veger) wrote :

Upstream report got marked as duplicate of this report

Changed in kdegraphics:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in kdegraphics:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
In , Thomas Tanghus (tanghus) wrote :

Kudos to whoever reopened this issue!

Revision history for this message
In , Janet (bugzilla-kerridis) wrote :

Still valid in KDE SC 4.13.4. - increasing the file numbering only should take place after a new screenshot is taken, not after a file is saved.

Revision history for this message
In , aseigo (aseigo) wrote :

Git commit 1e367462a06b3a1a5952554d7706e740d008156e by Aaron Seigo.
Committed on 15/09/2014 at 08:41.
Pushed by aseigo into branch 'frameworks'.

send the last saved snapshot, otherwise save our shot to a temp file

M +2 -2 ksnapshot.cpp

http://commits.kde.org/ksnapshot/1e367462a06b3a1a5952554d7706e740d008156e

Changed in kdegraphics:
status: Confirmed → Fix Released
Revision history for this message
In , Elias Probst (eliasp) wrote :

I can still reproduce this in 'frameworks' although the changes from comment#30 seem to be applied there in ksnapshot.cpp.

→ Open ksnapshot
→ Create a new snapshot
→ Send To…
→ Gwenview

- Loading 'snapshot_TJ9858.png' failed
- Could not open file /home/elias/snapshot_TJ9858.png

The mentioned file doesn't exist in my FS, neither in the mentioned path, nor in /tmp or other possible QDir::tempPath() (used by QTemporaryFile).

Using Qt 5.4.0 beta and ksnapshot 9cce9db7

Changed in kdegraphics:
status: Fix Released → Confirmed
Revision history for this message
In , Jospoortvliet (jospoortvliet) wrote :

With our new screenshot app this is no longer an issue, so - close.

Changed in kdegraphics:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.