kolourpaint can't be installed on jaunty

Bug #365650 reported by grofaty on 2009-04-23
4
Affects Status Importance Assigned to Milestone
kdegraphics (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kolourpaint

Hi,
on freshly installed Ubuntu 9.04 I tried to install kolourpaint (KDE drawing program) and got error (by the way the same program installs fine under Ubuntu 8.10):
=============
$ sudo apt-get install kolourpaint

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kolourpaint: Depends: kolourpaint4 but it is not going to be installed
E: Broken packages

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: kolourpaint None [modified: /var/lib/dpkg/info/kolourpaint.list]
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kdegraphics
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Thomas Kluyver (takluyver) wrote :

kolourpaint is described as a dummy package for transition to kolourpaint4. What happens if you try installing kolourpaint4?

grofaty (grofaty) wrote :

Thomas.
I tried:
sudo apt-get install kolourpaint4
and KolourPaint installed successfully!
But I can still start program in terminal using kolourpaint command. It looks there is some minor bug in dependency. I think installing package kolourpaint, should install package kolourpaint4.

Thanks a lot for help.
Regards

P.S. By the way, I have tried to install this program using terminal, because installing from Add/Remove install window freezed before starting download. Don't know if this is problem of today overloaded servers.

OK, cool. I don't know exactly why apt-get was refusing to do it via
kolourpaint, but the idea is to use the new package name, so it's all OK.

Add/remove (kpackagekit): The servers may have been a bit busy, or it may be
a problem with kpackagekit, I know there are a few. If it does it
consistently, then see if anyone's already filed a bug for it.

pocztapolska (pocztapolska) wrote :

Same problem here... any solutions?

grofaty (grofaty) wrote :

Hi,
kolourpaint package does not exist any more, it has been renamed, so install kolourpaint4 package like:
sudo apt-get install kolourpaint4
Regards

Jonathan Thomas (echidnaman) wrote :

It's not erroring out anymore (at least in 9.10), and it does say that the package has moved to kolourpaint4, so I think we can consider this as fixed.

Changed in kdegraphics (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers