Kpat runs very slowly

Bug #1013664 reported by Christopher Forster on 2012-06-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdegames (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, card animations & movement is very slow. When moving cards, Kpat is running at high (100%) CPU usage.

kpat --version
Qt: 4.8.1
KDE Development Platform: 4.8.3 (4.8.3)
Patiens: 3.6

See also: Kpat launches and runs very slowly http://old.nabble.com/-Bug-265029--New%3A-Kpat-launches-and-runs-very-slowly-td30812311.html

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: kpat 4:4.8.3-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Fri Jun 15 14:48:02 2012
ExecutablePath: /usr/games/kpat
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SourcePackage: kdegames
UpgradeStatus: No upgrade log present (probably fresh install)

My workaround for now, it's possible to run the Windows Solitaire through Wine.

Caution, don't try on production machines without fear of dealing with problems.

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update && sudo apt-get install wine

wine /host/WINDOWS/system32/spider.exe
wine /host/WINDOWS/system32/freecell.exe
wine /host/WINDOWS/system32/sol.exe
wine /host/WINDOWS/system32/mshearts.exe

spider.exe is Spider Solitaire
freecell.exe is FreeCell
sol.exe is Solitaire
mshearts.exe is Hearts

Copy Windows Solitaire to your Linux desktop
cp /host/WINDOWS/system32/spider.exe /home/USERNAME/Desktop && cp /host/WINDOWS/system32/freecell.exe /home/USERNAME/Desktop && cp /host/WINDOWS/system32/sol.exe /home/USERNAME/Desktop && cp /host/WINDOWS/system32/mshearts.exe /home/USERNAME/Desktop && cp /host/WINDOWS/system32/mfc42u.dll /home/USERNAME/Desktop

Jeremy Bicha (jbicha) wrote :

I had a friend who had trouble with Shishen Sho being slow in KDE 4.8.3 and 4.8.4 in Ubuntu 12.04. Updating to KDE 4.9 fixed the problem.

http://www.kubuntu.org/news/kde-sc-4.8.90

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers