Ktouch's "lectures" are hidden away and took a bit of time (and an expert Linux guru) to locate

Bug #72663 reported by bethanyfirem on 2006-11-21
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Educational Applications
Fix Released
Wishlist
kdeedu (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ktouch

After adding this package-which I have used before-KTouch made it a mystery to find and open a lecture in order to begin to learn to type.

It was unclear if I should "start a new session" under the training dropdown or "open a lecture" under the file dropdown.

After complaining to my boyfriend, he took control, dropping to the command line and doing some magic that the average user would not be able to understand. In his words, he issued the command "dpkg -L ktouch" to list all the files in the ktouch package. He discovered some xml files under /usr/share/apps/ktouch which *happened* to be the so-called "lecture" files.

This is way too hard to find.

Update: with KDE4 the path for lesson files is now /usr/share/kde4/apps/ktouch

Version: 1.5 (using KDE 3.5.2 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler: Target: i586-suse-linux
OS: Linux (i686) release 2.6.13-15.8-default

I was looking for a type trainer, so I had a look at ktouch. I found it somewhat difficult to get started with it. maybe you could take the following points in into consideration:

initial start: The first session should be loaded by default.

help manual:
- screenshots unuseable
- very technical
- something like 'how to get it running without reading the instructions' is missing

What the user wants: Open the program, start a training session.
So if the first session is not loaded by default, the file->open dialog should at least point to the right directory (I assume this is /opt/kde3/share/apps/ktouch/).

Now, in there are some *.ktouch.xml files. But the manual decribes that the lession files end on .ktouch -> this should be synchronized

Next the user may ask: So, what file do I have to select? Proposal: create subdirectories per language.

More, comparing it with commercial products, a brief description of what shall be learned in each section/line could also help to find a decision.

There are multiple requests in this issue, so this issue should be broken into multiple issues. (However, I don't have the permissions to do that.)

To add to the part about starting a training session/lecture:
- The File->Open Lecture opens to the home directory, but it should open to a directory where there's a high probability of finding lectures--e.g., /usr/share/apps/ktouch/.
- The File->Open Lecture and Training->Default Lectures should visually be near each other. Maybe you could put the Default Lectures under Open Lecture?

Richard Johnson (nixternal) wrote :

I agree. KTouch is in fact unclear on where and how to really start from a newer users perspective, and even mine at first.

Changed in kdeedu:
importance: Undecided → Low
status: Unconfirmed → Confirmed

What can I do move this bug towards completion?

Specially the "The File->Open Lecture opens to the home directory, ..." annoys me.

Braun said it very clear and synthetic: "What the user wants: Open the program, start a training session."

"Open lecture.." or "default lectures" and "keyboard layouts" are necessary to do this currently. These three are in separate menus, not very intuitively placed or organized.

I thought about an new organization in 4 menus: File (it could also be called "Lecture"), Stats, Settings, Help (names obviously open to be improved) . I don't see an reason for an "file" menu in ktouch. If it is not prohibited, you can exclude this menu and make 4 menus: Lectures, Stats, Settings, Help (names obviously open to be improved). If it is, then call the Lectures menu of File.

* Under the File/Lecture menu go: Open default lecture, Open lecture from a file..., Edit current lecture, Edit lecture from a file... (Instead of "open" the word "load" can be used. I think it is a bit more adequate, but not much difference)
* Under the Stats go: Start new session, Pause session and Lecture Statistics. ("Re-start session" could be an more appropriate name for "Start new session", as far as I perceived how it works, but I can be wrong)
* The settings menu would remain essentially the same, with only the addition of "Edit color scheme.../Custom color scheme..." inside "Color Schemes"
* The help menu remains the same

In addition to that, while we are at improving usability, the lessions and keyboards layouts should be organized in the menus by language, each one with an country flag attached to it. It will be more and more important as the number of keyboard and lessions shipped with the program grow as I hope it will do. So, to select an lesson for me in this new organization I would (hopefully) go: File > Open Default Lecture > Brazilian Portuguese > QUERTY ABNT2 (auto-generated)/br-nativo (defaut lesson)/br-nativo (combo/speed training)/dvorak-br/whatever , for example. The lecture should automatically load the correct keyboard layout, but leave the possibility to the user change this as it is now. I will fill an new bug about this.

As for one point that others said, the "default lectures" already load all lectures at /opt/kde3/share/apps/ktouch/ every time that you restart the program. So it is not necessary to remap "Open lecture..." to it.

PS: By the way, if you will do the language separation thing in the menu, please separate Brazilian Portuguese/Português do Brasil from "Portuguese" that is Portugal's Portuguese. This for keyboard layouts too, because for some reason we have two quite different standarts, with different number of keys and characters positions in that keys. Then, inside them, we have the variations of key positions. I don't know about the other Portuguese speaker countries, but I assume that they use one of these two general types. ;)

Harald Sitter (apachelogger) wrote :

Is this still the case in KDE 4?

Changed in kdeedu:
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

Yeah, still no easier to find.

Changed in kdeedu:
status: Incomplete → Confirmed
Harald Sitter (apachelogger) wrote :

Someone please forward the report to http://bugs.kde.org and add the URL to KDE Educational Applications (clicking the button left of the Name and Icon).

Changed in kdeedu:
importance: Undecided → Unknown
status: New → Unknown
Changed in kdeedu:
status: Unknown → New
fjarkenarken (aupaaus) wrote :

Yeah took me a couple mins myself it should be in front of you, abit of googling revealed > Click Training on the Menu bar, and click Default Lectures menu which reveals a list of lectures you can do.

Andrew Harvey (andrew-harvey4) wrote :

When I go to open lecture, it defaults to Home>Documents, but there are no lecture files. I went to /usr/share/apps/ but there is no ktouch folder. This is only really a bug if there are meant to be lecture files.

nah, I was confused at first, when I tried to open a lecture.

but you click training and select a lecture.

On 2/4/09, AndrewHarvey4 <email address hidden> wrote:
> When I go to open lecture, it defaults to Home>Documents, but there are
> no lecture files. I went to /usr/share/apps/ but there is no ktouch
> folder. This is only really a bug if there are meant to be lecture
> files.
>
> --
> Ktouch's "lectures" are hidden away and took a bit of time (and an expert
> Linux guru) to locate
> https://bugs.launchpad.net/bugs/72663
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in educational apps from the official KDE release: New
> Status in "kdeedu" source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: ktouch
>
> After adding this package-which I have used before-KTouch made it a mystery
> to find and open a lecture in order to begin to learn to type.
>
> It was unclear if I should "start a new session" under the training dropdown
> or "open a lecture" under the file dropdown.
>
> After complaining to my boyfriend, he took control, dropping to the command
> line and doing some magic that the average user would not be able to
> understand. In his words, he issued the command "dpkg -L ktouch" to list
> all the files in the ktouch package. He discovered some xml files under
> /usr/share/apps/ktouch which *happened* to be the so-called "lecture" files.
>
> This is way too hard to find.
>

description: updated

*** This bug has been confirmed by popular vote. ***

Changed in kdeedu:
status: New → Confirmed
Changed in kdeedu (Ubuntu):
status: Confirmed → Triaged
naught101 (naught101) wrote :

Not to mention that the only english lecture is horrible - who types "d d d d kd k k k"? less spaces would be good, and moving up to real words once there are enough letters...

hsherba (hsherba) wrote :

This is a USER UNfriendly app. The use should be obvious the lectures.

This why KTOUCH is NOT very well received and less used?????

Erik B. Andersen (azendale) wrote :

It seems like this bug is fixed. Is anyone still having this problem?

Erik B. Andersen (azendale) wrote :

By fixed I mean that it defaults to a lecture, so you don't have to open one to get started typing. If this bug is about it opening the home folder when going to open a lecture, that still happens. (The comment system could really use to let you edit your comments--sorry for the two in a row).

Klaus Borges (issues) wrote :

As of today, it's still the same thing.
The lectures are still "hidden" on /usr/share/kde4/apps/ktouch, which makes the application very user unfriendly, as hsherba stated. Which is odd, since they should probably be looking for an user friendly experience.

On the other hand, what naught101 said is wrong, those are only the first levels. And yes, the program does default to some text, but that same text makes it clear in the end that you should use the lectures, and when the user clicks to open one he gets to stare at his own home folder.

Changed in kdeedu:
importance: Unknown → Wishlist

Hello everyone

I fixed this annoying bug:

http://quickgit.kde.org/?p=ktouch.git&a=commit&h=8b10ade17f0b493206c12d55488cdf9b28e3efef

It will be part of KDE 4.7.

Version 2.0.0 introduces a complete new home screen to solve the issues here described.

It only presents the courses matching the system's current keyboard layout and the first lesson is already preselected. Gone are all the the menus and dialogs to configure that stuff manually. That way most users will have to only hit "Start Training" to get going.

Changed in kdeedu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.