step hangs trivially

Bug #333528 reported by Remove Me on 2009-02-23
2
Affects Status Importance Assigned to Milestone
KDE Educational Applications
New
Undecided
Unassigned
kdeedu (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kdeedu

Happens most frequently after this "steps":
- create a point
- pin it to the world with an anchor
- and try to add a stick starting at the point: click on the point and release the mouse button
  (sometimes stick can be added, but an attempt to modify it will hang the program). Very short stick, yes.

The program hangs going into endless loop:

(gdb) bt
#0 0x00000000004a685f in gmm::constrained_cg<gmm::row_matrix<gmm::rsvector<double> >, gmm::row_matrix<gmm::rsvector<double> >, gmm::identity_matrix, std::vector<double, std::allocator<double> >, std::vector<double, std::allocator<double> >, std::vector<double, std::allocator<double> >, gmm::identity_matrix> (A=@0x7fff37921490, C=@0x7fff37921430, x=@0x7fff379214f0, b=@0x7fff37921510, f=@0x7fff379214d0, PS=@0x7fff3792157f, M=@0x7fff3792157e, iter=@0x7fff379213d0) at /usr/include/gmm/gmm_blas.h:1665
#1 0x00000000004a31a3 in StepCore::CGConstraintSolver::solve (this=<value optimized out>, info=0x1efcdb8) at /build/buildd/kdeedu-4.1.4/step/stepcore/constraintsolver.cc:111
#2 0x0000000000497516 in StepCore::World::solverFunction (t=<value optimized out>, y=0x1f87d10, yvar=<value optimized out>, f=0x241ecc0, fvar=0x0, params=<value optimized out>) at /build/buildd/kdeedu-4.1.4/step/stepcore/world.cc:878
#3 0x0000000000431e51 in WorldModel::doEmitChanged (this=0x1ecf460) at /build/buildd/kdeedu-4.1.4/step/step/worldmodel.cc:396
#4 0x0000000000436a28 in WorldModel::qt_metacall (this=0x1ecf460, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff37921700) at /build/buildd/kdeedu-4.1.4/obj-x86_64-linux-gnu/step/step/worldmodel.moc:85
#5 0x00007f2e2d9b4134 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#6 0x00007f2e2d9aea43 in QObject::event () from /usr/lib/libQtCore.so.4
#7 0x00007f2e2c253c3d in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#8 0x00007f2e2c25b9ba in QApplication::notify () from /usr/lib/libQtGui.so.4
#9 0x00007f2e2e2f15db in KApplication::notify () from /usr/lib/libkdeui.so.5
#10 0x00007f2e2d99fd61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#11 0x00007f2e2d9cbab6 in ?? () from /usr/lib/libQtCore.so.4
#12 0x00007f2e2d9c81fd in ?? () from /usr/lib/libQtCore.so.4
#13 0x0000003004639d3b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#14 0x000000300463d50d in ?? () from /usr/lib/libglib-2.0.so.0
#15 0x000000300463d6cb in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#16 0x00007f2e2d9c815f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#17 0x00007f2e2c2e5a6f in ?? () from /usr/lib/libQtGui.so.4
#18 0x00007f2e2d99e682 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#19 0x00007f2e2d99e80d in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#20 0x00007f2e2d9a0cbd in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#21 0x00000000004908b8 in main (argc=1, argv=0x7fff379223f8) at /build/buildd/kdeedu-4.1.4/step/step/main.cc:58

Remove Me (remove-me) wrote :

A particle. Not "a point", start with a particle. Sorry, was confused.

Harald Sitter (apachelogger) wrote :

Hey Alex,

I just tried reproducing this with KDE 4.2, which hangs step just as well as on KDE 4.1. I am not sure this is really a problem within step, or an underlying component. In either case this bug needs to be forwarded to the KDE bug tracking system (http://bugs.kde.org) in order to make the step developers aware of this problem.

If you feel like forwarding the bug, it would be greatly appreciated, since we Kubuntu dudes are usually quite busy and it can take quite some time until we get to report the bug ourself :) In case you get around to post the bug in the KDE bug tracker, please post the bug's URL here, so we can link the two bug reports and thus get updates about status changes.

Thank you very much for this report.

Have a nice day :)

Changed in kdeedu (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

Could this possibly be bug 369679?

Harald Sitter (apachelogger) wrote :

Indeed.

Alex, can you please confirm that this doesn't happen in >= 4.2.4?

Changed in kdeedu (Ubuntu):
status: Confirmed → Incomplete
Remove Me (remove-me) wrote :

Any simple way to get step from kde 4.2.4?

Remove Me (remove-me) wrote :

That was simple enough. I tried Step from KDE 4.2.4. Same thing: freezes immediately.

IOW: it is NOT fixed in 4.2.4

Still an issue in Maverick or Lucid?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers