SRU 0.4.1 to saucy

Bug #1246433 reported by Michał Zając
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdeconnect-kde (Ubuntu)
Undecided
Michał Zając
Saucy
Undecided
Michał Zając
Trusty
Undecided
Michał Zając

Bug Description

SRU for this package is required because the Android counterpart has been updated to use a newer version of the protocol. Attempting to use the Android application with 0.3 will not work rendering the package useless.

Test Case:
1. Install kdeconnect-kde
2. Install KDE Connect from Google Play
3. Run the KDE Connect application
4. You should be able to see your PC listed there with "This device uses an old version of the protocol"

Regression potential:
As far as I can tell - virtually none.

This also fixes https://bugs.launchpad.net/ubuntu/+source/kdeconnect-kde/+bug/1244064

Changed in kdeconnect-kde (Ubuntu Trusty):
status: New → Fix Released
Changed in kdeconnect-kde (Ubuntu Saucy):
milestone: none → saucy-updates
description: updated
description: updated
Jonathan Riddell (jr)
tags: added: kubuntu
description: updated
Changed in kdeconnect-kde (Ubuntu Saucy):
status: New → In Progress
assignee: nobody → Michał Zając (quintasan)
Changed in kdeconnect-kde (Ubuntu Trusty):
assignee: nobody → Michał Zając (quintasan)
Revision history for this message
Jonathan Riddell (jr) wrote :

0.4.1 in saucy unapproved queue awaiting review by ~ubuntu-sru

summary: - SRU 0.4 to saucy
+ SRU 0.4.1 to saucy
Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Hello Michał, or anyone else affected,

Accepted into saucy-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kdeconnect-kde (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Clay Weber (claydoh)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Clay Weber (claydoh) wrote :

Installing kdeconnect-kde 0.4.1-0ubuntu1~saucy1 fixes the protocol mis-match, so kdeconnect is now functional again.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Waiving the seven day waiting period since it's totally broken as is.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdeconnect-kde - 0.4.1-0ubuntu1~saucy1

---------------
kdeconnect-kde (0.4.1-0ubuntu1~saucy1) saucy; urgency=low

  * Stable release upgrade for Saucy (LP: #1246433, LP: #1244064)
 -- Jonathan Riddell <email address hidden> Mon, 11 Nov 2013 15:34:55 +0000

Changed in kdeconnect-kde (Ubuntu Saucy):
status: Fix Committed → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers