kbluetooth4 not working (Intrepid beta)

Bug #282819 reported by mfabry on 2008-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebluetooth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebluetooth

I've recently upgraded from Hardy to Intrepid on amd64. I use bluetooth to connect to my PDA by usb adapter. I installed kdebluetooth. It's supposed to start after desktop starts, but there is no tray icon present even though kbluetooth4 is listed in processes. I've tried so far:
1. Plug in my adapter: a. before KDE starts, b. after KDE starts, c. before system starts. So far no luck. My adapter is properly recognized. I am able to make hcitool scan succesfully no matter when I plug in my adapter. Everything fails when I try to pair devices from my PDA and try to enter pin. Then all I get in syslog: bluetoothd[6252]: pin_code_request (sba=00:09:DD:10:46:71, dba=00:70:E0:AD:04:31)
2. I did another check - I killed all kbluetooth4 processes and restarted application from konsole. I got:
kbluetooth4(9434) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4(9434) KBlueTray::offlineMode: offline Mode
Needless to say there's still no tray icon and no response for pin request.
I have bluez:
  Installed: 4.12-0ubuntu2
and kdebluetooth:
  Installed: 1:0.2-0ubuntu2
3. I also tried to run kbluetooth4 with --sync --nocrashhandler --nofork options. What I got in syslog:
bluetoothd[6252]: HCI dev 0 registered
bluetoothd[6252]: HCI dev 0 up
bluetoothd[6252]: Registered interface org.bluez.Service on path /org/bluez/hci0
bluetoothd[6252]: Failed to listen on control channel
bluetoothd[6252]: Registered interface org.bluez.SerialProxyManager on path /org/bluez/hci0
bluetoothd[6252]: Registered interface org.bluez.NetworkPeer on path /org/bluez/hci0
bluetoothd[6252]: Registered interface org.bluez.NetworkHub on path /org/bluez/hci0
bluetoothd[6252]: Registered interface org.bluez.NetworkRouter on path /org/bluez/hci0
bluetoothd[6252]: Adapter /org/bluez/hci0 has been enabled
bluetoothd[6252]: Starting security manager 0
Any help will be appreciated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers