kbluetooth4 fails to add mouse

Bug #268383 reported by Craig Magina on 2008-09-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebluetooth (Ubuntu)
Undecided
Unassigned

Bug Description

When I tried to add my bluetooth mouse under Kubuntu Intrepid Ibex by using kbluetooth4's wizard, it failed with the following errors.

This is the first error I received:
kbluetooth4-wizard(7277) BTWizard::createBonding: Error: "org.bluez.Error.AuthenticationFailed: Authentication Failed"

The second error I believe is the more important one:
kbluetooth4-wizard(7277) BTWizard::createInputDev: Error: "org.freedesktop.DBus.Error.UnknownMethod: Method "CreateDevice" with signature "s" on interface "org.bluez.input.Manager" doesn't exist

Gordon Mckeown (thefluffyone) wrote :

I'm seeing the same behaviour:

Version: Kubuntu Intrepid Ibex Alpha 5 with updates to 14/09/08 at 18:30 BST.
Bluetooth: 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Mouse: Microsoft Bluetooth Notebook Mouse 5000

By entering a PIN of "0000" I don't see the authentication failure message, however the unknown method error is still displayed.

Error: "org.freedesktop.DBus.Error.UnknownMethod: Method "CreateDevice" with signature "s" on interface "org.bluez.input.Manager" doesn't exist"
probably means that you haven't installed the bluez-input package.

This has fixed it for me:
quit kbluetooth4
sudo apt-get install bluez-input
sudo invoke-rc.d bluetooth restart
start kbluetooth4 and try adding you mouse

kdebluetooth and gnome-bluetooth should both depend on bluez-input, or at least detect whether it is installed and -- if necessary -- at least prompt the user to install it manually.

Setting package to kdebluetooth although gnome-bluetooth seems to be affected too (confirmation needed)

The bluez-input packge is now recommended by bluez-utils (as of version 3.36-1ubuntu2).

If no PIN is entered in the authentication dialog, the following warning still appears:
BTWizard::createBonding: Error: "org.bluez.Error.AuthenticationRejected: Authentication Rejected"
Despite the warning, the device (a mouse in my case) is working afterwards, so I'd consider this merely annoying.
As pointed out in #1, entering e.g. 0000 solves this.

So I think this bug should be closed and a new bug should be filed regarding the authentication error.

Gordon Mckeown (thefluffyone) wrote :

Just to confirm that adding bluez-input sorted it out for me. I had done this originally, but didn't do the bluetooth restart (in this case it was working the next time I booted the machine).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers