[gutsy] kdebluetooth broken in current

Bug #134585 reported by sk0rp10
4
Affects Status Importance Assigned to Milestone
bluez-sdp (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by Emanuel Goscinski
kdebluetooth (Ubuntu)
Undecided
Ralph Janke
Nominated for Gutsy by Emanuel Goscinski

Bug Description

binary package hint: kdebluetooth

Kdebluetooth seems to be broken, the Send To Bluetooth device contextual menu in Konqueror disappeared with recent updates and sdp services are not detected neither in Bluetooth:/ nor with sdptool, which makes me think this is another problem related to Bluez.

description: updated
Revision history for this message
Andreas Wenning (andreas-wenning) wrote :

I can confirm this. No contextual menu in Konqueror.

Sending files using OBEX to the PC also stopped working. Service discovery is VERY slow, and only discovers very limited number of services. All things that has worked prior to this version.

Uname:
Linux andreas-laptop 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

kdebluetooth:
1.0~beta6~r702320-0ubuntu2

Changed in kdebluetooth:
status: New → Confirmed
Revision history for this message
Jorge Suárez de Lis (ys) wrote :

Same here.

* No contextual menu in Konqueror.

* Device discovery via bluetooth:/ is slow. My own bluetooth dongle isn't detected? It used to be. Also, after launching kbluetooth, or if connected the dongle while kbluetooth was running, device discovery won't work at all.

* Service discovery only discovers some services via bluetooth:/. I don't know if this is a feature, though (maybe the kio hides the services we can't handle?). Also, after launching kbluetooth, or if connected the dongle while kbluetooth was running, service discovery won't work at all.

* If I disconnect & reconnect the dongle AFTER use the new device config thing, kbluetooth crashes. This output is shown if I run kbluetooth in console:
---------------------------8<----------------------
process 26016: arguments to dbus_message_new_method_call() were incorrect, assertion "destination == NULL || _dbus_check_is_valid_bus_name (destination)" failed in file dbus-message.c line 1073.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_message_append_args_valist() were incorrect, assertion "message != NULL" failed in file dbus-message.c line 1521.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "message != NULL" failed in file dbus-connection.c line 3248.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_message_unref() were incorrect, assertion "message != NULL" failed in file dbus-message.c line 1391.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_message_new_method_call() were incorrect, assertion "destination == NULL || _dbus_check_is_valid_bus_name (destination)" failed in file dbus-message.c line 1073.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_message_append_args_valist() were incorrect, assertion "message != NULL" failed in file dbus-message.c line 1521.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "message != NULL" failed in file dbus-connection.c line 3248.
This is normally a bug in some application using the D-Bus library.
process 26016: arguments to dbus_message_unref() were incorrect, assertion "message != NULL" failed in file dbus-message.c line 1391.
This is normally a bug in some application using the D-Bus library.
KCrash: Application 'kbluetooth' crashing...
---------------------------8<----------------------

* The device discovery thing from kbluetooth won't work at all (well... via bluetooth:/ won't work also as I stated up there).

Revision history for this message
Jorge Suárez de Lis (ys) wrote :

libbluetooth2: 3.15-0ubuntu1
bluez-utils: 3.15-0ubuntu2
kdebluetooth: 1.0~beta6~r705625-0ubuntu1

With today updates of bluetooth libraries and kdebluetooth, kbluetooth won't affect the bluetooth:/ behaviour anymore. Device & service discovery will work ok. Kbluetooth is launched automatically when I plug de dongle, before this I must launch kbluetooth separately!

However,

* Kbluetooth new utilities still doesn't work.
* Contextual menu is still missing in Konqueror.
* Service discovery only discovers some services.

Revision history for this message
sk0rp10 (matteo-andreozzi) wrote :

With today update of kdebluetooth (beta6 r707240) filetransfer and contextual menu now work.

Revision history for this message
Andreas Wenning (andreas-wenning) wrote :

Filetransfer from Kubuntu is fixed. But receiving files still seems to be broken.

Revision history for this message
Emanuel Goscinski (emu--deactivatedaccount) wrote :

For me service discovery via bluetooth:/ still doesn`t work. I don't know why, maybe some packages are missing?

Receiving files doesn't work for me too.

It all worked fine in feisty.

Changed in bluez-sdp:
assignee: nobody → txwikinger
assignee: txwikinger → nobody
Changed in kdebluetooth:
assignee: nobody → txwikinger
Revision history for this message
Andreas Wenning (andreas-wenning) wrote :

@Emanuel:
About not being able to receive files see Bug #146145

Revision history for this message
Emanuel Goscinski (emu--deactivatedaccount) wrote :

@awen: Thanks for the hint.

Finally bluetooth:/ works for me too.

The other issue is posted in Bug #146145

Revision history for this message
Anthony Mercatante (tonio) wrote :

Now fixed

Changed in kdebluetooth:
status: Confirmed → Fix Released
Revision history for this message
Geo (pascal-s-deactivatedaccount) wrote :

hello
I have the same problem on Mandriva 2008, so could you post this fix directly on the Sourceforge Kbluetooth site ?

could I compil this fix to resolv my mandriva problem ?
Do you know if diff exist between ubuntu and mandriva KDEBLUETOOTH sources ?

thanks

Revision history for this message
Geo (pascal-s-deactivatedaccount) wrote :

hello
I finnaly compile this new version for my mandriva 2008.0, but same problem
Discovery feature does not work : my nokia phone can't "see" my computer to send photo/contact/meeting

Revision history for this message
Kamba (blamer) wrote :
Download full text (4.3 KiB)

Same problem on Hardy heron now.
~$ kbluemon
process 8170: arguments to dbus_message_new_method_call() were incorrect, assert
ion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 1074.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_append_args_valist() were incorrect, ass
ertion "message != NULL" failed in file dbus-message.c line 1521.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_connection_send_with_reply_and_block() were inco
rrect, assertion "message != NULL" failed in file dbus-connection.c line 3252.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_unref() were incorrect, assertion "messa
ge != NULL" failed in file dbus-message.c line 1391.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_new_method_call() were incorrect, assert
ion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 1074.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_append_args_valist() were incorrect, ass
ertion "message != NULL" failed in file dbus-message.c line 1521.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_connection_send_with_reply_and_block() were inco
rrect, assertion "message != NULL" failed in file dbus-connection.c line 3252.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_unref() were incorrect, assertion "messa
ge != NULL" failed in file dbus-message.c line 1391.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_new_method_call() were incorrect, assert
ion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 1074.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_append_args_valist() were incorrect, ass ertion "message != NULL" failed in file dbus-message.c line 1521.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_connection_send_with_reply_and_block() were inco rrect, assertion "message != NULL" failed in file dbus-connection.c line 3252.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_unref() were incorrect, assertion "messa ge != NULL" failed in file dbus-message.c line 1391.
This is normally a bug in some application using the D-Bus library.
process 8170: arguments to dbus_message_new_method_call() were incorrect, assert ion "_dbus_check_is_valid_path (path)" failed in file dbus-...

Read more...

Changed in bluez-sdp:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers