Konqueror crash on website

Bug #73291 reported by Richard Johnson on 2006-11-25
4
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
kdebase (Ubuntu)
Low
Unassigned

Bug Description

http://www.meijer.com - Konqueror crashes upon this site loading.

Backtrace:
==================

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1230809392 (LWP 4693)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb62445fc in non-virtual thunk to KHTMLView::~KHTMLView() ()
   from /usr/lib/libkhtml.so.4
#7 0xbfad765c in ?? ()
#8 0xb778ddfc in ?? () from /usr/lib/libqt-mt.so.3
#9 0xbfad7648 in ?? ()
#10 0xb624a687 in non-virtual thunk to KHTMLView::~KHTMLView() ()
   from /usr/lib/libkhtml.so.4
#11 0x088b24b8 in ?? ()
#12 0x00000000 in ?? ()
 ======================

John Vivirito (gnomefreak) wrote :

Thank you for this bug report. Can you please attach the full crash log in /var/crash. the partial backtrace you gave us isnt much help and i am not able to reproduce this at this time.

Changed in kdebase:
status: Unconfirmed → Needs Info
status: Needs Info → Confirmed
John Vivirito (gnomefreak) wrote :

Ignore the above it just happened here it was loading fine while i typed it and i looked in /var/crash for a report but ther eisnt one and that is the same back trace i got from it. marked this as confirmed as it happened here also on the same link.

Richard Johnson (nixternal) wrote :
Download full text (5.4 KiB)

Yes, there wasn't one in /var/crash :) I can't do my groceries if I can't view the site. So because of Konqi I am going to starve :)

I just tried this from the CLI:
$ konqueror http://www.meijer.com

This is what I got:

ASSERT: "!icon.isEmpty()" in /build/buildd/kdebase-3.5.5/./libkonq/konq_pixmapprovider.cc (81)
KCrash: Application 'konqueror' crashing...

Here is a new backtrace I got when running via CLI.

-------------------------------------------------------
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1233958720 (LWP 7936)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb5f227dc in DOM::ElementMappingCache::ElementMappingCache...

Read more...

Richard Johnson (nixternal) wrote :

I marked the importance as low, as I am the only poor sap probably complaining about it right now ;)

Changed in kdebase:
importance: Undecided → Low
John Vivirito (gnomefreak) wrote :

here is the backtrace i got using the konqueror-dbgsym package and running a backtrace it looks less helpful than Richards.

John Vivirito (gnomefreak) wrote :

I filed the bug upstream on this issue since i couldnt find one already. I marked this for upstream.

Changed in kdebase:
status: Unknown → Unconfirmed
Richard Johnson (nixternal) wrote :

This is definitely fixed in KDE 3.5.6 which will eventually make it's way to Edgy and such.

Changed in kdebase:
status: Confirmed → Fix Committed
Changed in kdebase:
status: Unconfirmed → Fix Released
Kieran Hogg (xerosis) wrote :

Obviously fixed in gutsy, and so, fix released.

Changed in kdebase:
status: Fix Committed → Fix Released
Christophe Dumez (hydr0g3n) wrote :

Hi,

I'm using latest gutsy and Konqueror is not browsing anymore since yesterday. I launched it in a console and I saw this output:
ASSERT: "!icon.isEmpty()" in /build/buildd/kdebase-3.5.7/./libkonq/konq_pixmapprovider.cc (81)

Are you sure this is fixed? or maybe the bug appeared again.

Richard Johnson (nixternal) wrote :

It is working for me right now using Gutsy as well.

Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.