High cpu load with newest KDE

Bug #66232 reported by John on 2006-10-15
4
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: akregator

Hello,

I think it came with the newest version of KDE this week on EDGY, but since then I'm getting a lot of kio_http taking a lot of ressources. Exiting Akregator does not kill them, and then the reboot is not possible ... But if I don't start Akregator, I have no problem.

Using Kubuntu Edgy up to date.

John (john.e) on 2006-10-15
description: updated
John (john.e) wrote :

It's not just akregator, I've been playing with konqueror panels now and I got the same problem with kio_http_cache_.

Luka Renko (lure) wrote :

Do you still see this with up-to-date Edgy? I cannot reproduce it here and I am using akregator...

Changed in kubuntu-meta:
status: Unconfirmed → Needs Info
John (john.e) wrote :

Yes, it can still happen.

The worst part is that the kio cannot be killed by me, so it's bad, but even the system cannot kill it so I can't fully shutdown or reboot, I have to do it on the unit. And therefore it may mess up my filesystem :(

To tell you,

right now I've just started the computer, I have :

konsole with 3 tabs,
konqueror with 6 local tabs (no internet)
Firefox (but it doesn't use kio)
Thunderbird (same)
SuperKaramba
Basket
Kopete
Amarok

And I have this with top :

4801 john 25 0 26180 6752 4636 R 92.0 1.3 4:38.65 kio_http_cache_

But as I'm not doing something too heavy, I don't feel it, but as soon as I have many kio_http started, and if I'm trying to do something heavier I will feel it.

If I can do anything to provide you more information, please tell me.

Thanks

John (john.e) wrote :

Also, let me say that as I use Folding @ home, under most circumstances it should be the first with top, and I did not have this problem like 1 week ago (about the time 3.5.5 arrived, but also about the time when I started to use basket, well that was like 1 week before ...).

John (john.e) wrote :

Still the same, but I have to add a few things :

1-Since then I can't shutdown the computer, it halts but does not poweroff, and with upstart I have no verbose to why is that, so I cannot say. It can also reboot fine ..

2- it seems the process that I always have now (at least one) kio_http_cache_ is started by kdeinit. Maybe that can help somewhere. I guess (but I may be wrong) that it has something to do with kde services, I've tried to stop them all, I'll try later not to start them all and to reboot as I can't kill this process, maybe stopping them is not enough ...

This is really annoying (the system is slower and it cannot shutdown).

I'll try to investigate more, but in the mean time if you have some idea, I'll be glad to try them.

Thanks

John (john.e) wrote :

Well, it seems it wanted me to lie, the reboot did not went well ....

As said, I have started KDE with no KDE services wanted, and I don't see the bad process bugging me.

I've started back every service but the DNS-SD service watcher, and still nothing so maybe that's where it comes from.

You may ask yourself why I don't start it, well I want to see one shutdown first, to see if the problems are the same or not ..

John (john.e) wrote :

Sorry for the delay, but I've tried a few things.

It seems my problem comes when any KDE application access the net. It happened with Konqueror, Kopete, and even Amarok. For each of these, I had nothing before, and when I started it (or with konqueror open a tab for a web site, konqueror as a file manager is fine) the kio_http_cache_ process appeared.

Without this process, the computer shuts down fine (I've just tested that).

All the tests done today and yesterday after my last post were done without the DNS-SD service started, but I've just started it and I still don't see the kio_http_cache_ process.

I hope all that can help, and I hope you will be able to help too :)

Thanks

John (john.e) wrote :

I can confirm this with further testing :

If no KDE program try to access the web, no problem. But if one tries, then problem comes one by one depending on the program(s) started.

I've been told I should report that to KDE maybe, can I get a word from you to do so or not ?

Thanks

Andrew Ash (ash211) wrote :

If possible, I would try to reproduce this with a clean install of edgy, or a livecd environment. Since you dist-upgraded from dapper to edgy (I'm assuming) there may be a config file or something left over in your ~/.kde folder that's causing this problem. You might also try moving that folder to ~/.kde_backup or similar and have KDE recreate ~/.kde . Just some ideas.

If it's still a problem then you should report this upstream to bugs.kde.org, after checking to see if it's already in their bug tracker.

John (john.e) wrote :

Yes, I've dist-upgraded from dapper, but this problem started as said with the latest KDE, or maybe I've just never had it before under edgy (which I started using around early september).

I will try what you said about the ~/.kde and the live CD, though as I'm the only one around me having this bug, I guess it has something to do with my desktop, somewhere.

John (john.e) wrote :

Well you were right, I started KDE as root (which I never did before, so it was kinda fresh) and I could not generate this problem.

Would you have an idea on where I could find the roots of this problem ? I'm much more the type of guy losing his day to fix the problem rather than reinstalling in the hour.
But of course, that's me and not the kubuntu team :)

John (john.e) wrote :

Well, I have another comment (holidays are good for that) :

Just after that, I tried with my normal session and the problem came, then in the KDE service manager I unchecked every service and rebooted.

With the next boot, I started to play with konqueror with no problem, I added a few services and still nothing. I then added almost all services with no problem, then I started kopete and still nothing. I started all the services that were not started and fired Amarok (which gave me the problem another day) and still nothing ...

I really don't understand a thing, is there any particular order between starting services and using programs that cause this problem ?

Andrew Ash (ash211) wrote :

The services info is baffling. I'm still of the mind that it's some config file in ~/.kde, because I had a problem in there with my dual monitors after dist-upgrading to dapper (or maybe it was pre-release edgy, I don't remember).

Try renaming ~/.kde and seeing if that fixes the problem. If it does, we know it's in there. I bet it's in one of the files in ~/.kde/share/config, but that's just a hunch.

But please check on a livecd environment or creating a new user to check for the problem, so we can make sure this isn't a problem for any other users. Thanks for the help!

John (john.e) wrote :

Well as I've tried with the root user it should be the same, but I have tried other things as well :

1- with a new user, which has by default all KDE services started, no problem.

2- with my normal user, with every KDE services started :
a- with a new ~/.kde/share/config, the problem is there
b- with a new ~/.kde, no problem

Andrew Ash (ash211) wrote :

Well then, it must be somewhere in ~/.kde, but not in ~/.kde/share/config If you'd like, you can keep playing with it and keep us updated on what you've found, but it sounds like this is an isolated glitch and not really a bug in all of Kubuntu.

Because of this, I'm going to mark this bug rejected, since no one else has confirmed it from the same set of circumstances. If that happens, we can see if there is anything the Kubuntu team can do to keep this from occurring to others. Until then, go ahead and keep us updated, and thanks for helping make Kubuntu better!

Changed in kdebase:
status: Needs Info → Rejected
John (john.e) wrote :

Fine with me, but if you know of a way to kill a process that cannot be killed (kill -15 / -15 fail), it would make my tests easier, as for now, each time this process spawns I have to reboot, so it takes a pretty amount of time.

Anyway I'll try to find it this week, but I can't say I will find it for sure ...

John (john.e) wrote :

I may have found it, though at this time I won't look much further, but I will sure apreciate some comments.

I've moved the cache-* directories out of the way from ~/.kde, and it seems to work just fine. Would there be any reason for that ?

Thanks

John (john.e) wrote :

Oh and with one of them I'm getting that right now :

"rm: reading directory `cache-Computer': Input/output error"

but this is from an old install, it should not be used anymore I guess, but maybe ?

Andrew Ash (ash211) wrote :

I'm not really sure about that one. I don't know much more than what I've already offered, so you're only going to get more support from people more knowledgeable than me.

I wish you good luck on figuring out what's going on here!

John (john.e) wrote :

Well for now it seems to work, and don't be too hard on yourself, you're the one who suggested looking in ~/.kde, so you helped me a lot finding it.

I may try to look at the reason behind the problem, but I again I can't guarantee I will find the reason.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers