KDE 3.5.5 upgrade & device icons on desktop

Bug #66110 reported by mlaverdiere on 2006-10-14
12
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdesktop

I just did an upgrade to KDE 3.5.5 last night on a Dapper box and everything went well, except that now I have device icons (local HD & Samba remote share) appearing on my desktop, which I don't want.

It turns out that the checkbox that is suppose to control device icons appearance on the desktop, under Kcontrol/Desktop/Behavior/Device icons is just not working right now. I've tried it with a fresh /home/user directory, without positive results. The only way to get rid of the icons is to uncheck each device, not just the "show devices icons", and restart x server (loging out then, at login screen, pressing ctrl+backspace).

Rocco Stanzione (trappist) wrote :

I tried unchecking individual icons such as unmounted samba shares, and had the same experience. The apply button has no effect. Have to restart X for the changes to take effect.

Changed in kdebase:
status: Unconfirmed → Confirmed
Daniel Eckl (daniel-eckl) wrote :

While I don't have this bug, I have the problem that the icons for mounted optical media do not show the name of the media anymore. Just "cdrom" or "dvdrom".

Could that be connected to that problem? If not, I'd create a new bug report.

Daniel Eckl (daniel-eckl) wrote :

Addendum: The icons in "media:/" view do show the name of the medium. And I'm using Dapper, not Edgy.

Also, see bug #67120, "[KDE 3.5.5] Device labels are not correctly displayed on desktop".

Keith Burton (keith-starbeast) wrote :

I ran into this on a Kubuntu Edgy to Feisty upgrade, and just lived with it for months. Thanks for posting the workaround here.

Jonathan Thomas (echidnaman) wrote :

This isn't an issue with the new device notifier/lister (Device Notifier plasma applet) in Kubuntu Intrepid Ibex. (8.10)
Thanks for your bug report as well as your interest in supporting Kubuntu!

Changed in kdebase:
status: Confirmed → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

Device Notifier doesn't seem to work in the same way - it doesn't seem to let you just plonk
arbitrary device icons on your desktop - which is what some people would like to do; in addition
it has a critical bug which means it just doesn't work at the moment (Intrepid Alpha 4):

https://bugs.kde.org/show_bug.cgi?id=170137

For an added bonus, the 'Device icons' on Hardy KDE 3.5.9 is also flaky and often they don't
always appear - so either way I'm not sure it's right to mark this as 'fix released' since at
the moment there is no solution either in Intrepid or Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.