After the screen has been locked (hibernate to disk or just "Lock Session" from K menu) X screensaver is set to ~70 seconds

Bug #65734 reported by Daniel Hahler on 2006-10-12
8
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
kdebase (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kdm

After resuming from hibernate, my screen blanks after about 70 seconds, despite the normal 10 minutes.

If I restart kdm after resume, it works like with a fresh boot.

Additionally, I cannot figure out where the "blank screen" gets invoked from.
I have setup "MatrixView (GL)" in the Screen Saver panel in kcontrol - not "Blank Screen" and even not set it up to "Start automatically".

However, now that I have checked "Start automatically", set it from "After 1 min" to "After 10 min", it does not blank after said 70 seconds anymore.
Even changing it back to "Not start automatically" as before now does not trigger the "blank screen" anymore - like a kdm restart would do.

Just to be clear: moving the mouse brings back the display like before, of course. It's just the triggering that's wrong.

Daniel Hahler (blueyed) wrote :

Seems to be related to the "dpms" setting for X.

With the kcontrol module "Monitor & Display" under the "Power saving" tab I've set "Enable power saving" and set it to "Switch off monitor after: 30 minutes".

However, it always blanks before those 30 minutes. About after 10 minutes normally and 1 minute after resuming.

Because this is quite time-consuming and boring to test, I'd like to hear where I should look specifically.

Daniel Hahler (blueyed) wrote :

Now after resume I get an huge white "X" logo instead.

Also, I've found out that it's not related to the "setx dpms" setting, but that I have to just change anything in the kcontrol "Screen Saver" module, so that the "Apply" button gets clickable, change it back (e.g. check and uncheck the "Start automatically" checkbox) and then click Apply.
This fixes it.

Maybe it's related to locking the screen just before hibernation - which triggers the configured screensaver?

Daniel Hahler (blueyed) wrote :

What script/action does kdm perform for the "Hibernate" and "Suspend" buttons in the "Log out..." dialog?
I'm quite sure, that the root of the error is there.

Also, "Suspend" does not work, when I click the button - but does work with manually running /usr/share/hal/scripts/hal-system-power-suspend, which uses /etc/acpi/sleep.sh through pmi.

So, where I can I look further?

Luka Renko (lure) wrote :

Some DPMS related issues are also reported in bug 65791.

Daniel Hahler (blueyed) wrote :

My bug is not DPMS related.

"xset -dpms" or "xset dpms 0 0 0" does not fix it.

BUT "xset s off" does. This deactivates the screensaver.

I've still no idea though, why the interval gets shortened or the X screenscaver activated at all after resuming.

Daniel Hahler (blueyed) wrote :

Changed the title after finding out that "Lock Screen" also triggers it.

Can anyone confirm this?

Changed in kdebase:
status: Unknown → Unconfirmed
Changed in kdebase:
status: Unconfirmed → Confirmed
Changed in kdebase:
status: Confirmed → Rejected
Changed in kdebase:
status: Unknown → Confirmed
Marco Maini (maini10) wrote :

Confirmed in upstream bug tracker.

Changed in kdebase:
status: New → Confirmed
Changed in kdebase:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Upstream says this is fixed. Could somebody test with Intrepid or KDE4?

Changed in kdebase:
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

Seems to be fixed. Please reopen if this can be reproduced in Intrepid.

Changed in kdebase:
importance: Undecided → Low
status: Incomplete → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.