Windows flicker/desktop unusable after upgrading to kde-3.5.5 (any kind of focus follows mouse policy enabled)

Bug #65644 reported by jstammi on 2006-10-12
2
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase

After upgrade to kde 3.5.5 this morning my desktop was not usable any longer as the windows were flickering by switching the focus all the time without any actions from me.

After switching Desktop -> Window Behaviour -> Focus policy from "Focus strictly under mouse" to "Click to Focus" the problem disappered. Any other setting there made the problem occur again.

I then found http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=391357 describing exactly this problem (not in the subject but in the contained discussion). As far as I understand this made debian raising a 3.5.5a version of kdebase which is said to resolve the problem.

My env:
Kubuntu Dapper
KDE 3.5.5
All patches up to now applied
Linux <HOST> 2.6.15-27-amd64-generic #1 SMP PREEMPT Sat Sep 16 01:50:50 UTC 2006 x86_64 GNU/Linux
nVidia Corporation NV41GL [Quadro FX 1400] rev 162

description: updated
Harm van Bakel (hvbakel) wrote :

I updated to 3.5.5 this morning and I'm also using 'focus follows mouse', but I don't have the problem as you describe above. I have an ATI rather than an nVidia card so maybe it's related to the graphics driver?

jstammi (johannes-stamminger) wrote :

Do use the keramik theme? The debian bug's author stated at the very end that the problem occurs only when starting kde using this theme (I did not test this myself but will do so tomorrow).

But anyway: there is the confirmed and by debian patched bug. I had a look to the kdebase-3.5.5 sourcecode in ftp://ftp.gwdg.de/pub/x11/kde/stable/3.5.5/src/kdebase-3.5.5.tar.bz2 (I hope this is the input for the kubuntu kdebase package, is it?). And there the debian patch is not (yet?) applied.
Though I do not see the keramik-theme relation there ...

jstammi (johannes-stamminger) wrote :

Correction: the author stated that the bug depends on the window decorations, not the theme as I mixed up before.

And I can confirm this. Switching to the KDE 2 decorations comes around the bug (switching the theme does not).

Maye (michael-aye) wrote :

I confirm this bug on Kubuntu Edgy Eft switching between Crystal and Keramik.
Keramik would not let me activate 'focus follows mouse' without that flickering bug. Crystal is fine with that setting.
Regards,
Michael
PS.: Environment: Edgy Eft Kubuntu on Thinkpad with ATI Radeon card.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers