Ubuntu

If GDM is the default display manager KDE logout dialog is missing shutdown and restart options

Reported by lcampagn on 2006-10-08
80
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Jonathan Riddell
Nominated for Karmic by Alex Zbarcea
Feisty
Undecided
Unassigned
meta-kde (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Alex Zbarcea
Feisty
Undecided
Unassigned

Bug Description

I started having this problem fairly recently.. I have tried changing the relevant settings in the "KDE Components/Session Manager" control panel, with no effect. Any ideas?

Related branches

idontknow (idontknow-2-2-2) wrote :

yes i have the same problem i cannot shutdown, restart, hibernate, suspend from the kde logut menu. only the logout option is visible.

idontknow (idontknow-2-2-2) wrote :

this problem is still continuing, it only occurs if i use gdm as the login manager.
if i use kdm then kde shows the correct options in the logout dialog.

idontknow (idontknow-2-2-2) wrote :

by the way i am using ubuntu feisty, gdm as the login manager, kde for desktop and ion3 as window manager

Aldin K (aldin) wrote :

should be confirmed

Changed in meta-kde:
status: Unconfirmed → Confirmed
Aldin K (aldin) wrote :

I have same problem, using feisty fawn with all upgrades, default GDM, default KDE, and no shutdown restart etc buttons only logout.

This was issuse on dapper too, but on edgy it was ok - it had all buttons no matter which DM was default, should be on feisty too.

btw when i use KDM as default there are all buttons, but then if i want to reboot from GNOME i dont have reboot button only logout.

EmxBA (emxba) wrote :

These buttons are missing at my installation too.

karl (karl-sebastian-liebich) wrote :

same problem. I am using the 64bit edition.

Scott Kitterman (kitterman) wrote :

Reassigned per crimsun (#kubuntu-devel IRC).

Sebastien Bacher (seb128) wrote :

not a gdm bug, KDE is not talking to it, rather a wishlist

Aldin K (aldin) wrote :

anyone knows will it be "ready" for 7.04 ?

Marco Cimmino (cimmo) wrote :

same here with kubuntu feisty final, if you want screenshots see duplicate Bug #108070

Scott Kitterman (kitterman) wrote :

Still present in 7.04 release.

Changed in kdebase:
importance: Undecided → Medium
Blaiz (blaiz) wrote :

Hello everybody,

I had the same problem. I have been using KDE with GDM as login screen since now, and I had this bug. I tried replacing gdm with kdm and it corrected the bug so I confirm that the bug comes with the use of GDM as the login screen.

I precise that I had not this problem under Edgy. It cames with the upgrade to Feisty.

Scott Kitterman (kitterman) wrote :

The bug is in KDM. If GDM is the default, KDM fails to make a call it needs to make to GDM. A fix for this is, I believe, being tested.

Changed in meta-kde:
status: Unconfirmed → Rejected
Tollef Fog Heen (tfheen) wrote :

Attached debdiff fixes this problem and has been uploaded to feisty-proposed.

Changed in meta-kde:
status: Unconfirmed → Rejected
Tollef Fog Heen (tfheen) wrote :

And that attached patch had nothing to do with the problem; updated patch attached.

Marco Cimmino (cimmo) wrote :

can we have a new debian file to test?

thanx Tollef :)

* Cimmo

| can we have a new debian file to test?

http://people.ubuntu.com/~tfheen/tmp/ has i386 binaries.

--
Tollef Fog Heen
UNIX is user friendly, it's just picky about who its friends are

Jonathan Riddell (jr) wrote :

Tollef has uploaded to feisty-proposed. pitti can you let it into the archive?

Marco Cimmino (cimmo) wrote :

thanx Tollef, tried your packages and all is back to work.

Just that you are patching kdebase, this is another similar but different problem, that affects old login (independent from gdm):
https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/103401

thanx

Martin Pitt (pitti) wrote :

Accepted into feisty-proposed. NB that this does not require a no-change -updates upload after verification (see updated SRU policy).

Changed in kdebase:
status: Unconfirmed → Fix Committed
assignee: nobody → jr
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

I verified that with gdm as display manager the only option in a kde session available is logout.

When I installed the updated packages shutdown, suspend and hibernate became available too.

I will mark this bug as verification-done. It can go into feisty-updates.

Aldin K (aldin) wrote :

hi, just to say that if u have kubuntu 7.04 (with KDM) and install GNOME 'sudo apt-get install ubuntu-deskop' and leave KDM as default DM, after u log into GNOME and try to reboot/shutdown from GNOME it is same... no reboot/shutdown buttons

so:

KDM default -> no reboot/shutdown buttons from GNOME

should it be "new bug" or should it be solved (together) in this bug report?

Paulo Dias (paulo-miguel-dias) wrote :

I can confirm that this bug was solved when i upgraded kubuntu feisty to kdebase 3.5.6-0ubuntu20.1, but yesterday i upgraded to kde 3.5.7 (kubuntu oficial repo) and this bug is now back again :( so i guess a similar patch must be applied to kubuntu kde 3.5.7.

Martin Pitt (pitti) wrote :

feisty-proposed package copied to -updates.

But please, pretty please get this fixed in gutsy.

Changed in kdebase:
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

Uploaded to gutsy in 3.5.7-1ubuntu3

Paulo Dias (paulo-miguel-dias) wrote :

Hi jonathan, could you please explain what you have done to solve this bug? that way i could compile the sources myself (taking them from the kubuntu/packages) and fix the bug in my desktop. if you could add the link to the sources and diff or attach the patch that would be greatly appreciated.

thanks :)

Martin Pitt (pitti) wrote :

Thanks Jonathan! Closing Gutsy task then.

Changed in kdebase:
status: In Progress → Fix Released
viking777 (viking-f2s) wrote :

A similar problem to this has occurred on my kubuntu gutsy 64bit installation following upgrade to kdebase 4.3.5.7-1ubuntu17.

The only shutdown option I have is 'logout'.

Of course it differs slightly in that being a kubuntu system it is not using gdm display manager but kdm.

Brian Murray (brian-murray) wrote :

viking777 - That sounds like a significantly different bug. Please submit a new bug report for your issue, thanks in advance.

viking777 (viking-f2s) wrote :

Thanks for reply that is now done, bug #136987.

I don't understand. Fix released in 2007, no comments since then, but the bug is still here. What's going on?

nuovodna (nuovodna) wrote :

Bug is still here :( Please fix!!

Harald Sitter (apachelogger) wrote :

I understand that since then GDM experienced changes that rendered KDE and GDM (and KDM and GNOME for that matter) incompatible. This should however be dealt with in the respective upstream projects, so please report this at http://bugs.kde.org

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers