Konqueror does not animate APNG files

Bug #488905 reported by Jarl on 2009-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
Wishlist
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase

Take a look at http://en.wikipedia.org/wiki/Animated_Portable_Network_Graphics

The ball at the right should bounce. It does so in firefox, but not in konqueror.

Jarl

ProblemType: Bug
Architecture: amd64
Date: Thu Nov 26 20:31:38 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx wl
Package: konqueror 4:4.3.2-0ubuntu3
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=da_DK.UTF-8
 SHELL=/usr/bin/tcsh
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: kdebase
Uname: Linux 2.6.31-15-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2273): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (npviewer.bin:2631): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64

Version: (using KDE KDE 3.2.3)
Installed from: Mandrake RPMs

Please support APNG images as described at http://www.vlad1.com/~vladimir/projects/apng/AnimatedPNG.html

(please change severity to wishlist)

I emailed the apng creators shortly after it appeared to notify them of an apparent bug in either KHTML or apng in that KHTML was displaying the last rather than the first image in the sequence. At any rate the authors expressed an interest in working to get apng working in KHTML since Safari too would benefit.

I believe we use Qts PNG-rendered so we probably need to fix the last-image bug there.

The APNG specification has been worked out and the implementation completed.
It's been included in the Mozilla tree as a patch to libpng for a few months
now.

The new spec is here: http://wiki.mozilla.org/APNG_Specification

I'm not sure KDE uses libpng at all.. but if you do, the libpng patch is available here: http://littlesvr.ca/apng/

Unfortunatly Firefox has beaten Konqueror to this. *gives it a nudge*

Looks like Opera has it too.

Jarl (jarl-dk) wrote :
Jonathan Thomas (echidnaman) wrote :

Hello,

Thanks for reporting this feature request! Unfortunately, at this time Kubuntu does not have the developer manpower needed to implement and maintain many features at the Kubuntu level. But don't worry! This issue is being tracked by the KDE developers at: https://bugs.kde.org/show_bug.cgi?id=88352
Once implemented in KDE, it will be included in Kubuntu once the KDE version the feature is implemented in reaches Kubuntu.

Thanks!

Changed in kdebase (Ubuntu):
status: New → Invalid
Jarl (jarl-dk) wrote :

Why are you confirming the bug and even provide an upstream bug reference for this bug and then at the same time marking the bug invalid. It doesn't make sense. I have changed status to "confirmed"

Jarl

Changed in kdebase (Ubuntu):
status: Invalid → Confirmed
Jonathan Thomas (echidnaman) wrote :

Try actually reading my comment.

Changed in kdebase (Ubuntu):
status: Confirmed → Invalid
Changed in kdebase:
status: Unknown → Confirmed

But wasn‘t APNG sanctioned by the PNG inventors in favor of MNG (which is superior in my eyes), but still would love to see that. Finally using alpha-transparent throbbers (that spinning wheel to indicate progress going on) that look good on ANY background :)

Changed in kdebase:
importance: Unknown → Wishlist

Not only did they reject APNG but they actually created the MNG format - only to reject themselves at a later point - stating somewhere that they felt PNG should be a stationary format only.

Now 1 problem there is whit APNG is if you create an animation in a program like VirtualDub APNG Mod 1.9.11.1 - it is stated that it's not cross-browser compatible - so I guess Linux users may not see it correctly.... I guess!

I think the best chance of getting an update animation format compared to gif - is if google succeeds in turning WebP into an animated format too, it is said on there page that they are currently working on that a.m.o.

Nevertheless, I have voted for this subject too-> anything that can replace the insufficient - but not necessarily redundant gif format - has my vote!! :-)

FYI, the code for native APNG support in WebKit:
https://bugs.webkit.org/show_bug.cgi?id=17022

Changed in kde-baseapps:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.