Moving the System menu breaks the screensaver kcontrol module

Bug #46599 reported by benj carson on 2006-05-25
14
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kmenuedit

If the default KDE System menu is moved to a sub-menu, the screensaver module in kcontrol is no longer able to load the list of screensavers. For example a menu like so will break the screensavers:

Full Menu
     + Development
     + Graphics
     + Internet
     + System
Home
Add/Remove Packages
...

The problem seems to be because KDE relies on having the (hidden) screensaver menu at the menu path System/ScreenSavers but kmenuedit moves the entire System menu without preserving the Screensaver path. According to http://docs.kde.org/development/en/kdebase/userguide/kde-menu.html#essential-menus the ScreenSavers sub-menu is "essential".

I've been able to edit my menu by hand (in ~/.config/menus/applications-kmenuedit.menu) in order to work around this issue. Instead of using <Move> tags to change the location of the System menu, I create a *copy* of it by repeating its definition in a new sub-menu and then applying a <Delete/> element to the root System menu. The screensaver module seems to be tolerant to this change.

The original System menu definition can be found in /etc/xdg/menus/kde-applications.menu

I can post example application-kmenuedit.menu files that demonstrate the problem, if required.

chavo (chavovaldez) wrote :

I can confirm this behavior. After moving all menus into a submenu my screensavers no longer function. They are not listened in the control center applet at all.

Changed in kdebase:
status: Unconfirmed → Confirmed
Rocco Stanzione (trappist) wrote :

+1, though I never moved the screensavers submenu item (I'm 99% sure of this). It's not where it apparently should be, though. This is on Edgy.

Rocco Stanzione (trappist) wrote :

Oh. I'm missing the whole System menu.

Rocco Stanzione (trappist) wrote :

Now I understand. I eliminated the problem by commenting out the problem section like so:

<!-- <Move>
  <Old>System</Old>
  <New>Utilities/System</New>
 </Move> -->

Jonathan Thomas (echidnaman) wrote :

kcm modules no longer use the .menu system in Intrepid + onwards, solving this bug.

Changed in kdebase:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers