KDE won't shut down

Bug #465672 reported by Adric Riedel on 2009-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase

I'm running a release version of Kubuntu 9.10; all updates as of 2009-10-30, on an HP Pavilion dv3-2150us.

Observed behavior: When I go to the KDE menu and select shutdown (or use the shutdown/lock widget to shut down), I get a dialog whose options do nothing. No matter what I click on, I am returned to the desktop with no changes. Further attempts to click on the shutdown button do nothing at all; there is no dialog.
I have to shut down my system with `sudo shutdown now' or similar.
This is identical to a supposedly closed bug that pinned the problem on knotify waiting to play the logout sound and being unable to.
Before I tried a clean install of Kubuntu 9.10, I was running Kubuntu 9.10RC, and when this happened, turning off the shutdown sound in System Settings->Notifications->KDE Settings worked. I would verify the names of those panels in the system settings applet, but after I try to shut down the `right' way, I can't open the System Settings applet at all.

Expected behavior: KDE logs out/shuts down.

Question: sox (`play') and pidgin have sound; play skips with alsa underruns every so often and pidgin only has sound when its server is set to `automatic' or `esd'. KDE apps like Amarok and KDE notifications (but curiously not dragon-player) themselves are silent. Is this inability to shut down linked to my inability to play sounds in KDE?

Adric Riedel (adric-riedel) wrote :

I can confirm the workaround: disable the logout noise in notifications.

Chris Puttick (cputtick) wrote :

This is not a duplicate of 401535. No sound plays and shutdown never happens; this is a deeply annoying, albeit non-fatal bug that results in my desktop settings never being saved because I have to forcibly shutdown every time.

Chris Puttick (cputtick) wrote :

@Adric: I have got general sounds in KDE (after noting my game (Red Alert C&C...) in Wine has sound through pulse-audio by reconfiguring the sound settings: specifically changing backend to Xine and setting pulse-audio as default. Of course, having to forcibly shutdown means these settings might not be saved for my next session...

Chris Puttick (cputtick) wrote :

And can now confirm that with "PulseAudio" enabled as preferred sound output device using the Xine backend all works as expected (including playing the exit sound without issue or significant delay to shutdown).

Ergo, this is categorically *not* a duplicate of 401535.

Adric Riedel (adric-riedel) wrote :

It doesn't work for me... With PulseAudio set as the preferred sound device and Xine as the backend I still get no sound whatsoever, and no failure messages either. Anything that uses ESD seems to be fine. I installed and used pavucontrols to confirm that sound is not muted in Pulseaudio (which would, I suspect, have made all Gnome apps silent anyway). No luck, no sound. The only unusual element I can think of is that my HP Pavilion dv3 requires specifying a model (hp-dv5) in /etc/modprobe.d/alsa-base.conf to get sound to work at all... and yet, since it does in Gnome and all non-KDE apps, I don't know where the problem is.

I second that this is not a duplicate.

Adric

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers