Konqueror can't remember passwords for launchpad or amazon

Bug #3735 reported by Jorge Bernal on 2005-10-31
8
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Kubuntu Bugs

Bug Description

There's a problem right now, since the login is done at $CURRENT_URL/+login, so browsers (it seems only Konqueror) don't recognise it as the same page and you have to type your password every time.

James Henstridge (jamesh) wrote :

Which browser has this problem? Do you know what algorithm your browser uses to decide whether to prefill the data?

The current setup seems to work okay for me in Firefox.

Jorge Bernal (koke) wrote :

Firefox now (breezy), but I use Konqueror at work and it behaves the same way

Jorge Bernal (koke) wrote :

Actually it seems to happen only in konqueror.

Matthew Paul Thomas (mpt) wrote :

Does the same problem happen with Konqueror at amazon.com, which also uses a multitude of URLs for logging in? I'm tempted to say this is a browser bug.

Steve Alexander (stevea) on 2005-12-16
Changed in launchpad:
status: New → NeedInfo
Jorge Bernal (koke) wrote :

It fails at amazon.com too.

Matthew Paul Thomas (mpt) wrote :

I consider Konqueror a target browser for Launchpad, but not to the point of working around broken autofill behavior, sorry. Konqueror should be going by hostname and field names, not by exact URL.

Changed in launchpad:
assignee: nobody → mpt
status: NeedInfo → Rejected
Jorge Bernal (koke) on 2005-12-21
description: updated
Seth Kinast (seth) on 2005-12-22
Changed in kdebase:
assignee: nobody → kubuntu-team
Jonathan Jesse (jjesse) wrote :

More information on this bug:

If I go to https://launchpad.net/people/jjesse and then select login, my password is auto-filled in. If I go to https://launchpad.net and then select login my password is filled in

I have not had any issues w/ my amazon account

Jonathan Jesse (jjesse) wrote :

Currently having no problems with either launchpad, or amazon or any sites with Konq remembering passwords. Running on Kubuntu 6.06 LTS. Could the orginal reporter please verify if they are still having problems?

Thanks,

Jonathan

Changed in kdebase:
status: Unconfirmed → Needs Info
Jorge Bernal (koke) wrote :

Actually I don't have KDE installed now. Maybe it was some configuration problem, so I think this can be closed

Frode M. Døving (frode) wrote :

I can not reproduce this either. Running Kubuntu 6.06 LTS. Closing as Jonathan and myself could not reproduce.

Changed in kdebase:
status: Needs Info → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: launchpad
Nikita Zlobin (nick87720z) wrote :

Hello. I have this bug.
Konqueror 4.10.2 (from kubuntu-backport ppa), ubuntu 12.04

Not sure, is it good, to report if when causer is from ppa.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers