dolphin does not allow files with names with ? or : to be copied

Bug #367989 reported by Paul Gevers on 2009-04-27
2
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kdebase

When I try to copy a file with a "?" or a ":" (and probably others) in the file name dolphin complains that:
"""
Could not write to /path/to/file.
"""

Although I understand that such filename are slightly difficult, they are valid names and I like to be able to copy them.

I converted my CD collection to MP3 but I can not easily copy them to my MP3-player because names including those characters block the rest of the file transport.

So, either allow those files to be copied, or allow them to be skipped and *continue* with the rest of the copying.

Kind regards
Paul

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: dolphin 4:4.2.2-0ubuntu4
SourcePackage: kdebase
Uname: Linux 2.6.28-11-generic i686

Paul Gevers (paul-climbing) wrote :

'@' is also invalid.

Jeff Folsom

Paul Gevers wrote:
> ** Attachment added: "Dependencies.txt"
> http://launchpadlibrarian.net/26030276/Dependencies.txt
>
> ** Attachment added: "ProcEnviron.txt"
> http://launchpadlibrarian.net/26030278/ProcEnviron.txt
>
>

Jonathan Thomas (echidnaman) wrote :

I cannot reproduce this in KDE 4.3, so there's a good chance that this has been fixed. Can anyone confirm?

Changed in kdebase (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Paul Gevers (paul-climbing) wrote :

I cannot reproduce it anymore after upgrade to the backports from
https://launchpad.net/~kubuntu-ppa/+archive/backports

With kind regards
Paul

Jonathan Thomas wrote:
> I cannot reproduce this in KDE 4.3, so there's a good chance that this
> has been fixed. Can anyone confirm?
>
> ** Changed in: kdebase (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: kdebase (Ubuntu)
> Status: New => Incomplete
>

Jonathan Thomas (echidnaman) wrote :

Cool, thanks for testing.

Changed in kdebase (Ubuntu):
status: Incomplete → Fix Released
Paul Gevers (paul-climbing) wrote :

I finally found out what trigger my original bug. It was when I copied the files to a vfat filesystem. It would be great when dolphin would suggest renaming the files or explaining WHY it could not write the file.

BTW: it looks currently that dolphin does copy the rest of the files nevertheless.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers