Konsole Shell Refused to Start after 8.10 -> 9.04 upgrade

Bug #367608 reported by z_mikowski on 2009-04-26
2
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: konsole

Kubuntu Jaunty 9.04
konsole 4:4.2.2-0ubuntu4

BACKGROUND:
Konsole was working fine in 8.10. I upgraded to 9.04. After uneventful upgrade, I started Konsole (using all launch methods - Alt-F2, K menu, virtual terminal)

EXPECTED RESULT:
The bash shell prompt should show in the Konsole and one should be able to interact with it.

ACTUAL RESULTS:
The Konsole window would open, but the cursor would be stuck in the upper RH corner, and nothing could affect it.

TRIAGE:
I could still access virtual terminals via Alt-Ctrl-Fn, so I launched Konsole from there and watched the error messages:

$ export DISPLAY=:0.0
$ konsole

I got 3 lines of errors, and the first appeared to be the most important -- something about not being able to attach to terminal. As I ran this on a tty, I am unable at this time to retrieve the errors - I may be able to recreate later.

I tried again as root:

$ xhost +
$ sudo su root
# export DISPLAY=:0.0
# konsole

And it worked fine. Here is what I did to triage the problem:

$ sudo usermod -a -G tty username

This appears to have something to do with /dev/pty* nodes; on my laptop (which I updated as well) these don't exist and neither does this problem. On my desktop - which had the problem -- /dev/pty* and /dev/tty* nodes both have ownership and permissions as follows:

crw-rw---- 1 root tty 2, 173 2009-04-26 13:14 /dev/ptyzd
crw-rw---- 1 root tty 2, 174 2009-04-26 13:14 /dev/ptyze

crw--w---- 1 root root 4, 0 2009-04-26 13:14 /dev/tty0
crw------- 1 user tty 4, 1 2009-04-26 14:21 /dev/tty1

I do not know if this is an appropriate fix. Please review and advise.

dsurber (dnsurber) wrote :
Download full text (3.8 KiB)

I am seeing the same problem. Same upgrade. Different details.

> konsole -v
Qt: 4.5.0
KDE: 4.2.2 (KDE 4.2.2)
Konsole: 2.2.2

 Start Konsole from Kmenu and a tab appears labeled "Konsole" but nothing else happens. Dashboard acts as though the tab isn't there and after a bit it goes away.
Attempted to start Konsole via Alt-F2.

> konsole
QFSFileEngine::open: No file name specified
konsole(9833) Konsole::KeyboardTranslatorManager::findTranslator: Unable to load translator "vt420pc"
konsole(9833): Attempt to use QAction "change-profile" with KXMLGUIFactory!
<unknown program name>(9832)/: Communication problem with "konsole" , it probably crashed.
Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

Which then brought up a crash notification with the following:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
... many similar lines deleted ...
(no debugging symbols found)
0xb7f0f430 in __kernel_vsyscall ()
[Current thread is 0 (process 9833)]

Thread 1 (Thread 0xb5e08b50 (LWP 9833)):
#0 0xb7f0f430 in __kernel_vsyscall ()
#1 0xb6478780 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2 0xb64785be in sleep () from /lib/tls/i686/cmov/libc.so.6
#3 0xb78f88b2 in ?? () from /usr/lib/libkdeui.so.5
#4 0xb78f9274 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
#5 <signal handler called>
#6 0xb7e7b73c in ?? () from /usr/lib/libkdeinit4_konsole.so
#7 0xb7ed8fe3 in ?? () from /usr/lib/libkdeinit4_konsole.so
#8 0xb7ea10d3 in Konsole::Session::run () from /usr/lib/libkdeinit4_konsole.so
#9 0xb7edc7a1 in ?? () from /usr/lib/libkdeinit4_konsole.so
#10 0xb7edcd3a in ?? () from /usr/lib/libkdeinit4_konsole.so
#11 0xb7891e66 in ?? () from /usr/lib/libkdeui.so.5
#12 0xb789005e in ?? () from /usr/lib/libkdeui.so.5
#13 0xb7451d7a in ?? () from /usr/lib/libQtDBus.so.4
#14 0xb7452f92 in ?? () from /usr/lib/libQtDBus.so.4
#15 0xb7453501 in ?? () from /usr/lib/libQtDBus.so.4
#16 0xb74539fa in ?? () from /usr/lib/libQtDBus.so.4
#17 0xb73493a0 in QObject::event () from /usr/lib/libQtCore.so.4
#18 0xb73383db in QCoreApplication::event () from /usr/lib/libQtCore.so.4
#19 0xb68ee409 in QApplication::event () from /usr/lib/libQtGui.so.4
#20 0xb68eaf2c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#21 0xb68f322e in QApplication::notify () from /usr/lib/libQtGui.so.4
#22 0xb788894d in KApplication::notify () from /usr/lib/libkdeui.so.5
#23 0xb7338a3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#24 0xb7339695 in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#25 0xb733988d in QCoreApplication::sendPostedEvents () from /usr/lib/libQtCore.so.4
#26 0xb73647ef in ?? () from /usr/lib/libQtCore.so.4
#27 0xb6171b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0xb61750eb in ?? () from /usr/lib/libglib-2.0.so.0
#29 0xb6175268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0xb7364438 in QEventDispatch...

Read more...

Clay Weber (claydoh) on 2009-04-29
Changed in kdebase (Ubuntu):
status: New → Confirmed
z_mikowski (z-mikowski) wrote :

I now have updated my fourth computer to Jaunty. And I had trouble with Konsole, again. The update was uneventful, and the problem occurred as described in comment 1.

However, the pty* devices did not exist this time. Trying to run konsole from a virtual terminal resulted in warnings about flow control, and could not connect to dbus. Again, I am sorry but the exact message was lost since I cannot cut and paste from my virtual terminal, and it has scrolled off the display after I performed the fix.

I found a strong hint for at least an interim fix here:

http://www.splatdot.com/2009/04/24/ubuntu-904-jaunty-jackalope-upgrade-notes

See the notes about adding /dev/pts into the fstab. Specifically, adding this line to /etc/fstab:

devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=620 0 0

and then running in a virtual terminal:

$ sudo mount -a

solved the problem. Apparently one needs to reorder the init scripts to make sure it (and my RAID -- another story) work on reboot. I noticed that /dev/pty* devices still do not exist, but that is not a worry to me. Seems like a much more appropriate and less risky fix than adding a user to a group.

Hope this helps.

z_mikowski (z-mikowski) wrote :

There appears very much related to this bug:

https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/338071

In fact, it may be a complete duplicate. This is from Dean's notes here:

http://www.splatdot.com/2009/05/02/ubuntu-904-jaunty-jackalope-problems-fixed

I removed myself from the tty group, and ran the named script. Will report back on success/failure after logging out and back in.

z_mikowski (z-mikowski) wrote :

Success! I propose we call this a duplicate of bug 338071. Confirmed I am no longer in tty group, but Konsole works as expected.

Also, I suggest to raise the importance of 338071. This omission seems to be biting people in numerous apps across Gnome and Kubuntu.

z_mikowski (z-mikowski) wrote :

Confirmed Fix:

The link in /etc/rcS.d/S11... as outlined in bug 338071 fixes the issue after reboot. Explicitly:

* Ensure /etc/init.d/mountdevsubfs.sh exists (it should)
* Symlink in /etc/rcS.d as below:

# cd /etc/rcS.d
# sudo \
  ln -s ../init.d/mountdevsubfs.sh S11mountdevsubfs.sh

This will fix the problem on reboot. You may also run the script by hand in the virtual terminal to fix:

# /etc/init.d/mountdevsubfs.sh start

* There is no need for any other fix; explicity, no need to add a /dev/pts entry in /etc/fstab; and no need to add users to groups. This single fix solves all problems I have found with Konsole startup.

dsurber (dnsurber) wrote :

Perhaps the problem encountered by the original filer is a dup of bug 338071, but the problem I am hitting is not. mountdevbufs.sh and S11mountdevbufs.sh both exist. Running mountdevbufs.sh does not fix the problem. If this bug is changed to a dup of 338071 I will file a new bug with the details outlined in my comment above. https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/367608/comments/1

dsurber (dnsurber) wrote :

The problem I encountered is not a duplicate. It is also not the same as the original filer's. See http://ubuntuforums.org/showthread.php?t=1138091 for the resolution to the problem I encountered.

guanche (guanche-celsere) wrote :

I can also confirm that the problem is not solved by the proposed mountdevbufs.sh-based fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers