libjack0.80.0-0 removed from unstable; rebuild required

Bug #19854 reported by Debian Bug Importer
8
Affects Status Importance Assigned to Milestone
kdebase (Debian)
Fix Released
Unknown
kdebase (Ubuntu)
High
Jonathan Riddell

Bug Description

Automatically imported from Debian bug report #317203 http://bugs.debian.org/317203

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #317203 http://bugs.debian.org/317203

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (4.5 KiB)

Message-Id: <20050706213344.88F3C841D@kermit>
Date: Wed, 06 Jul 2005 22:21:30 +0200
From: Robert Jordens <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: libjack0.80.0-0 removed from unstable; rebuild required

Package: kdebase
Version: unknown
Severity: serious
Tags: sid
Justification: uninstallable in unstable (policy 5.3)

Hi!

A new release of jack-audio-connection-kit (0.100.0-2) has been uploaded
to Debian unstable. The old library libjack0.80.0-0 (and
libjack0.80.0-dev) have been removed and replaced with libjack0.100.0-0
and libjack0.100.0-dev since the API changed in some parts. For most
packages that means a simple rebuild.

Since libjack0.80.0 has been removed from unstable, this is a
release-critical issue.

A few notes about how to resolve this bug:

   1. Please Build-Depend only on libjack0.100.0-dev. Build-Depending
   on libjack-dev as a virtual alternative allows the autobuilders to
   build against the old libjack0.80.0 if they find it. (Versioned
   virtual dependencies probably don't work.)

   2. There are some packages (like for example xmms-jackasyn) which
   "accidently" obtain a dependency on libjack0.80.0-0 but do not
   Build-Depend on it. In my opinion this is incorrect. But if you want
   to maintain that indirect dependency, you will have to coordinate
   with the package's maintainer whose package you are build-depending
   on (libjackasyn-dev in the case of xmms-jackasyn) and and only upload
   your package (xmms-jackasyn; with a suitable _versioned_
   build-dependency on the other package, libjackasy-dev) iff the other
   package has already been uploaded (and built on as many architectures
   as possible to lighten the pressure of failed builds). =20
  =20
   3. If this transition collides with the C++ transition for your
   package (because it may be/contain a C++ library), then please follow
   the timeline of the C++ transition instead of this one.

(Thanks to Adeodato Sim=C3=B3 for these hints).

A list of the packages for each maintainer and a list of the affected
source packages has been attached.

 Robert.

Guenter Geiger (Debian/GNU) <email address hidden>
    hydrogen
    ladcca-bin
    ladccad
    libjackasyn0
    meterbridge
    puredata
    qjackctl
    rezound
    seq24
    snd-gtk
    sooperlooper
    stk

Enrique Robledo Arnuncio <email address hidden>
    freqtweak
    rosegarden4
    tapiir

Paul Brossier <email address hidden>
    supercollider
    xmms-jackasyn

Ben Burton <email address hidden>
    konq-plugins
    kpresenter
    kscreensaver
    noatun-plugins

Chris Butler <email address hidden>
    spiralsynthmodular

Debian Qt/KDE Maintainers <email address hidden>
    akode
    artsbuilder
    juk
    kaboodle
    kdelibs4
    krec
    kwifimanager
    libarts1-audiofile
    libarts1-mpeglib
    libkonq4
    noatun

Free Ekanayaka <email address hidden>
    ams
    brutefir
    creox
    horgand
    jackeq

Free Ekanayaka <email address hidden>
    amsynth

Guenter Geiger <email address hidden>
    jack-rack

Henrique de Moraes Holschuh <email address hidden>
    timidity

Robert Jordens <email address hidden>
    jack-tools

Daniel Kobras <email address hidden>
   ...

Read more...

Revision history for this message
In , Dato Simó (dato) wrote : Marking this bug as fixed

# Will be completely fixed when 3.4.2-1 gets into sid
reassign 317203 libkonq4 4:3.3.2-1
close 317203 4:3.4.1-1
thanks

* Robert Jordens [Wed, 06 Jul 2005 22:21:30 +0200]:

> Package: kdebase
> Version: unknown
> Severity: serious
> Tags: sid
> Justification: uninstallable in unstable (policy 5.3)

--
Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621

Don't worry about what anybody else is going to do. The best way to
predict the future is to invent it.
                -- Alan Kay

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 25 Aug 2005 11:32:17 +0200
From: Adeodato =?utf-8?B?U2ltw7M=?= <email address hidden>
To: <email address hidden>
Subject: Marking this bug as fixed

# Will be completely fixed when 3.4.2-1 gets into sid
reassign 317203 libkonq4 4:3.3.2-1
close 317203 4:3.4.1-1
thanks

* Robert Jordens [Wed, 06 Jul 2005 22:21:30 +0200]:

> Package: kdebase
> Version: unknown
> Severity: serious
> Tags: sid
> Justification: uninstallable in unstable (policy 5.3)

--
Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621

Don't worry about what anybody else is going to do. The best way to
predict the future is to invent it.
                -- Alan Kay

Revision history for this message
Carthik Sharma (carthik) wrote :

Fixed in version libkonq4/4:3.4.1-1 in Debian. Fix present in Dapper. Closing.

Changed in kdebase:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.