Root instance of konqueror does not allow for editing files

Bug #158028 reported by Ian MacGregor on 2007-10-28
4
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: konqueror

System:
I'm using Kubuntu 7.10 installed from the Desktop livecd and the system is fully updated.

Desired action:
In a root instance of the konqueror file manager, right-click on a file and choose an editor to edit the file as root ("open with ..").

Product:
Changes to the file were disallowed due to insufficient privileges

Steps to reproduce this bug:
1) Launch a root instance of the Konqueror file manager, run: kdesu -c 'konqueror --profile filemanagement /root'
2) In the new konqueror window, right-click on any text file and choose "Open with" > Kate or any other text editor
3) The file will be opened in the text editor and you can make changes to the file, but saving will not be allowed due to insufficient privileges

It is my opinion that a root instance of the konqueror file manager should also allow root to edit files via the context menu of that window. To be able to use Kate to edit a file as root from a root instance of Konqueror in Gutsy, I had to write a new service menu as follows:

[Desktop Entry]
Version=0.1
Encoding=UTF-8
Actions=EditWithRootKate
ServiceTypes=text/*,application/x-desktop

[Desktop Action EditWithRootKate]
Name=Edit with Kate (Root)
Icon=kgpg
Exec=kdesu kate %U

I write a lot of service menus but someone new to Kubuntu won't understand why they can't edit a file via the context menu of a root instance of konqueror.

Ian MacGregor (ardchoille42) wrote :

I wrote a better service menu for this. For anyone who wants to have this functionality, download the following file and place it in ~/.kde/share/apps/konqueror/servicemenus/

auspex (auspex) wrote :

I agree, this is a pain in the butt. Thanks for the workaround.

Guillaume Martres (smarter) wrote :

I don't have this problem with Kubuntu 7.10/KDE 3.5.8, I can read and write file in my /root with kate when I launch konqueror with kdesu, and if I don't use kdesu I can't even access to the /root directory.

Guillaume Martres (smarter) wrote :

And if you want to edit a file as root you already have the service menu /usr/share/apps/konqueror/servicemenus/edit-as-root.desktop

auspex (auspex) wrote :

Well, it seems to have been fixed at some point, because I can now run either konqueror or kfmclient via kdesu and actions seem to execute as root.

Changed in kdebase:
status: New → Fix Released
Ian MacGregor (ardchoille42) wrote :

Yes, It's been fixed. My gratitude to whomever fixed this bug :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers