KControl and KInfoCenter are empty after Gutsy upgrade

Bug #152325 reported by Luke Plant
30
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

A day after upgrading from Feisty to Gutsy RC, kcontrol and kinfocenter have no items in them at all. My 'lost and found' folder in the main menu system seems to have inherited most of the missing items though!

This problem is reported widely on the internet, I've yet to find an easy solution (some suggest purging and resinstall kdebase-data, which sounds like it could be a pain, as you have to reinstall lots of other things to)

Revision history for this message
Luke Plant (spookylukey) wrote :

Workaround:

1) create empty directory 'temp'
2) Extract contents of deb manually, something like
dpkg-deb -x /var/cache/apt/archives/kdebase-data_4%3a3.5.8-0ubuntu1_all.deb temp
3) Then copy over the file you need
sudo cp temp/etc/xdg/menus/applications-merged/kde-essential.menu /etc/xdg/menus/applications-merged/

I really don't know why 'dpkg --unpack' and 'aptitude reinstall' are not capable of doing this!

Revision history for this message
Luke Plant (spookylukey) wrote :

After another update (my kdebase-data is now at 4:3.5.8-0ubuntu2 this happened again.

Revision history for this message
MikeC (michael-cereda) wrote :

I found this workaround..
Just type:
sudo chmod 777 -R /etc/xdg/menus/

That's All!

Revision history for this message
viking777 (viking-f2s) wrote :

My fresh install of Hardy has exactly the same problem as described here, kcontrol is empty and all the modules that should be in there are under 'Lost and Found' in the KDE menu.

Revision history for this message
Ralph Janke (txwikinger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in kdebase.

Revision history for this message
Luke Plant (spookylukey) wrote :

This bug is still biting me -- after a recent update, to kdebase-data 4:3.5.8-0ubuntu2.1l from gutsy-updates, this occurred again. I discovered that /etc/xdg/menus/application-merged was a symlink to /etc/xdg/menus/kde-applications-merged/applications-merged . After removing this symlink, I still have the problem that 'aptitude reinstall' simply does not restore kde-essential.menu, but I found that this command line works:

sudo dpkg-deb -x /var/cache/apt/archives/kdebase-data_4%3a3.5.8-0ubuntu2.1_all.deb /

It may be that the problem will not recur after this, seeing as the symlink has been removed.

Revision history for this message
Jared Schlicht (jschlicht) wrote : Re: [Bug 152325] Re: KControl and KInfoCenter are empty after Gutsy upgrade

On Sunday January 13 2008 3:09:33 pm Luke Plant wrote:
> This bug is still biting me -- after a recent update, to kdebase-data
> 4:3.5.8-0ubuntu2.1l from gutsy-updates, this occurred again. I
> discovered that /etc/xdg/menus/application-merged was a symlink to
> /etc/xdg/menus/kde-applications-merged/applications-merged . After
> removing this symlink, I still have the problem that 'aptitude
> reinstall' simply does not restore kde-essential.menu, but I found that
> this command line works:
>
> sudo dpkg-deb -x /var/cache/apt/archives/kdebase-
> data_4%3a3.5.8-0ubuntu2.1_all.deb /
>
> It may be that the problem will not recur after this, seeing as the
> symlink has been removed.

I've been away for a while. I tried out that command, no good.

/etc/xdg/menus/application-merged is *NOT* a symlink on my install.
Extracting the deb does not help.

I seem to have a kde-essential.menu now, however, it has not fixed the
problem. I suppose I'll have to download the Alpha3 CD and see if the
problem is still there.

Changed in kdebase:
status: New → Confirmed
Revision history for this message
Jared Schlicht (jschlicht) wrote :

This is now fixed in Hardy. Please close this bug.

Revision history for this message
Jared Schlicht (jschlicht) wrote :

Sorry, I thought that this was my own bug report. My mistake.

Still, it is fixed for me.

Revision history for this message
Loye Young (loyeyoung) wrote :

CHANGING THE OCTAL MODE OF THE /etc/xdg/menus DIRECTORY, AS SUGGESTED ABOVE, IS INSECURE AND A BAD IDEA! DON'T DO IT!

The following is a better solution to the problem (more of a work around, really, because the problem shouldn't be there in the first place):

# sudo ln /etc/xdg/menus/kde-applications-merged/kde-essential.menu /etc/xdg/menus/applications-merged/

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://www.iycc.net

Revision history for this message
Anita (a-lewis) wrote :

I was missing kde-essential.menu in a current Gutsy ubuntu with kubuntu-desktop installed. I tried reinstalling kdebase-data which did not give me the file. I then did Luke's recommended:

sudo dpkg-deb -x /var/cache/apt/archives/kdebase-data_4%3a3.5.8-0ubuntu2.2_all.deb /

That gives me the file although it did not remove the symlink, applications-merged to kde-applications-merged. KControl now works.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Reported fixed in Hardy.

Changed in kdebase:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers