kdesktop kde crash on startup

Bug #149261 reported by jwlockhart on 2007-10-05
6
Affects Status Importance Assigned to Milestone
KDE Base
Invalid
High
kdebase (Ubuntu)
Low
Richard Johnson

Bug Description

after making a clean install of kubuntu 7.04 using a md5sum hash verified .iso burnt to disk, on initial startup after installing 7.04, before running any additional programs, recieved

"the application KDesktop (kdesktop) crashed and caused the signal 6 (SIGABRT)"

In full the backtrace read as follows -

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232852768 (LWP 5781)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xffffe410 in __kernel_vsyscall ()
#7 0xb7ce4df0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8 0xb7ce6641 in abort () from /lib/tls/i686/cmov/libc.so.6
#9 0xb7ee8270 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0xb7ee5ca5 in ?? () from /usr/lib/libstdc++.so.6
#11 0xb7ee5ce2 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb7ee5e1a in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0xb7ee625e in operator new () from /usr/lib/libstdc++.so.6
#14 0xb7ee633d in operator new[] () from /usr/lib/libstdc++.so.6
#15 0xb7561dc9 in QString::setLength () from /usr/lib/libqt-mt.so.3
#16 0xb7569748 in operator>> () from /usr/lib/libqt-mt.so.3
#17 0xb7aaecfb in KIO::Slave::createSlave () from /usr/lib/libkio.so.4
#18 0xb7adfcf3 in KIO::Scheduler::createSlave () from /usr/lib/libkio.so.4
#19 0xb7afc0c6 in KIO::Scheduler::startJobDirect () from /usr/lib/libkio.so.4
#20 0xb7afc449 in KIO::Scheduler::startStep () from /usr/lib/libkio.so.4
#21 0xb7afdafc in KIO::Scheduler::qt_invoke () from /usr/lib/libkio.so.4
#22 0xb724788b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb7248330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#24 0xb75d5ba6 in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#25 0xb726f596 in QTimer::event () from /usr/lib/libqt-mt.so.3
#26 0xb71dea60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#27 0xb71e088f in QApplication::notify () from /usr/lib/libqt-mt.so.3
#28 0xb78e6ce2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#29 0xb71711e9 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#30 0xb71d14ab in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#31 0xb7185d25 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#32 0xb71f9136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#33 0xb71f8f46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#34 0xb71e0609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#35 0xb65fe816 in kdemain () from /usr/lib/libkdeinit_kdesktop.so
#36 0xb66f5464 in kdeinitmain () from /usr/lib/kde3/kdesktop.so
#37 0x0804e6bf in ?? ()
#38 0x00000001 in ?? ()
#39 0x08077740 in ?? ()
#40 0x00000001 in ?? ()
#41 0x00000000 in ?? ()

Richard Johnson (nixternal) wrote :

Did this occur just once or has it happened on multiple occasions?

Confirming due to upstream report.

Changed in kubuntu-meta:
assignee: nobody → nixternal
importance: Undecided → Low
status: New → Confirmed
Changed in kdebase:
status: Unknown → New
Stefan Bader (smb) wrote :

I got this with Kubuntu-Desktop-amd64 (8.04 2008-04-17.1) after a clean install from CD (not via the live system). During my test I also got this only once (up to now). So it still seems to be there but quite rare. Login after logoff succeeded without problems.

Changed in kdebase:
status: New → Invalid
Jonathan Thomas (echidnaman) wrote :

This shouldn't be an issue in Kubuntu Intrepid (8.10) since KDesktop is no more. (replaced by Plasma)
Thanks for the bug report, and thanks for your interest to help Kubuntu!

Changed in kdebase:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.