FN Keys for LCD brightness since kernel 2.6.22-12-generic x86_64

Bug #146280 reported by Christian Schneiker on 2007-09-28
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

After an upgrade from kernel 2.6.22-10 from the tribe5 cd to kernel 2.6.22-12 on my Dell XPS M1330 with 64Bit and Core2Duo the FN Key and UP/DOWN for brightness controll aren't working any more after boot. When I hibernate and wake up again, all is working fine.

Here lsmod output for both normal boot and hibernate.

normal boot

Matthew Garrett (mjg59) wrote :

Are you using KDE or Gnome as your desktop?

I'm using KDE.

Rick Clark (dendrobates) wrote :

Same issue here. On a Dell 1505n with Feisty preloaded. When I upgraded to Gutsy tribe 5, The brightness fn keys stopped working. All other fn key combos work fine.

The brightness slider in the KDE power manager does function however.

I am also using kubuntu. I'm not sure that this is kernel related, though.

Rick Clark (dendrobates) wrote :

Oh, I'm using 32 bit.

It's working with kernel 2.6.22-10. Though it could be kernel related.

Rick Clark (dendrobates) wrote :

Still not working for me as of:
2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

This looks like a dup of bug #145337. I had same issue on xps 1330 with gutsy 32-bit, problem solved as of 9/30 updates.

I've made the update and nothing is solved for me.

LEVIS Cyril (atlas95) wrote :

This is solved for me !

Now how to suspend to disk ???

I can suspend to ram if i blacklist usbvision and uvcvideo (but sometimes this failed and i don't know why)

Solved for Gutsy x86. Not following x86_64 at this time.

Changed in dell:
status: New → Invalid

What have you done that it works for you? For me it isn't working with amd64 nor with x86.

I installed the latest Gutsy image from http://cdimages.ubuntu.com/daily-live and performed all updates. Check your Power Management Preferences and verify you don't have anything screwy. What video card are you using?

My video card is a nvidia 8400 GS but it's also not working with nv module.

What kernel version do you use? 2.6.22-12-generic or 2.6.22-12-386?

LEVIS Cyril (atlas95) wrote :

I use nvidia drivers from nvdia website for get it working for me.

lostangel78 (lostangel78) wrote :

Try typing this command in a terminal

 xgamma -gamma 0.75

 I have posted my own solution here:

 http://ubuntuforums.org/showthread.php?p=4168042#post4168042

This sounds like Bug #25931which recently received a fix. Is this still happening with a current Gutsy system?

Changed in hal:
status: New → Incomplete

Sorry for the bug spam. Too many tabs open, the above comment isn't meant for this bug.

Changed in hal:
status: Incomplete → New
Harald Sitter (apachelogger) wrote :

Is this still an issue in Kubuntu Intrepid?

Changed in kdebase:
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in kdebase:
status: Incomplete → Invalid
Changed in hal:
status: New → Invalid
Changed in somerville:
status: New → Invalid
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305648

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers