Ubuntu

[apport] kfontinst crashed with SIGSEGV in FT_Get_PS_Font_Info()

Reported by Franck Goethals on 2007-04-22
222
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kdebase

Happened while installing a font found on the site http://www.dafont.com/fr/ .

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Sat Apr 21 19:54:24 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/kfontinst
Package: kcontrol 4:3.5.6-0ubuntu20
PackageArchitecture: i386
ProcCmdline: kfontinst -rx /home/franck/.fonts/
ProcCwd: /home/franck
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: kdebase
Stacktrace:
 #0 0xb7ef6e13 in FT_Get_PS_Font_Info () from /usr/lib/libfreetype.so.6
 #1 0x080559af in ?? ()
 #2 0xb7906a78 in ?? () from /usr/lib/libkdecore.so.4
 #3 0xbfab3ae4 in ?? ()
 #4 0x00000000 in ?? ()
StacktraceTop:
 FT_Get_PS_Font_Info () from /usr/lib/libfreetype.so.6
 ?? ()
 ?? () from /usr/lib/libkdecore.so.4
 ?? ()
 ?? ()
Uname: Linux pc-franck 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Franck Goethals (lemontchauve) wrote :

StacktraceTop:FT_Get_PS_Font_Info (face=0xb7906a78, afont_info=0xbfab3ae4) at /build/buildd/freetype-2.2.1/freetype-2.2.1/src/base/fttype1.c:39
KFI::CFontEngine::openFontFt (this=0xbfab3d48, file=@0xbfab3c8c) at /build/buildd/kdebase-3.5.6/./kcontrol/kfontinst/kfontinst/FontEngine.cpp:763
KFI::CFontEngine::openFont (this=0xbfab3d48, file=@0xbfab3c8c, face=0) at /build/buildd/kdebase-3.5.6/./kcontrol/kfontinst/kfontinst/FontEngine.cpp:136
KFI::CXConfig::createFontsDotDir (dir=@0xbfab3d94, fe=@0xbfab3d48) at /build/buildd/kdebase-3.5.6/./kcontrol/kfontinst/kfontinst/XConfig.cpp:794
KFI::CXConfig::configureDir (dir=@0xbfab3d94, fe=@0xbfab3d48) at /build/buildd/kdebase-3.5.6/./kcontrol/kfontinst/kfontinst/XConfig.cpp:65

Changed in kdebase:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Jonathan Thomas (echidnaman) wrote :

Due to the KDE4 rewrite, KDE4/Kubuntu Intrepid's kfontinst is unlikely to have this same crash, and at the least the rewrite would change the stacktrace of a similar crash. Due to these reasons I'm closing this bug as fixed. Please report if you have any problems with font installation in Kubuntu Intrepid or KDE4 in general.

Changed in kdebase:
status: Confirmed → Fix Released
To post a comment you must log in.