System Settings changes configuration files .fonts.conf and .fonts/ even without me applying any changes

Bug #69085 reported by Frank Siegert on 2006-10-29
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Base
Invalid
Medium
kdebase-workspace (Ubuntu)
Wishlist
Richard Johnson

Bug Description

When I open System Settings -- Appearance (only open, not even change anything, and of course not apply!), it applies some changes to my user settings, which make my fonts look blurry.

The first unwanted change is in .kde/share/config/kdeglobals (see attached kdeglobals.diff).
The second change is the addition of a ~/.fonts directory and corresponding ~/.fonts.conf (see attached fonts.diff) and apparently running fc-cache.

Both these changes have to be undone (by editing kdeglobals accordingly, removing .fonts.* and running fc-cache), then after logging out and back in fonts are back to normal state (it is not enough, to only undo one of these two changes). The difference between the states can be seen in the two attached screenshots.

The same happens, when I open kcontrol and its Appearance & Themes -- Fonts section. It also happens directly on the Edgy Live-CD, so it should be fairly easy to test and confirm.

Summary:
1. (minor) System Settings should not make any changes when I don't hit Apply.
2. (major) It should not create a setting and .fonts.conf which makes fonts look blurry. I have not exactly determined yet, why fonts look blurry if a ~/.fonts.conf exists (it doesn't even have to contain anything between <fontconfig> and </fontconfig>). This part of the bug might belong to another program, e.g. fontconfig.

Frank Siegert (fsiegert) wrote :
Frank Siegert (fsiegert) wrote :
Frank Siegert (fsiegert) wrote :
Frank Siegert (fsiegert) wrote :
Daniel Musketa (daniel-musketa) wrote :

Same behavior here on Kubuntu 6.10 (video driver "fglrx").

T (tws2k3) wrote :

I can confirm I get this exact problem. I did two clean installs on separate machines and as soon as I changed some appearance settings my fonts became blurry, especially in Konsole. I found that I have to remove the line "XftHintStyle=hintmedium" from the [General] section of ~/.kde/share/config/kdeglobals and delete the file .fonts.conf file to get the fonts to be clear again.

The only difference in my case is that if I go back to change any settings, .fonts.conf is written to, but kdeglobals is not. Also when .fonts.conf is altered afterwards my fonts are fine. This only seems to effect my machines after a clean install and I'm going in to change appearance settings for the first time. I've attached a comparison shot of before and after the fonts change.

Richard Johnson (nixternal) wrote :

Is anyone still experiencing this issue? I am unable to confirm this issue and never remember seeing this issue prior. Thanks!

Changed in kde-systemsettings:
assignee: nobody → nixternal
status: New → Incomplete
Frank Siegert (fsiegert) wrote :

I cannot test on the same laptop as before, and with my new laptop I don't see blurry fonts anymore on 7.10.
But the system settings still write out ".fonts.conf" and ".fonts/" even if I don't change or apply anything (you should be able to confirm that?). I don't know, whether this can still screw up somebody's setup. So if you are sure that this does not hurt, and nobody else sees blurry fonts, go ahead and close this bug.

Changed in kde-systemsettings:
status: Incomplete → Confirmed
Richard Johnson (nixternal) wrote :

The only thing I can confirm in this report is the creation of ~/.fonts/ an ~/.fonts.config. The .fonts.config is created with the settings that are in system settings. I cannot confirm any blurry effects after logging out and back in at all with this.

If you want to, change the report to system settings creating the .fonts/ and .fonts.config and then we can wishlist it and look into it. But at this time, it isn't creating any issues at all.

Changed in kde-systemsettings:
status: Confirmed → Incomplete
Frank Siegert (fsiegert) wrote :

I agree and have changed the title. I don't seem to be allowed to change it to wishlist status, so I have set it back to confirmed and leave it to you to wishlist it.

Changed in kde-systemsettings:
status: Incomplete → Confirmed
Richard Johnson (nixternal) wrote :

Good deal Frank, I will take a look at the code and see why it is creating those files. You would think if those files are meant to be there in the first place, they would be installed from the get go. I will look into this, this very well could turn out being a real bug more so than a wishlist item. Thanks again!

Changed in kde-systemsettings:
importance: Undecided → Wishlist

The weird font antialising / blurry fonts problem is discussed in Bug #69091 "Fonts look blurry if ~/.fonts.conf (even empty one) is present".

PJSingh5000 (pjsingh5000) wrote :

I am experiencing this problem in Hardy. The systemsettings | Appearance option creates a local ~/.fonts.conf file. The settings in this file do not correspond to the options I select when I execute:
$ sudo dpkg-reconfigure fontconfig-config --force
   Select:
 Font tuning method for screen: Autohinter
 Enable subpixel rendering for screen: Automatic
 Enable bitmapped fonts by default? No
As a result the fonts revert to a fuzzy appearance. To correct this, I have to manually delete the local ~/.fonts.conf each time I access the Appearance option from systemsettings.

Brandon Applegate (vom) wrote :

This problem seems reversed in Hardy (Kubuntu). By default (testing right now from the LiveCD) fonts are what is reported as "blurry". Upon entering into System Settings - Appearance - Fonts my .fonts.conf is created, and on the next login the fonts clear up. So it seems that the issue is now reversed. It is broke by default and fixed by simply going into System Settings (?!?!). So we've had a fixed then broken and now a broken then fixed. I wish I could do something to contribute beyond this comment to get us to a fixed then still fixed. :)

  • unnamed Edit (1.4 KiB, text/html; charset=ISO-8859-1)

Did you have the source code in order to solve that issue ?

On 6/11/08, Brandon Applegate <email address hidden> wrote:
>
> This problem seems reversed in Hardy (Kubuntu). By default (testing
> right now from the LiveCD) fonts are what is reported as "blurry". Upon
> entering into System Settings - Appearance - Fonts my .fonts.conf is
> created, and on the next login the fonts clear up. So it seems that the
> issue is now reversed. It is broke by default and fixed by simply going
> into System Settings (?!?!). So we've had a fixed then broken and now a
> broken then fixed. I wish I could do something to contribute beyond
> this comment to get us to a fixed then still fixed. :)
>
>
> --
> System Settings changes configuration files .fonts.conf and .fonts/ even
> without me applying any changes
> https://bugs.launchpad.net/bugs/69085
> You received this bug notification because you are subscribed to Ubuntu.
>

--
Atentamente :

Francisco Miguel Rincon Garcia

Jonathan Thomas (echidnaman) wrote :

Is this still an issue in Intrepid?

Changed in kde-systemsettings:
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in kde-systemsettings:
status: Incomplete → Invalid
Changed in kdebase:
status: Unknown → Invalid
Changed in kdebase:
status: Invalid → Unknown
Craig Magina (craig.magina) wrote :

This is still an issue in natty, amd64 fully updated as of 01/31/2011. I also updated bug #69091 as it also caused my fonts to lose anti-aliasing and other settings just by the creation of the fonts.conf file after I had entered the font configuration in system settings.

Changed in kdebase:
importance: Unknown → Medium
Changed in kdebase:
status: Unknown → Invalid
Ivo Anjo (knuckles) wrote :

I had exactly same issue as the one described in comment #18, on a fresh amd64 natty install done today.

If anyone stumbles onto this, you can fix it by deleting a hidden file called ".fonts.conf" on your home directory.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.