XDMCP lstening on udp6 instead of udp

Bug #58071 reported by DerekSlovin on 2006-08-29
18
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Medium
Kenny Duffus

Bug Description

XDMCP via KDE3 on dapper does not listen on ipv4, but instead ipv6.

netstat -l:
udp6 0 0 *:xdmcp *:*

Kenny Duffus (kduffus) wrote :

05:43 < seaLne> what do you have uncommented in /etc/kde3/kdm/Xaccess ?
05:44 < derekS> * CHOOSER BROADCAST #any indirect host can get a chooser
05:44 < derekS> * #any host can get a login window

Changed in kdebase:
assignee: nobody → kduffus
importance: Untriaged → Medium
Jesse R Lanninhg (stservers) wrote :

I am having this same problem. I've reproduced the same error on my main Kubuntu desktop, and separate clean installs of Ubuntu and Kubuntu 32bit and 64bit installs respectively.

root@amd2800:~# netstat -apn | grep ":177 "
udp6 0 0 :::177 :::* 5636/kdm
root@amd2800:~#

Regards,
Jesse

Jesse R Lanninhg (stservers) wrote :

I found a work-a-round for those who do not wish to use ipv6.

First disable net-pf-10 in /etc/modprobe.d/aliases by changing:

"alias net-pf-10"
to
"alias ipv6 off"
"alias net-pf-10 off"
"alias net-pf-10 ipv6 off"

and then add "blacklist" and "ipv6" to /etc/modprobe.d/blacklist

You will also need to remove or comment out all ipv6 addresses in /etc/hosts.

After that you can reboot(or possibly even restart your network, though I did not test that).

When you computer is back up type the following command in console:
ip a | grep inet6
If nothing shows up then you should be good to go.

After doing everything above, XDMCP started working on IPv4 again and as a positive side effect, I could use SCP again(didn't work before either, because SSH was listening on tcp6).

In conclusion, this doesn't look like a KDM specific problem.

Regards,
Jesse

lethargy (lethargy) wrote :

I fixed a possible similar problem with tftpd listening on IPv6, but I've not tried it with XDMCP as i've moved on now.

For more intrepid souls wishing to have a go, here's a link to the launchpad bug in question:

https://bugs.launchpad.net/ubuntu/+source/netkit-tftp/+bug/105863

Kevin Mills (ubuntu-chiron) wrote :

FWIW: I see the same thing with Edgy. Jesse's changes above disabled IPV6 and I see kdm listening on udp:177, but I still can't connect via XDMCP (and yes, I've enabled it in kdmrc, Xaccess, etc).

Kevin Mills (ubuntu-chiron) wrote :

More: I upgraded my box to Fiesty and still see the problem. I allowed the upgrade to overwrite the configuration files and then made the required changes and kdm is still on udp6:177. I just noticed that sshd is listening on tcp6:22 as well. I, again, disabled ipv6 per Jesse's suggestion and still cannot connect. Wireshark shows the XDMCP conversation happening, ending with the XDMCP Manage going across, but the Linux machine never attempts to connect back.

Richard Johnson (nixternal) wrote :

Anyone still seeing this with either Gutsy or Hardy? Kenny, do you have any input on this? I looked upstream and didn't see any similar reports for this. Thanks!

Changed in kdebase:
status: New → Incomplete
Kevin Mills (ubuntu-chiron) wrote :

With a recent update to 7.10 (sorry, I don't know which one) I am now able to connect via XDMCP. Curiously, netstat shows XDM listening on udp6:177 like before, but (for whatever reason) it is now working!

Eric B (ebischoff) wrote :

Here is a simpler workaround. Add on top of your Xaccess file the following line:

LISTEN 0.0.0.0

That will force kdm to listen to the udp4 port.

Eric B (ebischoff) wrote :

To Richard : yes, I confirm the bug on Gutsy (with KDM 3.5.8).

Changed in kdebase:
status: Incomplete → Confirmed
Jonathan Thomas (echidnaman) wrote :

Still an issue in Intrepid?

Changed in kdebase:
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in kdebase:
status: Incomplete → Invalid
Andy Rabagliati (andyr) wrote :

I bumped into this bug - actually https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/105938 (marked as a dup of this).

I found a workaround - which I document here for others.

The problem is not xdmcp - the problem is a failing dns lookup of the hostname of the machine.

I configured dnsmasq on the gdm machine, named myhost.org

In /etc/dnsmasq.conf I added this :-

local=/myhost.org/

That forces any lookups in that domain to come from /etc/hosts

xdmcp magically started working again. Just this change.

kfsone (oliver-kfs) wrote :

Also a problem in Lucid 10.4 RC, and I can't find a way to disable ipv6.

osmith@lucidb2:/etc$ netstat -an | grep 177
udp6 1784 0 :::177 :::*

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers