[Lucid] New bug: Plasma crash at KDE logout

Bug #564433 reported by Swâmi Petaramesh on 2010-04-16
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
High
kdebase-workspace (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: kdebase-workspace

Since the latest couple rounds of KDE updates (as of 2010/04/16 Lucid Beta 2) a new bug appears for me :

- Each and every KDE logout causes a KDE crashbox to appear, reporting that the plasma workspace crashed (kdeinit4 sig11)

- The logout process continues so the box closes very fast, so I can't start any bug-reporting activity from there...

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: plasma-desktop 4:4.4.2-0ubuntu12
ProcVersionSignature: Ubuntu 2.6.32-21.31-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Fri Apr 16 08:14:09 2010
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: kdebase-workspace

Søren Holm (sgh) wrote :

I can confirm that. It also happenens when rebooting.

Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Rohan Garg (rohangarg) wrote :

I was going to report this bug today but since its already reported i can just say that it happens to me to! Unfortunately there no way to get a backtrace since as soon as i start loading the backtrace the laptop shuts down/reboots

Rohan Garg (rohangarg) wrote :

By any chance do you have the wallpaper clock installed? ( version 0.4 )

Darwin Bautista (baudm) wrote :

I think this bug has something to do with the Battery widget. With the Battery widget loaded in the System Tray, quitting plasma-desktop like so:

$ kquitapp plasma-desktop

would make plasma-desktop crash. Attached is the backtrace (I currently don't have the debug packages installed).
Even though the debug information is missing, one can guess that plasma_applet_battery.so may have something to do with the crash.

To test this hypothesis, I removed all instances of the Battery widget and terminated plasma-desktop like before. plasma-desktop terminated cleanly, without any segfaults.

I also tried several other tests, placing the Battery widget in the System Tray, Panel, and on the "desktop" itself. In all tests, plasma-desktop crashed when terminated.

Can anybody else confirm my findings?

Søren Holm (sgh) wrote :

I can confirm. Removing the battery-applet completely removes the crash. Dring the removal on the applet plasma-desktop crashed. I can add that a backtrace taken when plasma-desktop crashed during logout gives the same result yours Darwin.

tags: added: iso-testing
Felix Geyer (debfx) wrote :

The crash is caused by kubuntu_101_brightness_fn_keys_and_osd.diff.
The attached patch fixes this.

Jonathan Riddell (jr) on 2010-04-23
Changed in kdebase-workspace (Ubuntu):
milestone: none → ubuntu-10.04
Changed in kdebase-workspace (Ubuntu Lucid):
importance: Undecided → High
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.4.2-0ubuntu14

---------------
kdebase-workspace (4:4.4.2-0ubuntu14) lucid; urgency=low

  * Update kubuntu_101_brightness_fn_keys_and_osd.diff from Felix Geyer,
    closes LP: #564433 'Plasma crash at KDE logout'
 -- Jonathan Riddell <email address hidden> Fri, 23 Apr 2010 13:17:36 +0200

Changed in kdebase-workspace (Ubuntu Lucid):
status: Confirmed → Fix Released
Adrian Patzak (zoiss) wrote :

I have still the same problem when logging out of KDE.
I'm not able to create a bug report because the shutdown progress is going on and the plasma workspace bug window disappears, but it still writes something regarding (kdeinit4).
I would appreciate any suggestions.

I you press CTRL-AL-F1 you can get to a text-mode console. There you can
attach gdb to kdeinit4 like this

$ gdb kdeinit4 $(pidof kdeinit4)

then gdb will be attached to the runnin kdeinit4. Now press ALT-F7 to get back
into KDE. When the crash occours press CTRL-ALT-F1 again and you will see that
gdb has catched to crash.

Adrian Patzak (zoiss) wrote :

Thank you for your answer!
I don't know if i did right, because this is new to me, but I was able to get some (hopefully helpful) information about the crash now.
I attached the file. Please tell me if I was wrong and if you got some instructions for me.

Søren Holm (sgh) wrote :

It's ok, but I really do not know how to interpret the dump.
btw. did you issue "thread apply all bt" ? it seems like 2 threads are not
enough.

Adrian Patzak (zoiss) wrote :

Sorry, but I'm not sure what you are actually talking about.
I tried to follow your instructions, so i started gnu debugger via "gdb kdeinit4 $(pidof kdeinit4)" and then i went back to logout from my kde session. When the error occured, I switchted back to tty1, but there was no further information in gdm.
Thats why I'm not able to tell you if there was a "thread apply all bt" or something like that.

Søren Holm (sgh) wrote :

No problem

When at the prompt seeing the crash type the following two lines

set logging file crashdump.txt
thread apply all bt

It should put a more complete backtrace in the file crashdump.txt

Adrian Patzak (zoiss) wrote :

Ok, I tried to get something, but I'm still not sure if I did it the right way.
When logging out of KDE, the KDE crash box appears and disappears.
After that the workspace is stuck until I quit gdm, so I switch via ctrl+alt+f1 to tty1 but nothing appended in gdm. Then I wrote:

set logging on
thread apply all bt

The result can be seen in gdb.txt.

It's not much information, but you may find anything.
If I'm still wrong please don't give up :]

Søren Holm (sgh) wrote :

Ehm .... still not enough output.

Remember that when the crash happenens you should switch immediately to tty1.

Adrian Patzak (zoiss) wrote :

I'm going back immediately. The problem is: there is no output coming at the console.
The only output comes, when I write "thread apply all bt". This output looks always similar to the given gdb.txt.

Do I need to install some more debug symbols or anything?
Any instructions in gdb ...?

Søren Holm (sgh) wrote :

Try installing kdebase-dbg

Adrian Patzak (zoiss) wrote :

Sorry, did not change anything unfortunately.
The KDE error box is not appearing every time I log off, so I try to get this error reproducible.
I will tell when i found out

koso (koso) wrote :

It looks like your problem is in clock applet (library plasma_applet_clock.so). It is part of plasma-widgets-workspace, where is also battery applet -> this package probably needs to be rebuilded against actual libraries...

Adrian Patzak (zoiss) wrote :

I just closed the clock applet and then the same KDE error box appeared:
I attached the info given at this crash.

This might have been the problem, thank you.

Vertago1 (vertago1) wrote :

"I just closed the clock applet and then the same KDE error box appeared:
I attached the info given at this crash.

This might have been the problem, thank you."

You can try logging out without the battery or clock applets to see if the error still appears, and that will give confirmation.

Adrian Patzak (zoiss) wrote :

Ok, I did not experience any KDE crash anymore when logging out.
Seems that the clock application is some kind of corrupt.
Thank you guys!

cyril (ivi610) wrote :

the bug still exists but this thread
http://ubuntuforums.org/showthread.php?p=9203854
gives a solution.
It seems the bug comes from the login manager kdm.
Switching to gdm allows logout and shutdown.

Scott Kitterman (kitterman) wrote :

That's a different bug with similar symptoms.

cyril (ivi610) wrote :

ok Scott.
I didn't manage to find the bug report for the bug I mentionned wich have similar symptoms.
Scott, do you know wich bug report is it?
Thank you!

Scott Kitterman (kitterman) wrote :

If you can't find one, file a new one.

Changed in kdebase:
status: Unknown → Invalid
Changed in kdebase:
status: Invalid → Unknown

same kind of problem on Kubuntu 10.10 since upgrading to KDE sc.4.6.0

Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.