KDM needs plymouth transition patch

Bug #540177 reported by Jonathan Riddell on 2010-03-17
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: kdebase-workspace

KDM needs a port of the GDM patch to create a smooth transition from Plymouth's splash screen.

28_plymouth_transition.patch

it also needs to detect and use the current vt from plymouth.

Related branches

Jonathan Riddell (jr) on 2010-03-17
Changed in kdebase-workspace (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
tags: added: kubuntu
Changed in kdebase-workspace (Ubuntu Lucid):
assignee: nobody → Alberto Milone (albertomilone)
Changed in kdebase-workspace (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
importance: Medium → High
Leo Milano (lmilano) wrote :

I'll provide feedbback for this, I am running Kubuntu Lucid + KMS with a Radeon HD3450.

Right now, plymouth shows perfectly at shutdown. On boot up, though, it only pops up _very_ late (about a second before KDM loads), and it's only displayed for a fraction of a second.

Cheers!

Changed in kdebase-workspace (Ubuntu Lucid):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.4.1-0ubuntu7

---------------
kdebase-workspace (4:4.4.1-0ubuntu7) lucid; urgency=low

  * Replace "-br" with "-nr" in 07_kdmrc_defaults_kubuntu.diff so that
    if possible, we prevent the xserver from clearing the screen which
    should still have the bootplash on.
  * Remove kubuntu_33_kdm_bulletproof_x.diff, obsoleted by
    kubuntu_34_kdm_plymouth_transition.diff.
  * Remove kubuntu_104_kdm_active_vt_plymouth.diff, obsoleted by
    kubuntu_34_kdm_plymouth_transition.diff.
  * Add kubuntu_34_kdm_plymouth_transition.diff which allows a smooth
    transition from Plymouth's bootsplash and integrates support for
    failsafe X (LP: #540177).
 -- Alberto Milone <email address hidden> Fri, 26 Mar 2010 16:45:03 +0100

Changed in kdebase-workspace (Ubuntu Lucid):
status: In Progress → Fix Released
Steve Langasek (vorlon) wrote :

This appears to have regressed with the upload of 4.4.2-0ubuntu1; I assume 4.4.1-0ubuntu7 was overlooked since it wasn't committed to bzr. Can someone please merge those changes back in, to give kdm a smooth transition from plymouth?

Changed in kdebase-workspace (Ubuntu Lucid):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.4.2-0ubuntu5

---------------
kdebase-workspace (4:4.4.2-0ubuntu5) lucid; urgency=low

  * Restore changes from the 4:4.4.1-0ubuntu7 upload that were inadvertently
    dropped when 4.4.2-0ubuntu1 was uploaded, refix LP: #540177
 -- Scott Kitterman <email address hidden> Thu, 01 Apr 2010 00:46:04 -0400

Changed in kdebase-workspace (Ubuntu Lucid):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

I'm afraid there's one more bit missing before we can safely enable plymouth to do a smooth transition to kdm. This bit from the gdm upstart job needs to be duplicated to the kdm job:

            case "${ARG}" in
                text|-s|s|S|single)
                    plymouth quit || : # We have the ball here
                    exit 0
                    ;;
            esac

Once this is done, we can add kdm to the rule in plymouth-stop.conf and declare a breaks on previous kdm versions.

Changed in kdebase-workspace (Ubuntu Lucid):
assignee: Alberto Milone (albertomilone) → nobody
status: Fix Released → Triaged
FreeMinded (pascal-planetmages) wrote :

Not sure if this is somehow related to this. When login in with kdm it takes several seconds after hitting enter for actually something to happen. The cursor keeps blinking as if the enter key wouldn't have been hit. After a few seconds only the login is precessed. It's nothing serious but somewhat anoying.
This is with Kubuntu Lucid updated daily. In Kubuntu 9.04 the problem does not exist. The login is processed immediatly after hitting enter.
In case this is totally unrelated, I'm glad to create a separate bug report and provide additional information.

Changed in kdebase-workspace (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.4.2-0ubuntu6

---------------
kdebase-workspace (4:4.4.2-0ubuntu6) lucid; urgency=low

  [ Jonathan Riddell ]
  * Add back and update kubuntu_12_kubuntu_homepage.diff to link to kubuntu.org
    (LP: #553530)

  [ Steve Langasek ]
  * Make the upstart job handle plymouth teardown in the text / single-user
    boot cases, finishing up kdm's support for a smooth plymouth transition.
    LP: #540177.
 -- Steve Langasek <email address hidden> Fri, 02 Apr 2010 15:13:23 -0700

Changed in kdebase-workspace (Ubuntu Lucid):
status: Fix Committed → Fix Released
Tadej Novak (ntadej) wrote :

I'm still experiencing this bug as written before:

"Leo Milano wrote on 2010-03-18: #1

I'll provide feedbback for this, I am running Kubuntu Lucid + KMS with a Radeon HD3450.

Right now, plymouth shows perfectly at shutdown. On boot up, though, it only pops up _very_ late (about a second before KDM loads), and it's only displayed for a fraction of a second.

Cheers!"

Scott Kitterman (kitterman) wrote :

Tadej,

The issue this bug was filed to address has been fixed. Please file a new bug. It is common for different root causes to have similar observable symptoms.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers