Monitor brightness can not be controlled by hotkeys

Bug #500613 reported by Hans Bakker on 2009-12-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KDE Base
Invalid
Medium
kdebase-workspace (Ubuntu)
Medium
Unassigned

Bug Description

Using Kubuntu 10.04
xserver-xorg-video-radeon 1:6.12.99+git20091125.0061c4db-0ubuntu1

In systemsettings, the Display Brightness Up and Down keys are correctly mapped to the corresponding actions (in systemsettings -> Keyboard & Mouse -> Global Keyboard Shortcuts; component: KDE Daemon).
When using PowerDevil or the brightness slider in the corresponding Plasma applet the brightness can be controlled.

However, the display brightness does not respond to the keys.

Monkey (monkey-libre) wrote :

I assign this bug to the udev package. Thank You for making Ubuntu better.

affects: ubuntu → udev (Ubuntu)
Changed in udev (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Please exercise the steps at https://wiki.ubuntu.com/Hotkeys/Troubleshooting to determine at which level your hotkey problems occur, and attach the collected information. Thanks!

Changed in udev (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in udev (Ubuntu):
status: Incomplete → Invalid
Hans Bakker (hansmbakker) wrote :

xev correctly recognizes the buttons as XF86MonBrightnessDown and XF86MonBrightnessUp.

In System Settings -> Keyboard & Mouse the display brightness keys are correctly recognized as brightness up and down when clicking "Custom key" for a random action and pressing those buttons.

This means that X11 and Qt do know that the buttons are pressed.

Probably the bug is in KDE, then?

Btw, this is a regression from Kubuntu 9.10.

Changed in udev (Ubuntu):
status: Invalid → Confirmed
Martin Pitt (pitti) on 2010-03-28
affects: udev (Ubuntu) → kdebase (Ubuntu)
Martin Pitt (pitti) on 2010-03-30
Changed in kdebase (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
Hans Bakker (hansmbakker) wrote :

At this moment when pressing the monitor brightness up or down key, KDE's monitor brightness OSD pops up, but the brightness does not change (display does not become brighter or less bright; the keys are assigned properly; I can control the brightness using the plasma PowerDevil applet)

Fortunato Ventre (voria) wrote :

Exactly the same behaviour here as Hans Bakker, on a Samsung NC10 netbook.

Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

affects: kdebase (Ubuntu) → kdebase-workspace (Ubuntu)
Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Invalid
Hans Bakker (hansmbakker) wrote :

I filed the report at KDE Bugzilla. As I currently don't have Kubuntu installed, unfortunately I have no way to test if it still exists.

Changed in kdebase:
status: Unknown → New
Geordi LaForge (develop-ipv7) wrote :

Same problem for me, added comment on the bug system of KDE.

Changed in kdebase:
status: New → Unknown
Changed in kdebase:
importance: Unknown → Medium
Changed in kdebase:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.