Latest HAL update in Lucid causes many problems with KDE.

Bug #491834 reported by Michael Marley on 2009-12-03
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
HAL
Fix Released
High
kdebase-workspace (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: hal

After the latest HAL update on my Kubuntu Lucid test box, KDE will not work correctly. Attempting to log on in KDM causes an Xserver crash. Logging on again works, but both kded and plasma-desktop crash, resulting in a non-functional desktop. Trying to log in to the "failsafe" desktop doesn't work either. I see the beginnings of a terminal window being drawn, but then an Xserver crash occurs. This occurs every time I attempt to log in failsafe. Reverting the HAL updates and reinstalling the previous version works around the problem.

description: updated
zigi (ziegleka) wrote :

i confirm this bug. How can I downgrade?

plasma-desktop crash information attached

Michael Marley (mamarley) wrote :

You have to go to the launchpad page for the older version, and manually download and install the debs of the older version. You don't need the -dev files.

affects: hal (Ubuntu) → kdebase-workspace (Ubuntu)
zigi (ziegleka) wrote :

Lucid: KDE 4.3.80 and Qt 4.6 problem persists

Michael Marley (mamarley) wrote :

This looks like it has been fixed upstream, so it should start working in Beta 2.

Changed in kdebase-workspace (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

Fix released and is building for lucid.

Changed in kdebase-workspace (Ubuntu):
status: Fix Committed → Fix Released
Michael Marley (mamarley) wrote :

This bug is not entirely fixed. Now, the X server crashes only on the first login attempt; all subsequent attempts are successful.

Changed in kdebase-workspace (Ubuntu):
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

The double-login issue is being tracked at bug 495100

Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Fix Released
Changed in hal:
status: Unknown → Fix Released
Yves Glodt (yglodt) wrote :

Can kubuntu also be run without hal now (as ubuntu)?

Removing hal still wants to remove kubuntu-desktop (as of today)

Jonathan Thomas (echidnaman) wrote :

Nope, but that's off-topic.

Yves Glodt (yglodt) wrote :

Should I file a separate issue for that (hal removal removes kubuntu desktop) ?

Jonathan Thomas (echidnaman) wrote :

Nope, KDE needs hal. There's nothing wrong with that.

Changed in hal:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.