Ubuntu

kwin doesn't honor xrandr --primary flag

Reported by Andrew M. on 2009-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase-workspace

Howdy All -
I've noticed on Karmic that I can't seem to hint to KDE which output to use as my "primary" (ie where my toolbar goes.)

I've got a Thinkpad T61 with:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

I have the bulit in LCD on LVDS1 and and an external monitor with VGA and DVI inputs.

If i connect *only* the VGA to my monitor and tell xrandr:
thinkpad ~ $ xrandr --output LVDS1 --auto --primary ; echo $?
0
thinkpad ~ $ xrandr --output VGA1 --auto --right-of LVDS1 ; echo $?
0
thinkpad ~ $ xrandr --output DVI1 --auto --right-of LVDS1 ; echo $?
0
thinkpad ~ $ xrandr --output LVDS1 --primary ; echo $?
0
KDE behaves properly - VGA is enabled, right of LVDS, and taskbar is on LVDS.

However, if I connect *only* DVI to my monitor and tell xrandr:
thinkpad ~ $ xrandr --output LVDS1 --auto --primary ; echo $?
0
thinkpad ~ $ xrandr --output VGA1 --auto --right-of LVDS1 ; echo $?
0
thinkpad ~ $ xrandr --output DVI1 --auto --right-of LVDS1 ; echo $?
0
thinkpad ~ $ xrandr --output LVDS1 --primary ; echo $?
0
KDE sends my taskbar over to the external monitor (which is wrong - it should have made internal LCD primary and kept the taskbar there), but screen geometry and positioning are correct.

this is on a Karmic 9.10 system, with versions:
armalota@armalota-thinkpad ~ $ apt-cache policy xserver-xorg-video-intel xserver-xorg-core libxrandr2 kubuntu-desktop kdebase-workspace-binxserver-xorg-video-intel:
  Installed: 2:2.9.0-1ubuntu2
  Candidate: 2:2.9.0-1ubuntu2
  Version table:
 *** 2:2.9.0-1ubuntu2 0
        500 http://software.linux.ibm.com karmic/main Packages
        100 /var/lib/dpkg/status
xserver-xorg-core:
  Installed: 2:1.6.4-2ubuntu4
  Candidate: 2:1.6.4-2ubuntu4
  Version table:
 *** 2:1.6.4-2ubuntu4 0
        500 http://software.linux.ibm.com karmic/main Packages
        100 /var/lib/dpkg/status
libxrandr2:
  Installed: 2:1.3.0-2
  Candidate: 2:1.3.0-2
  Version table:
 *** 2:1.3.0-2 0
        500 http://software.linux.ibm.com karmic/main Packages
        100 /var/lib/dpkg/status
kubuntu-desktop:
  Installed: 1.154
  Candidate: 1.154
  Version table:
 *** 1.154 0
        500 http://software.linux.ibm.com karmic/main Packages
        100 /var/lib/dpkg/status
kdebase-workspace-bin:
  Installed: 4:4.3.2-0ubuntu7
  Candidate: 4:4.3.2-0ubuntu7
  Version table:
 *** 4:4.3.2-0ubuntu7 0
        500 http://software.linux.ibm.com karmic/main Packages
        100 /var/lib/dpkg/status

Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in kdebase-workspace (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers