Ubuntu

kdeinit4: plasma-desktop takes 60-90% of CPU

Reported by Laurent Claessens on 2009-08-26
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

The process plasma-desktop uses most of time between 60 and 90% of my CPU when KDE is started.

In order to fix the situation (and make plasma-desktop use ~ 10% of CPU), the following works most of time
1. right click on the desktop
2. unblock widgets
3. re-block widgets

When it does not work, the fact to change the wallpaper fixes the situation (I'm using globe -> OpenStreetMap). Notice that re-changing the wallpaper to OpenStreetMap does not re-create the problem.

$ lspci |grep VGA
2:00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

I have the same problem with an Nvidia card on an other computer.

I am having the same problem. I usually just end up killing plasma-desktop and restarting it. This probably happens 10x throughout the day. I have not seen the same problem on my other desktop. This problem started when I upgraded to KDE 4.3.0.

$ lspci |grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

Laurent Claessens (moky-math) wrote :

Same problem with my other computer :
lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8300 GS] (rev a1)

Seems not to depend on the graphical card.

I would also like to add that this happens regardless if I enable desktop effects or not. And that the fix suggested above of "unlocking and then re-locking widgets" does not seem to do anything for me. How disappointing...

Andrea (adenatale) wrote :

It's the same for me, plasma-desktop process uses more and more CPU%, switching the widgets block works for a short time, now CPU temperature has reached 93°C... I've to switch to Gnome.

Richard Johnson (nixternal) wrote :

Confirming due to comments, however I do not have this issue. Is this reproducible in Karmic with KDE 4.3.1 at all? Thanks!

Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Laurent Claessens (moky-math) wrote :

I still have the issue with Karmic-Alpha (KDE). Precision : X takes a lot from the CPU in the same time. Typically 40-40 between X and plasma-desktop (total between 60 and 90%).

I'm willing to give more informations if one says what I have to do.

Here, in the north hemisphere, we are getting into the winter, thus the cooling problem of my laptop is going to be resolved by itself up to Karmic+1 ;)

Richard Johnson (nixternal) wrote :

Could you all please list the plasma applets you have running? I have a default desktop and everything seems fine here. Do I need to have my widgets locked before logging in?

Laurent Claessens (moky-math) wrote :

I'm performing some tests. Up to now, the fact to remove the "Note" applet seems to fix the problem in the sense that X is stabilized under 20% of CPU (it's in the same time more than the "normal" and much less than what I usually have) while plasma-widget stays at 0%, which is perfect.

However, I'm only speaking on the basis of a one hour experiment. I let you know tomorrow if removing the "note" applet is really a fix.

For the other question, yes, when I'm starting KDE, the applets are locked.

Laurent Claessens (moky-math) wrote :

I also have "View of a directory" (the one which is by default). This one does not seem to pose problem.
If my X goes again to 60% without the "Note", I will try to remove the "view of a directory" and putting back the "Note".

Since I don't know how to trigger the bug, I'm forced to test each combination separately and wait some hours before to be sure if a combination works or not.

Hi,
I'm also affected from this issue. On my desktop is enough to have 3 additional frame pictures: (default size, round corners, rotated, slide show from one directory jpg's weight ~5MB) For sure I put also Calendar applet (rotated as well)
KDE compiz effects launched.
After one cycle slideshow you can click right on desktop. There should be 3-4 seconds break (99% cpu usage) and will appear. In few minutes, the same slowness effect. Sometimes click in up right corner has similar symptoms.
If I remove picture frames, everything goes smoothly.
my desktop on attachment

Richard Johnson (nixternal) wrote :

I am testing combinations here as well without any luck thus far. Though by doing this, I have found other bugs though :) I will let you know if I find something. Thanks!

Laurent Claessens (moky-math) wrote :

Well ... The fact to remove the "Note" *seems* to make my X feel better. I still get 70% on X and 25% on plasma-desktop at start (with or without locking the applets). But when I "fix" the situation[1], I get 20%-0% (ok) and the bug it seems not to get back. That information has to be taken with some care.

Now I'm removing the "View of a directory". I have no more applets but the taskbar[2].

I would like to add that I'm using the theme Tania, which implies quite a lot of transparencies effects when Compiz is activated.

Can I get, in some way, a valuable information via gdb or something ? Please, feel free to ask the output of any command lines (other than sudo cat /etc/shadow ;) )

PS : Just to be sure to speak the same language : "applet", "widget" and "plasmoid " are three words for the same, or there is a difference ?

[1] In order to get back 20%-0%, I lock and unlock a certain amount of time, and at a certain point, by some magics, the CPU usage gets right. Sometime, the fact to open the DesktopSetting (by the right click) gives also back the 20%-0%.

[2] My bar contains : K menu, two clocks, the notification tray, the list of connected disks, the battery state, and a countdown (which stays at 00:00 most of time).

Laurent Claessens (moky-math) wrote :

It turns out that I was maybe too enthusiastic last time. Removing all the applets but the taskbar does not makes my situation any better.

However, I think that I found a quite reliable trigger for the bug :) :)
In the notification tray, I have some auto-hide (for example, I want to see the state of Kopete, but not my keyboard layout selector). That tray has a small arrow that toggle "hide/extend". The fact to click on the arrow in order to extend the view triggers the bug. When I make the click, I instantaneously get X -> 70%, plasma-desktop -> 20% of CPU.

Unfortunately, the fact to re-hide does not fixe the situation. It is also quite sure that there are many other triggers.

BTW, one should change the description of the bug because it is impacting X as well (and, in fact, much more) as plasma-widget.

aftertaf (david-wooffindin) wrote :

i have same issue on karmic.....

top shows these . . .
 2173 aftertaf 22 2 359m 59m 27m R 46.9 3.0 3:01.18 plasma-desktop
 1107 root 20 0 123m 39m 8016 R 21.5 2.0 1:56.79 Xorg
 2167 aftertaf 20 0 286m 43m 20m R 8.9 2.2 0:41.93 kwin

67% of CPU, with nothing running . . . .

I have no *exotic* plasmoid-widget-applets.

Same thing, changing desktop settings, playing around with the system tray notification popup settings etc, brings it down to reasonable levels.... (until it triggers again . . . . for reasons unknown)

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2217 aftertaf 20 0 166m 37m 21m S 5.3 1.9 0:15.94 yakuake
 1107 root 20 0 137m 44m 8384 S 5.0 2.2 2:55.35 Xorg
 2167 aftertaf 20 0 288m 45m 20m S 1.3 2.2 1:01.44 kwin
 2173 aftertaf 22 2 365m 67m 29m S 0.7 3.4 4:44.02 plasma-desktop

Each time I have seen this, I initially thought it was plasma. In my case, at least, plasma was showing as the culprit, but in fact it was the nsplugin viewer for flash causing the hiccup. I kill the plugin viewer for flash, and plasma would start behaving.

Can you test this and see if there is a nsplugin instance running at the time of the problme, and kill it and see if it fixes it? For me it does.

Laurent Claessens (moky-math) wrote :

I propose to write a list of triggers/fixes.

TRIGGER

* extend the notification tray to show the hidden icons (click on the small arrow) This always triggers the bug.

FIX

* right click on the desktop, then lock/unlock widgets several times
* right click on the desktop, then "Properties of the desktop" (works 1 time over 10)

@aftertaf Can you add your items to the list, by writing more explicitly what you mean by "playing around with the system tray notification popup settings etc,".
I'm interested in knowing your techniques to fix ... I desesperately need it ;)

Laurent Claessens (moky-math) wrote :

@Roderick B. Greening. Does it answer your question ?

19:23:02 ~ >$ ps aux|grep nsplugin
217:moky 11213 0.0 0.0 3052 812 pts/7 R+ 19:25 0:00 grep --color=always -n nsplugin

If so, the answer is no. I have no nsplugin running while my bug is present. In this precise case, I triggered the bug by extending the view of my notification tray.

Laurent Claessens (moky-math) wrote :

I found that the fact to modify the size of the panel sometimes fixes the bug. Also the fact to add a new panel and remove it makes X and plasma-desktop back to a natural use of CPU.

I append these into the list

FIXES

* right click on the desktop, then lock/unlock widgets several times
* right click on the desktop, then "Properties of the desktop" (works 1 time over 10)
* Add/remove a panel
* Change the size of the panel

btw, most of the other triggers/fixes are related to the size of the panel since when I unlock the objects, it adds the "plasma" logo on the right of the panel, and when I extend the view of the notification tray, I also implicitly modify the size and the content of the panel.

Laurent Claessens (moky-math) wrote :

Well guy, since this morning (18 of October), I have no more problems.
Please, don't close the bug : I still have to check on my other computer.

Moreover, I created yesterday night a second activity on which I put almost all my plasmoids... In particular, the notification tray, the connection manager and the battery state passed from my panel to the desktop of my second activity.

So, I dramatically changed the widget landscape of my desktop, and the bug seem to have disapeared in the same time.

John Dong (jdong) wrote :

Fully updated machine including the Kubuntu PPA still exhibits this in VMWare.

araknyd (domsinator) wrote :

Karmic Kubuntu with the latest kernel updates

lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4200] (rev a3)

ps aux --sort=+%cpu
user 1846 32.7 2.7 321144 14208 ? Rl Dec09 13:46 kdeinit4: plasma-desktop [kdeinit]
root 1480 37.0 2.7 42520 13880 tty7 Rs+ Dec09 15:47 /usr/bin/X -br -nolisten tcp :0 vt7 -auth /var/run/xauth/A:0-NjxuWa

doesnt seem to matter what i have running, CPU usage is always up with those two. i realize i have an old graphics card but within the recommended hardware. desktop bg is a plain colour, nothing fancy. have one panel with 5 widgets. default desktop effects and possibly less enabled. i do have KSensors in the tray to monitor CPU temp since i typically run near 100% usage causing heat issues. there was only one time when i noticed the CPU usage drop off which occurred right after a boot. as soon as i started an app the usage jumped back up and stayed there even after closing it. im not comfortable enough with linux processes to know which ones i can kill.

araknyd (domsinator) wrote :

ran kdeinit in a console and usage went down to near 15% system total. not sure what happened. output below.

kdeinit
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /home/araknyd/.DCOPserver_COSMIC-XPRESS__0
and start dcopserver again.
---------------------------------

KDE Daemon (kded) already running.
kbuildsycoca running...
Reusing existing ksycoca

araknyd (domsinator) wrote :

half a day later and CPU usage is still down, running at less than 50% and as low as 5% (lasts only a few seconds).

Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers