Ubuntu

Most simple plasma Ruby script does not run

Reported by Adrien Cordonnier on 2009-05-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

In Jaunty (9.04), when I try to run the most simple ruby plasmoid example from http://techbase.kde.org/Development/Tutorials/Plasma/Ruby/GettingStarted

The window widget displays the following error:
   This object could not be created for the following reason:
   Could not create a ruby-script ScriptEngine for the Hello Ruby widget.

It seems there is no Ruby bindings for Plasma nor any other scripting engines except Python (solved for Python by Bug 338996). In Debian Sid, the package is "plasma-scriptengine-ruby".

There should be "plasma-scriptengine-*" packages available (and automatically installed if needed) in order to be able to run plasmoids from the plasmoid installer.

I have found a solution by installing package libkorandum-ruby1.8 which gives Ruby binding for Plasma.

This package should be automatically installed if someone install a Plasmoid which requires it. Plasmoid can be installed with the "Get Hot New Stuff" Plasma tool without using a deb package manager.

1) Plasma should install libkorandum-ruby1.8 if "X-Plasma-API=ruby-script" is in the metadata.desktop installation file of the plasmoid (zip archive)
2) Plasma should install dependencies as stated in "X-KDE-PluginInfo-Depends=" in the metadata.desktop installation file.

affects: ubuntu → kde4libs (Ubuntu)
affects: kde4libs (Ubuntu) → kdebase-workspace (Ubuntu)
Harald Sitter (apachelogger) wrote :

I actually think that some dependency is missing, either on libkrossruby or libkorundum (i.e. the ruby stack is incomplete). The actual scripting engine is as a matter of fact built into the main kdebase-workspace package.

I started writing a plasmoid using ruby and didn't run into any problems, though I have the complete kde-ruby stack installed for sure :D

We probably should test on a new install what package is missing, so it can be fixed.

Austin Howard (magnesium) wrote :

I don't have the package libkorandum-ruby1.8 on my system (Kubuntu Jaunty, KDE 4.2.2). I think Adrien made a typo, because after installing libkorundum4-ruby1.8, Ruby worked in Plasma for me.

Richard Johnson (nixternal) wrote :

I am going to close this report due to the comments suggesting it actually does work with the correct packages installed. If this is not the case, then I urge you to please reopen this report with further information. Thank you!

Changed in kdebase-workspace (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers