KWin Desktop Effects Zoom function not working in Jaunty

Bug #367794 reported by Klaus S. Madsen on 2009-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Base
Unknown
Medium
kdebase-workspace (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kde-window-manager

When enabling desktop effects under KDE in Intrepid, I could zoom the entire desktop using the shortcuts Super+= and Super+-. However after upgrading to Jaunty, this no longer works correctly if the Compositing Type is set to OpenGL. It does work if compositing type is XRender, this is too slow to be usable.

The way it fails is this:

When I press Super+= nothing happens. However if I switch to another desktop and back, I will get the zoomed result. When this happens, moving the mouse does not pan the screen, so only the area immediately available can be seen. Pressing Super+- until the zoom-level reaches 1:1 will result in 1:1 zoom-level without switching desktop, however none of the steps before reaching 1:1 will result in visible changes to the zoom-level.

I'm using an Lenovo T61p with a NVidia Quadro FX 570M card. The NVidia driver version is 180.44.

Jonathan Thomas (echidnaman) wrote :

I can't reproduce this bug in KDE 4.2.2 in Kubuntu 9.04.
Is this still a problem for you in KDE 4.2.2?

Changed in kdebase-workspace (Ubuntu):
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

Oh, it worked in Intrepid, but not in Jaunty. (I just got a bit confused)

Changed in kdebase-workspace (Ubuntu):
status: Incomplete → New

I have just tried KDE 4.2.3 from ppa, and this problem still exists.

Just found out that zoom works, as long as I don't enable the "Blurs the background behind semi-transparent windows" effect. Whenever that is enabled, zoom stops working.

Jonathan Thomas (echidnaman) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugs.kde.org/show_bug.cgi?id=182817

Changed in kdebase-workspace (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in kdebase:
status: Unknown → Confirmed
Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: http://bugs.kde.org/show_bug.cgi?id=182817
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Invalid
Changed in kdebase:
status: Confirmed → Invalid
Changed in kdebase:
status: Invalid → Unknown
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.