kwin does not run due to kwin-kde4 package being installed following upgrade from intrepid to jaunty

Bug #367474 reported by Fraser Campbell on 2009-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kde-window-manager

Following upgrade from interpid to jaunty kwin would not run because /usr/lib/kde4/kwin3_oxygen.so could not be loaded. I investigated and found that kwin-kde4 package was installed. I notice that kwin-kde4 and both supply this library ... my kwin-kde4 was obviously outdated (version 4:4.0.3-0ubuntu2) so I purged it and reinstalled kde-window-manager, this resolved issue.

I have 3 lines in /etc/apt/sources.list they are as follows:

deb http://archive.ubuntu.com/ubuntu jaunty main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu jaunty-security main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu jaunty-updates main restricted multiverse universe

I upgrade with "apt-get dist-upgrade". My system has been upgraded through several ubuntu releases and I have few (in fact I think no) non-ubuntu packges installed.

Further my system crashed (power failure) during upgrade so I'm not sure if that may have impacted ... still though I did have "apt-get dist-upgrade" reporting cleanly and all packages configured (dpkg --configure -a) while this issue was occurring.

So ... I'm not sure why kwin-kde4 was not automatically removed (I had also done several "apt-get autoremove" to get rid of non-required items).

Richard Johnson (nixternal) wrote :

Hey Fraser, I apologize that nobody got to this issue sooner. Are you by chance still experiencing this issue? Were you able to recover from it? If so, you were lucky. I lost power during a major upgrade and it hosed way to much for me to spend so much time fixing :) Thanks!

Changed in kdebase-workspace (Ubuntu):
status: New → Incomplete

No problem, yes I fixed it ... just purged the offending package I
suspect, though it's too long ago for me to recall ;-)

Richard Johnson wrote:
> Hey Fraser, I apologize that nobody got to this issue sooner. Are you by
> chance still experiencing this issue? Were you able to recover from it?
> If so, you were lucky. I lost power during a major upgrade and it hosed
> way to much for me to spend so much time fixing :) Thanks!
>
>

Richard Johnson (nixternal) wrote :

Thanks for the quick reply. In the mean time I will go ahead and close this report, however if the issue ever surfaces again, then please feel free to reopen this report. Thanks again!

Changed in kdebase-workspace (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers