KDE4: resizing panel fails with fast mouse movements

Bug #367390 reported by Alan Jenkins on 2009-04-26
2
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
kdebase-workspace (Ubuntu)
Low
Unassigned

Bug Description

Here's the most reliable way to demonstrate this:

- First resize the panel so it's nice and big.
- Now resize it by clicking on "Height" (or "Width") as normal, and dragging the mouse all the way to the screen edge in one smooth motion.

Expected result: panel shrinks to the minimum possible size
Actual result: panel only responds to the first mouse event, which shrinks it slightly. By the time it has redrawn itself fully, my mouse cursor has reached the bottom of the screen. The panel does not shrink to the minimum possible size.

It looks as if the panel drops the mouse events which occur while it is being redrawn.

ubuntu@ubuntu:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
ubuntu@ubuntu:~$ apt-cache policy kdebase-plasma
kdebase-plasma:
  Installed: 4:4.2.2-0ubuntu4
  Candidate: 4:4.2.2-0ubuntu4
  Version table:
 *** 4:4.2.2-0ubuntu4 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Changed in kdebase:
status: Unknown → New
affects: kdebase (Ubuntu) → kdebase-workspace (Ubuntu)
Changed in kdebase-workspace (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in kdebase:
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: http://bugs.kde.org/show_bug.cgi?id=190721
Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Invalid
Changed in kdebase:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.