"Set date and time automatically" doesn't work

Bug #367164 reported by Martin on 2009-04-26
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Low
Harald Sitter

Bug Description

Binary package hint: kdebase-workspace

When I check "Set date and time automatically" in systemsettings, that will set the time and date that one time, but the next time I open systemsettings, the option is always unchecked again.

Is this thing supposed to adjust date&time automatically in regular intervals? With ntpd?

If it's not, the labeling and the interface with the checkbox is misleading and should be changed (like from a checkbox to a button). That would make it more clear that what you're doing is a one-time synchronization, not setting the system up to undergo regular synchronization with a time server.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: systemsettings 4:4.2.2-0ubuntu2
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: kdebase-workspace
Uname: Linux 2.6.28-11-generic x86_64

Martin (lodp) wrote :
Tim Makarios (tjm1983) wrote :

This behaviour also surprised me. Kubuntu Jaunty i386.

Martin (lodp) on 2009-05-20
Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
KIAaze (zohn-joidberg) wrote :

Bug still present in Kubuntu 9.10 Karmic.
Is there any known workaround like starting the ntp daemon manually?
I installed the ntp package and it looks like it is set to start automatically (/etc/rc2.d/S23ntp file), but the checkbox in system settings for automatic time synchronization still isn't checked after starting it.

TrReardon (tr-reardon) wrote :

Still broken in Lucid.

Changed in kdebase-workspace (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → Low
Russell Lewis (russlewi) wrote :

I'm having this issue as well. The UI will also let me type in a custom NTP server, and appears like it will work, but the setting does not persist. It is interesting however, that it WILL set the time once this way. Attached is what the UI looks like when I set the time using a custom ntp server. If I go back to the Date and Time settings, "Set date and time automatically" is unchecked, and the custom NTP server is gone and the box is greyed out. I need to use a custom NTP server because our silly firewalls block external NTP.

Russell Lewis (russlewi) wrote :

Looking closer at the messages in my screen shot, you can also notice that the "Server" description isn't exactly correct in my case.

Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Fix Committed
Russell Lewis (russlewi) wrote :

Cool, thanks for fixing this Harald! Is there any testing I can do to help?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.4.2-0ubuntu7

---------------
kdebase-workspace (4:4.4.2-0ubuntu7) lucid; urgency=low

  [ Harald Sitter ]
  * Dont hide klipper from menu, otherwise users will find it diffcult to
    get it back if accidently the autostart was turned off.
  * Drop kubuntu_71_default_plasma_layout.diff in favor of plasma-desktop
    init script in kubuntu-default-settings
  * Add kubuntu_01_fix_dateandtimekcm.diff from upstream to fix a whole
    set of funny bugs in the date&time KCM, amongst them LP: #367164
  * Add kubuntu_02_screensaver_restricted_install.diff to recommend installation
    of kscreensaver package via k-n-h (LP: #273667)

  [ Jonathan Thomas ]
  * Add kubuntu_112_kdm_multiscreen_fix.diff, backported from upstream's 4.4
    branch. Can be dropped in 4.4.3.
  * Add kubuntu_113_kmenuedit_folder_move_fix.diff, a backport of two off-by
    one error fixes that makes moving folders in kmenuedit actually work
  * Add kubuntu_114_respect_screensaver_settings.diff from the upstraem 4.4
    branch that only enables the screensaver if it is enabled in the settings
  * Add kubuntu_115_read_compositing_settings.diff. Backport of kde svn
    revision 1109537. Fixes a crash when compositing is forced in the
    environment variables
  * Add kubuntu_116_oxygen_cursor_fix, a backport of several commits in
    B.K.O 231844. Prevents the cursor from turning into a vertical resize
    cursor after you move a window. Can be removed in 4.4.3.

  [ Jonathan Riddell ]
  * Update kubuntu_98_dbusmenu.diff from Aurelien Gateau (LP: #553685)
 -- Jonathan Riddell <email address hidden> Thu, 08 Apr 2010 15:50:34 +0100

Changed in kdebase-workspace (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers