Desktop effects fail even though 3d works everywhere else

Bug #366843 reported by Shaved Wookie on 2009-04-25
6
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase-workspace

Hi there,

I've had this bug since the beta FGLRX drivers first let me have 3d at all on Jaunty, but didn't report it before as I figured it was just a beta driver thing (they have been replaced with the final by now haven't they?).

Anyway here's what happens:

If I enable Kwin's Desktop Effects (even with none of the effects selected) it goes through the following steps:

1. The screen blanks to nothing but the Plasma wallpaper and mouse pointer for about 10 seconds.
2. It flashes back to my normal desktop for about 1/2 a second.
3. Repeat of step 1.
4. Repeat of step 2 and then for 1/2 a second I see the desktop with no desktop effects, but window decoration faulty, mainly just showing dark boxes where window decoration should be. Sometimes Plasma will die at this point (with the taskbar etc. disappearing). Sometimes a pop up appears saying "Failed to activate desktop effects with the current configuration".

Then it goes back to my normal desktop with Desktop Effects turned off.

It does this with 100% reproducability.

lsb_release gives:
Description: Ubuntu 9.04
Release: 9.04

apt-cache policy kdebase-workspace
kdebase-workspace:
  Installed: (none)
  Candidate: 4:4.2.2-0ubuntu2
  Version table:
     4:4.2.2-0ubuntu2 0
        500 http://archive.ubuntu.com jaunty/main Packages

ProblemType: Bug
Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: kwin None [modified: /var/lib/dpkg/info/kwin.list]
ProcEnviron:
 LANGUAGE=
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: kdebase-workspace
Uname: Linux 2.6.28-11-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package

Shaved Wookie (shavedwookie) wrote :
Shaved Wookie (shavedwookie) wrote :

I don't know what's with the "This is not a genuine Ubuntu package" thing. I installed from the standard live CD (albeit before the final Jaunty release). I only used stuff from the repo's and update daily at least.

mjames (mcj210) wrote :

I am getting this bug, too, with it exhibiting exactly the same behavior. I am using Kubuntu 9.04 desktop/amd64 with the fglrx driver (on an ATI 3850). I, too, can repro it 100%, and it makes the Desktop Effects unusable.

I have a second machine running Kubuntu 9.04 desktop/32-bit on an NVIDIA Ti4200, and the problem is not present there; the Desktop Effects seem to work fine.

Richard Johnson (nixternal) wrote :

The reason for the genuine package thing I think is because the drivers are the binary versions from ATI. Anyways, does this issue still occur, specifically on Karmic? I though ATI/Radeon/FGLRX was golden with KDE4. It is funny you say no problems with NVIDIA because my old work machine would not run KDE4 at all, but the laptop with Intel ran it fine and my other desktop with FGLRX ran it fine, though that was about a year ago now.

Anyways, anyone else still experiencing these issues with the latest KDE? 4.3.1 (4.3.2 soon in Karmic) or such? Thanks!

Changed in kdebase-workspace (Ubuntu):
status: New → Incomplete
Shaved Wookie (shavedwookie) wrote :

Thanks for asking.

Seems to work like a dream now in my beloved KDE 4.3.1 (my
 precioussssss) +fglrx 2:8.660-0ubuntu2 . Windows are now wobbling with
 the best of them.

 Huzzah.

Jonathan Thomas (echidnaman) wrote :

Yay. \o/

Changed in kdebase-workspace (Ubuntu):
status: Incomplete → Fix Released
Shaved Wookie (shavedwookie) wrote :

Yee Har! :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments