ksmserver crashed with SIGSEGV in HalPower::slotDeviceRemoved()

Bug #328535 reported by Vítor E. Silva Souza on 2009-02-12
4
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
kdebase-workspace (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kdebase-workspace

1) vitor@seattle:~$ lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

2) vitor@seattle:~$ apt-cache policy kdebase-workspace
kdebase-workspace:
  Installed: (none)
  Candidate: 4:4.2.0-0ubuntu4
  Version table:
     4:4.2.0-0ubuntu4 0
        500 http://it.archive.ubuntu.com jaunty/main Packages

3 + 4) I removed my wireless mouse from the USB and KDE crashed, returning to KDM.

ProblemType: Crash
Architecture: i386
Disassembly: 0x24:
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/ksmserver
Package: kdebase-workspace-bin 4:4.2.0-0ubuntu4
ProcCmdline: ksmserver
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: kdebase-workspace
StacktraceTop:
 ?? ()
 HalPower::slotDeviceRemoved ()
 HalPower::qt_metacall ()
 QMetaObject::activate () from /usr/lib/libQtCore.so.4
 QMetaObject::activate () from /usr/lib/libQtCore.so.4
Title: ksmserver crashed with SIGSEGV in HalPower::slotDeviceRemoved()
Uname: Linux 2.6.28-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:?? ()
HalPower::slotDeviceRemoved (this=0x8c2aef8, udi=@0x8b7cfb0)
HalPower::qt_metacall (this=0x8c2aef8,
QMetaObject::activate () from /usr/lib/libQtCore.so.4
QMetaObject::activate () from /usr/lib/libQtCore.so.4

Jonathan Thomas (echidnaman) wrote :

Report sent upstream. It is possible that this is a duplicate of bug 293126. If this crash happens or happened regularly, could you test with the latest updates to see if this is fixed? (If it never happened with any regularity it will be hard to tell whether or not this is fixed.)

Thanks!

Changed in kdebase-workspace:
importance: Undecided → Low
status: New → Triaged
Changed in kdebase:
status: Unknown → Confirmed

It's been a while that I haven't got this problem... Updates since then probably fixed the issue. Here's my current config (Kubuntu Jaunty):

vitor@seattle:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

vitor@seattle:~$ apt-cache policy kdebase-workspace
kdebase-workspace:
  Installed: (none)
  Candidate: 4:4.2.2-0ubuntu2
  Version table:
     4:4.2.2-0ubuntu2 0
        500 http://it.archive.ubuntu.com jaunty/main Packages

vitor@seattle:~$ uname -a
Linux seattle 2.6.28-13-generic #44-Ubuntu SMP Tue Jun 2 07:57:31 UTC 2009 i686 GNU/Linux

Thank you!

Jonathan Thomas (echidnaman) wrote :

Cool, I think we can mark this as fixed then.

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Fix Released
Changed in kdebase:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.