ksmserver crashes

Bug #317983 reported by Stefan Bader on 2009-01-16
4
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Medium
Unassigned

Bug Description

Kubuntu 9.04 20090116-daily (amd64)
kde-base-workspace-bin 4.4.1.96-0ubuntu3

Live session starts and reports the crash of ksmserver. Menu options from the bottom bar only display a border with no content. Trying to upload the crash report will seem to do something but then fail with <urlopen error: the read operation timed out>

ksmserver crashed with SIGFPE

StacktraceTop:
QPainter::drawTiledPixmap()
  ?? () from /usr/lib/libplasma.so.3
  ?? () from /usr/lib/libplasma.so.3
  Plasma::FrameSvg::paintFrame()
  ?? () from /usr/lib/libkdeint4_ksmserver.ko

Scott Kitterman (kitterman) wrote :

What version of plasmoid-quickaccess do you have installed?

> What version of plasmoid-quickaccess do you have installed?

0.7.1-0ubuntu5

Scott Kitterman (kitterman) wrote :

Thanks. That cancels a theory I had.

Stefan Bader (smb) wrote :

Ok, for now I did check the CD: passed
memtest86: ok

I repeated the test and it seems there are actually two things. First a crash of nepomukservicestub.

Stefan Bader (smb) wrote :

Window manager seems to act quite sluggish. I logout and login again and get the second crash report (of ksmserver).
When I delete the crash files and logout/login again. There is no new report. But all the times whenever I try to open the application launcher (tooltip looks ok) I get a frame with transparent empty content.

Stefan Bader (smb) wrote :

Adding the Xorg.log (not sure this is info that is contained in the crash reports.

Jonathan Thomas (echidnaman) wrote :

The nepomukservicestub crash is bug 284331, that much I know. ;)

Harald Sitter (apachelogger) wrote :

Is this still reproducable with a current live image? http://cdimage.ubuntu.com/kubuntu/daily-live/current/

If so, please install kdebase-workspace-dbg and get new backtraces, the current ones are missing debugging symbols and aren't of much use due to this.

Stefan Bader (smb) wrote :

The daily image 20090118 still shows the two crash reports, however the system
is now useable. All the menu frames which only showed nothing before, now have
content and are usable.
Since the errors were the same with an installed instance, I will now reinstall
the system and add the debug package before actually launching the desktop.

Stefan Bader (smb) wrote :

This is the ksmserver crash report from the installed system. This is happening only when leaving kde (e.g. selecting restart or shutdown from the menu). In those cases (restart / shutdown), the requested operation is not performed but kdm restarts and presents the login prompt.
I also got an updated nepomukservicestub crash report but perhaps it would be better to add it to bug 284331?

Changed in kdebase-workspace:
importance: Undecided → Medium
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers