Ubuntu

KDM is killing my keyboard (and others)

Reported by Edmundo on 2008-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-workspace (Ubuntu)
Undecided
Unassigned

Bug Description

Well.... what started as a problem with the keyboard and not being able to start compiz as different bugs ended up being related (apparently) to kdm.

When I get to kdm, all things are OK. I can write "@" (altgr + q) and can move the cursor with the keys. Also, on the VTs, everything is OK.

When I log into kde by kdm (kubuntu intrepid on a Presario V3317la with the Nvidia driver) the arrows don't work at all and altgr behaves like <intro>. Also, Compiz doesn't get to start... and that's because I didn't get DirectRendering activated (according to glxinfo). Also I always get a message about an application crashing detected by kde4d. All things apparently unrelated.

Now.... the thing that is bothering me the most is the keyboard, so I started testing. I shutdown kdm and started kde by hand:

sudo /etc/init.d/kdm stop
X &
DISPLAY=localhost:0.0 startkde

When i did this, I got to KDE as usual, but:
1 The keyboard is working perfectly
2 I got no error about any application crashing on the startup
3 Got DirectRendering working and could start compiz by hand: compiz --replace

Any idea of how I can solve it?

Thanks!

Jonathan Thomas (echidnaman) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Kubuntu release? Thanks in advance.

Changed in kdebase-workspace (Ubuntu):
status: New → Incomplete

I haven't seen this anymore. Not using that box anymore (and I think
it solved after reinstalling anyway... did I hate doing that). So I
guess you can close it.

Jonathan Thomas (echidnaman) wrote :

Thanks. Sorry it took so long to get a response.

Changed in kdebase-workspace (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers